[Guide] Install Intel Wireless Drivers on Linux

This took me a bit of research to figure out so I thought I’d share this guide for installing the wireless drivers on Linux.

This will require a computer with an existing internet connection or for you to connect to the network via a USB->Ethernet adapter.

This guide assumes you are using the Intel 6E Wireless chip sold with the Framework laptop, though this will work for other Intel wireless chips as well.

  1. Go to the Intel Linux Driver Downloads page.
  2. Download the appropriate driver for your card. The one that comes with the Framework laptop is the Wi-Fi 6 AX210. Don’t mind that it is lacking the E.
  3. Download and extract the files in the tarball to your downloads folder or other location.
  4. Open your terminal and cd into the directory containing the files you just extracted.
  5. Run this command. Replace XX with the version number of your driver (or just use tab autofill):
    sudo cp iwlwifi-ty-a0-gf-a0-XX.gcode /lib/firmware
  6. Reboot your laptop.

When you sign in next time, you should now notice the Wi-Fi symbol in your system tray. Connect to your wireless network.

If you have any issues, please reply to this thread and I’ll do my best to help you.

See also: Using the AX210 with Linux on the Framework Laptop


Does this allow for working bluetooth on the latest linux kernel as well?

@Anthony_Powell Sorry for the delay in getting back to you. I just tested by connecting my dad’s Sony WH-1000XM4 headphones to my laptop via bluetooth. Audio sounds great and it connected without issue.

1 Like

@Foxtrek_64 thx for this post!
I did as u wrote.
Cept the file I found is not a “Gcode”, but a “Ucode.”
I can LS it in /etc/firmware/
Its there.
But after booting still Wi-Fi symbol/
All ideas welcome!

I am having the same issue. I spent a few hours yesterday trying to figure this out but I am still pretty new to Linux so have not had any luck yet. If I figure things out or find a more detailed guide I will share.

So I am waiting on my preordered WD SN750SE which is supposed to be delivered on Monday but have been live booting with Kali and realized I was being stupid and not using live with persistence so everything I was doing was getting wiped out after each reboot and I didn’t notice it till this morning.

Hi @Sifu

What is the reason you’ve put firmware under /etc/firmware path instead of the /lib/firmware?
Usually the default location is the /lib/firmware and you copy firmware using: cp iwlwifi-ty-a0-gf-a0-59.ucode /lib/firmware or sudo cp iwlwifi-ty-a0-gf-a0-59.ucode /lib/firmware command.
Have you modified your kernel to look for the firmware under different path or are you using some specific distro that has custom path configured for firmware and set to the /etc/firmware?

If it’s just a wrong path used by you, could you please try and sudo cp iwlwifi-ty-a0-gf-a0-59.ucode /lib/firmware ? Just reboot after this and it should work. Please note, the kernel version supported by this firmware is 5.10+.

P.S. Also, if you are using Ubuntu LTS revision, please do this step as well( additionally to the step mentioned above):

I will quote it here:
sudo mv /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.bak
This is required to ensure the stock firmware is not used instead of the new shiny Intel firmware.


Hi, I have the WiFi: Intel® Wi-Fi 6E AX210 No vPro® and downloaded the Intel® Wi-Fi 6 AX210 160MHz 5.10+ iwlwifi-ty-59.601f3a66.0.tgz from the site you posted.

I am using Ubuntu 20.04.3 LTS for my os and I believe I installed the nic correctly. I connected the wires to match what was on the nic. I ensured the nic was seated all the way into the motherboard.

I did the command copy command to the /lib/firmware directory and restarted but still not able to detect the nic.

I also added the file to /usr/lib/firmware but still no luck.

Thanks in advance.

Edit: Nvm, I was able to get it to work by using the " sudo mv /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.bak" but for my version of firmware. Thanks to user before me

Thanks for posting these directions. I performed them as stated except for using .ucode instead of .gcode (because that’s what the file was named when I downloaded the tarball and unpacked it) and rebooted but I’m still being told no network devices available.

I know the wifi card is working because I had previously installed Windows 10 for a quick and dirty check of the functionality before loading Mint 20.2 MATE. Afraid I haven’t kept up with Linux distributions over the last 15 or so years but I felt the Framework was the perfect platform to start back up again.

I followed the guide using the ucode and it worked perfectly for me! I’m on Fedora 35, and my WiFi stopped working after latest kernel update, but this brought it back. Thanks @Foxtrek_64

1 Like

Has anyone been able to get this to work with kali? I moved the new driver over to /lib/firmware and disabled the default all fine. I am able to see networks only after turning wifi off and back on in the setting and cannot connect to any. Any thougths?

Most distro’s should handle this automatically for you I would think.

e.g For Arch, there’s a linux-firmware package that contains the drivers for just about everything.

i have Intel® Wi-Fi 6 AX200 , how do i know the version of my driver , can u write that command line in the 5 step for me ( im Linux beginner and my english is not good sorry ) , have been stuck with no wifi adapter found for 3 days

@Kayden Once you have downloaded the driver in step 2, you’ll want to unpack the files from the tarball. You can think of this as being the same as extracting files from a .zip or .rar file, though the instructions vary based on which distro you choose. You’ll want to find instructions on how to do this for your specific distro.

As for step 5, Linux’s command line parser is smart. If you start typing the file name you want, then press tab, it will autofill with the name of the file or directory. I assume regardless of what Intel driver you download, the name will start with iwlwifi even if version numbers and such are different. So I would type sudo cp iwlwifi and then press tab. If it selects the wrong thing, press tab again. Eventually it’ll end up with the driver file typed out for you in the command line. Then you can just hit space and add on /lib/firmware and you’re good to go.

1 Like

I also could not install ucode drivers on fedora. That is what worked for me:

sudo rm /lib/firmware/iwlwifi-ty-a0-gf-a0-59.ucode <<name of a driver you installed.

sudo dnf install iwl7260-firmware

And reboot.

From there:

1 Like

@NoneenoN Glad to see these firmware drivers have finally been added to the dnf package source. When I wrote my original post, this was not yet the case. The steps you provided should be the preferred way to install these drivers on Fedora (and RHEL/CentOS/Rocky) moving forward.

I have the framework laptop with the AX210 card and am running Ubuntu 21.10 which runs a 5.13 kernel. The WiFi was working previously but, for some unknown reason, stopped working today. I’m pretty sure there were no system updates involved b/c my daughter uses the laptop and does not have sudo permissions.

I ended up downloading the most recent .tgz from the tags at: kernel/git/firmware/linux-firmware.git - Repository of firmware blobs for use with the Linux kernel

Extracting all the files in the archive, I then:

  • Copied all the iwlwifi-ty-a0-gf-a0-* files to /lib/firmware/
  • Shutdown & restarted (as opposed to rebooting, which I understand may cause warm boot issues that cause the new firmware to not be loaded)

That brought WiFi back for me.

To get wifi working on Kubuntu 20.04, I had to download the drivers onto a USB as suggested by OP, insert the USB into framework, and then after reading this thread I ran these commands.

cd /media/AC2D-0233/
tar -xf iwlwifi-ty-59.601f3a66.0.tgz
cd iwlwifi-ty-59.601f3a66.0
sudo cp iwlwifi-ty-a0-gf-a0-*.ucode /lib/firmware
sudo mv /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.bak

Then, the first thing I did was update and upgrade with apt, and reboot. I was again greeted with no WiFi. I just had to rerun the mv command so the default firmware wouldn’t be used. Seems like upgrading created the /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm file again.

sudo mv /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm /usr/lib/firmware/iwlwifi-ty-a0-gf-a0.bak
sudo reboot now

The command above fixed it again after the upgrade. Maybe worth checking if that file has been recreated if you lose WiFi between boots, especially after an upgrade. Thanks for all the info here!

1 Like

Thank you all, copying the wifi libraries to /usr/lib/firmware/ worked perfectly, much easier than I expected

Anyone here having a very unstable WiFi-6 (ax) connection?

Doesn’t matter the distro… Every few minutes I lose connectivity and I’m starting to lose my cool…

Doesn’t happen in Windows and been looking for any post on the internet about issues with WiFi 6 and I find none.

Other laptops I have work flawlessly so… I’m guessing it’s this bloody AX210 card…