Memory compatibility FW 13 AMD Ryzen™ 7040U series DDR5-SODIMM-5600MT/s

@Kyle_Reis, Makes sense to me.

I do find this pnp kid from topic start at

I got a Kingston KF556S40IBK2-32 Kit lying on my desk and I’m just waiting to get the upgrade mainboard and will report back here.

I’m in batch 1.


I got this kit KF556S40IBK2-64 Kingston Technology Fury Impact 64GB (2x32GB) 5600MT/s DDR5 CL40 defaulting to 5600 MT/s without having any problem with XMP advertised on the package.
So far so good !


Seems to be running at the correct speed!


framework 13 DIY, with amd, 7840U, works with 2modules of the following brand / model:

crucial DDR5 5600 SO-Dimm, 1.1volt, cl46
Crucial CT48G56C46S5

just assembled the DIY AMD edition and fired up the bios/POST sequence only, it shows the 96GB total ram. probably usable :wink: dont have time for much more atm.

amazon/ASIN is: B0C79T2CP7


meanwhile: i have finished at least one round of memtest+ ( with the full 96GB ram installed. it tested all fine, and has real high transfer speeds (59.6GB/s)

memtest86+ screen after the first successful pass: openSUSE Paste (image link valid for 3months)

real life usage of this system with linux: opensuse leap 15.5 KDE live iso image boots and runs just fine. so does some gparted iso distro (partitioning, tools etc.)

  • gparted-live-1.5.0-1-amd64.iso
  • openSUSE-Leap-15.5-KDE-Live-x86_64-Build10.117-Media.iso
  • nixos-gnome-23.05.2975.a16f7eb56e88-x86_64-linux.iso

tried these three booting fine from a ventoy usb stick just fine (secureboot disabled in bios/uefi)

p.p.s: after several weeks I can report I dont have yet any problems of instability or anything at all, 2x 48GB ram (96GB total) works perfectly normal and just fine. linux system that is.


Did you know that you can add the ventoy key to the Bios and keep the secure boot loader ? I don’t know for opensuse but Fedora/Ubuntu publish with their own key signature that is recognised by modern bioses, so you can stay secured the whole process.
See the following page, and look at the gif. It’s really easy !

1 Like

i guess I know… MOKenroll MOKutil and what not. didnt bother to go down the road for enrolling own keys and stuff. i dont really like secure boot and uefi and all actually ;p

were you able to run it at any higher speeds? my mainboard arrived as an upgrade to my 11th gen fw13, but I was waiting for a deal on RAM that can be overclocked a bit

No I did not tried to change anything since I’m not really interested on overclocking. The performances so far on my usages (and some gaming on NMS) are really good. Way better than my 3years old desktop workstation (3800X, 32Gb DDR4, 1060 GTX 6Go).

Received my 7840U motherboard today and successfully upgraded my 1165G7 board.

I can confirm that the G.Skill 64GB kit here works at the rated 5600 MT/s and 46-45-45-89 timing.


Anyone run it at 6400MT/s ?

You can’t, the max is 5600 mhz as per AMD’s spec sheet.

1 Like

So you’re saying that there’s no overclocking on memory speeds available in the current iteration of the Zen 4 mainboard?

Yeah. If you want higher speeds, you need soldered memory.

Thanks so much! i was going for a 2x16 kit from this product line. Im so glad to hear it works!

1 Like
in order to keep upgradeable sodimms framework was stuck with the limit of the cpu from amd’s spec sheets

Has anyone tested this kit yet?

G.Skill Ripjaws 64GB Kit DDR5-5600 CL40 (F5-5600S4040A32GX2-RS)

Even if you have faster memory modules, the framework BIOS available to consumers doesn’t allow for timing tuning (e.g. no user-define CAS).

Someone on reddit said a few days ago that was working fine.