Missing drivers can't install windows

i am misisng bios on windows install, help

Would you be able to take a picture of the screen you are seeing?

When booting up the laptop if you keep pressing F2 does it bring you to a menu with different options?

sorry i mean drivers i am missing the drivers need to install windows

Ah, gotcha.

The driver bundle for windows can be found on this page but if you are hitting that error where Windows 11 will not let you continue because the wifi driver is not working you might try this method that lets you skip the internet connection and Windows 11 sign in. You can transfer the driver bundle via usb, install it, and after a restart proceed as normal.

how do i install drivers if i cant click on .exe file because i dotn have windows

Do you have an SSD installed in your Framework laptop and access to another computer with a free USB port?

yes i do

image

this is the screen im stuck at

After a quick search for things I am seeing a variety of fixes people found for this. Has the drive you are installing to ever been used in another system? I am seeing some people who had issues with ext4 drives used in Linux having problems until they reformatted the drive to ntfs. How did you create the installation media? I am finding some people who had problems with installation until they tried using Rufus to create the installation media and then this problem went away for them.

the drivers are only in the form of .exe from framework and i need to figureout how to make them into a format that windows installer recognizes

i use rufus to create the widows instaltion

It is a bit jank but if it were me I would use Rufus to create a live bootable Windows or Linux USB, format the drive to ntfs, and then create another normal installation media and proceed from there.

What drivers are you trying to install? Other than wifi, which you don’t need if you follow the instructions, there shouldn’t be any needed.

1 Like

I’ve seen this before when the windows install needs drivers for the installation media. Try a different flash drive and plug it directly into the laptop (no usb hub or docking station).

@Cobe_Alberici - can you try using our guide here to install Windows? You’ll want to make sure you have a thumb drive! Windows 11 Installation on the Framework Laptop 13 (AMD Ryzen™ 7040 Series) - Framework Guides

Note this is a similar screen that you can get at when the Windows installer does not see ANY drives to install on. Check your NVMe is showing up correctly in the BIOS.

(This was a legacy step because older server systems were known to never have the disk controller drivers pre-loaded because they were custom chipsets or not widely available. The operating system gave you the option to load controller drivers and then check again for sources to install the operating system in.)

Not all NVMe drives are the same FYI, I tried repurposing an NVMe drive from an XPS 15" Dell machine and it will not show up under the Windows installer no matter what I do. I can put the same drive in an external enclosure and it shows up on every system I throw at it.

I solved it, the issue was with downloading the iso. Winraw was turning it into a zip. And rufas didn’t work with that so I I had to delete winraw

2 Likes

I’m happy to hear that the issue is resolved now! Do you mind if we update the name of the thread with [RESOLVED] ?

Some NVMe drives are SATA, not PCIe, but some external enclosures are clever and can handle either type.