Missing Drivers from Driver Bundle

Hey All,

First post here so hopefully someone can help me with my new Framework 16 Ryzen 9 7940HS 16inch laptop. Am I correct in assuming I have just bought a laptop and we don’t even have drivers for it. I have looked at this page BIOS and Drivers Downloads (frame.work) and it doesn’t have this laptop listed.

In Device Manager I have 5 devices missing drivers and can’t seem to locate them. I have tried directly the AMD Driver Installing, installing the package a couple of times, attempted it both on Windows 10 and Windows 11 all with no luck.

Any help appreciated.


P.s. The missing drivers are like PCI Device or Unknown Device.

Hi Jeff!

There is a driver bundle for the Framework 16 - Framework Laptop 16 BIOS and Driver Releases. Make sure you are using Windows 11.

Here is the main knowledgebase for the Framework 16 - Framework Laptop 16 Knowledgebase.

Hopefully this helps!

Hey Bulletz,

Yes that link is for the 7040 not the 7940 series.

I have used that bundle in Windows 10 and Windows 11 without success. After completing the bundle installation, I still have the missing devices.

Screenshot 2024-05-08 134815

Do you know where the link is for the 7940 series? Or where the drivers are for these missing devices?




For the Framework 16, if you are wanting to use Windows; Windows 10 is NOT supported. You will need to use Windows 11. The full setup process for Windows 11 can be found here - Windows 11 Installation on the Framework Laptop 16 DIY Edition.

Important note from the guide (Step 11), after you install the driver package, reboot, then run Windows updates. Once those are done, it is best to reboot again and then see if anything else is showing within Windows Update. When it shows it is completely up to date, then check the Device Manager to see if anything is missing from that point.

Personal note - I had to do Windows Updates and reboot a couple times before it showed completely up to date on my Framework 16.

From the link that lbkNhubert shared above, it shows the 7940HS is apart of the 7040 series which the driver package should work for when following the above guide on Windows 11.


7040 series means it covers the series of processors with the 7*40 in the code number, such as the 7840 and 7940 used in the framework 16.

7940 isn’t a series of processors it’s just a single processor in the 7040 series.

For windows 10 install the 7040 framework driver and bios update bundle then install the AMD driver bundle and everything but the TPM will be recognised.


Awesome Information. I will try again following your suggestions on Windows 11

The information that the drivers don’t work in Windows 10 is incorrect, to the best of my knowledge. I’ve seen several reports from people who have installed them on Windows 10, saying that they work fine in that environment as well.

This is the AMD driver bundle I was referring to by the way:


To my knowledge, it may work but is not a “officially supported” OS (All documentation, guides, knowledgebase, order page, and links I have seen relating to Windows for the Framework 16 are for Windows 11). Similar to how people may us Pop!_OS for Linux where things may work; it is not officially supported as the only officially supported Linux Distros are Fedora and Ubuntu; and Arch Linux is compatible community supported. (Linux Compatibility chart).

I personally really like Windows 10 and is still what my desktop uses. I installed Windows 11 on my Framework 16 and then personalized it to make it similar to Windows 10 like moving the taskbar back to the left instead of center😄.

Thanks everyone. I may have had an older ISO version of Windows 11. Once I had finished all the windows updates after a few restarts and checking for updates again I then ran the driver bundle a second time. This time it popped up with a few extra notifications from windows during install and after the restart all the drivers were instal Pled.

My only advice to people in the future would be to ensure you have completed the windows updates first then install the driver package. Problem solved


Glad to hear that everything is working now!