MT7922 shuts down under load - Archlinux 6.6.x

Hi folks. I’m having an issue when I try to download large files. (in this case, FFXIV) Wifi will work fine for a while, then once I put the network under load (~30Mb/s), it’ll eventually drop out. It also sometimes drops out after using the laptop for a while. The only thing that gets it running again is rebooting the system.

Framework laptop 13, AMD 7840u, Mediatek MT7922 (what the marketplace calls AMD RZ616). Luckily, the ethernet expansion card works alright, (even once the wifi adapter goes down) which is how I can post this.

dmesg output:

[   26.515541] wlan0: authenticate with f4:f5:e8:81:91:f9
[   27.019006] wlan0: send auth to f4:f5:e8:81:91:f9 (try 1/3)
[   27.021871] wlan0: authenticated
[   27.023762] wlan0: associate with f4:f5:e8:81:91:f9 (try 1/3)
[   27.038270] wlan0: RX AssocResp from f4:f5:e8:81:91:f9 (capab=0x1111 status=0 aid=5)
[   27.069165] wlan0: associated
[   27.250655] wlan0: Limiting TX power to 27 (30 - 3) dBm as advertised by f4:f5:e8:81:91:f9

I’ve disabled power management in /etc/NetworkManager/NetworkManager.conf to try to fix this:

# Configuration file for NetworkManager.
# See "man 5 NetworkManager.conf" for details.

but I’m not having any luck.

Could the adapter be overheating? sensors shows the wifi adapter at 42c.

There is an upstream bug introduced in 6.6.4-6.6.5 around the wireless stack (not mt specific). You’ve probably hit this. Details in other threads.

the other thread:

thanks all! i’ll keep an eye out for updates, then. glad it’s not hardware, i didn’t want to have to buy a new adapter.

did some testing with prior kernels (6.6.4 and 6.6.3) and the issue is persisting – are we sure this is the same root issue?

I get the same hanging issues as the bug report references, but only on a single tty – I can issue commands as normal if I switch to another.

Also, my networking isn’t entirely down. It just shuts down as soon as I put it under load, and can’t be revived. Right now I’m throttling my speeds to keep it from shutting down.

6.6.3 also seems to fix the hang-on-shutdown issue.

There is a mt76 specific patch to disable powersaving features by default related to performance/latency floating around (it’s part of the sentry-fsync kernel patchset). If I had to guess possibly if you’ve tuned power management via powertop/tlp - this might be excacerbating things. (Having said that I’m running with all the powersave knobs/udev rules turned out without issue - on F39 and a custom kernel from 6.7-rc4)

I haven’t noticed problems underload (qualcomm radios on AP side) and I routinely do multigigabit transfers from NFS shares across my network.

Hmmm, I haven’t touched powertop or tlp. But, iwconfig reveals:

wlan0    [...]
          Mode:Managed  Frequency:5.745 GHz  Access Point: F4:F5:E8:81:91:F9   
          Bit Rate=108 Mb/s   Tx-Power=3 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

So I doubt that’s the problem. I can mess around with it though, see if there’s some setting I’m missing.

If you get this to work, do you mind sharing the settings it runs at (and how much pain it is to install)? As a former FFXIV player, that’d be interesting to know.


@Soukyuu Runs comfortably on desktop (standard). If you want anything higher I’d keep dynamic resolution turned on and probably not run content, just take screenshots and stuff. It’s odd; FFXIV is the poorest-performing game I’ve tried despite being a decade old lol. Assassin’s creed odyssey spikes a bit but I can get it to run at a comfortable 60 FPS.

Yay kernel patch! Hoping for the best :crossed_fingers:

You should have tried running v1.x then lol, it managed to perform poorly even on high end machines (without looking particularly better). V2.x running at standard preset (and on linux!) is not bad… might be worth checking out… but then, I don’t really have time to play anyway.

Thanks for the feedback!

1 Like