My Display Would Not Turn On

I recently purchased my Framework laptop to prepare for college. Thursday night I spent the time getting Windows downloaded on it and everything was running smoothly. Friday morning, I wanted to take my laptop to school to work on it some more and see if I could get all of my stuff transferred and to my liking. When I went to turn it on, the LED would turn on around the power button, but the display wouldn’t come on. I thought it may not have charged completely and needed to be plugged in. I plugged in the laptop, waited a few minutes and then turned it on. This time the display turned on and I continued organizing things.
I then got pulled away, so I closed it thinking nothing of it. When I returned and opened my laptop up, the display would not turn on. I was confused because I had not shut it down completely. I decided to research on Frameworks website and found a helpful thread that explained what might be going on if your computer won’t turn on, but the LEDs turn on. I found that on the side, next to the expansion card ports, the LEDs will flash a code to let you know what could be wrong. When counting the flashes, I thought that the 11th flash and 12th flashes were red (11th flash meant there was something wrong with the RAM). Knowing that there was nothing I could do about the issue till I got home from school, I stopped trying to turn the laptop on and just gave up for the time being.
After I got home from school, I followed the directions on how to test out each RAM (I have 2 16GB). I took one out to test the other, and the display would not turn on and it flashed the same code. I got hopeful thinking I found the issue. I tried the other RAM to see if that one worked, but it still threw the same code on the side. By this time, I was starting to get a little frustrated and emotional. When my mom came in, she took a look at the code and counted that it was the 12th flash that was red (this was a problem with initializing the internal display), so I had counted wrong all day. I didn’t know what to do at this point, but my mom suggested that I put in the USB drive that had the Windows operating system on it. We tried that and the display would still not turn on and the same code was flashing.
Later Friday night I end up calling my uncle because he has a much greater understanding of computers than me. I explain my issue and he walked me through a couple things to try. First, we tried checking the WiFi to make sure the nodes weren’t touching. Since they weren’t we decided to move on to the next possibility. I disconnected the internal display and then reconnected it. This did not work either. Now, this whole time that we are trying things and then turning the laptop back on, I am connecting the keyboard and screwing it back together (this will be important later). Finally, he had me take the battery out as well as the Seymour battery. We took it out and let it sit for about 10 minutes.
I put the batteries back in and red LEDs began to flash on the internals, which it was not doing previously. I reattached the keyboard and went to turn on the computer, but the display would still not turn on. With few options left, I just decided to open the laptop back up and I was just staring and the flashing lights on the internal.
At this point, I accidentally press the power button. I don’t think much of it till I see the display turning on. I was absolutely shocked! I put the keyboard back on and closed the laptop so I could screw it back together. When I went to open it back up, the display was off again and would not come back on. Now we were finally getting somewhere. Next, I removed the keyboard again, turned on the computer, the display came on, and instead of closing the screen to screw in the keyboard, I left it open. I got the bottom 2 screws just fine, but then I needed to close the screen to around 80 degrees. As I was screwing in the top right (when looking at the bottom) screw the screen shut off. When I took the keyboard back off, I looked at the left side of the internals (that would correspond with the upper right screw when looking at the back directly) and it seemed as though the wire connecting the internal display wasn’t underneath a metal flap. I tucked the wire back under that flap and turned on the computer. The display turned on and this time, I tilted the laptop so that the back of the screen was on the ground. I wanted to be able to watch the screen while I slowly tightened the screws. I got nervous as I reached the final screw (the one that caused issues earlier), but the display stayed on!
I then turned it off and on a few times to test it to make sure that it was working. I didn’t have an issue with the display not turning on. This morning, I was nervous about turning it on and what might happen, but there were no issues.
I don’t know what caused the problem and I don’t know if there was a singular thing that fixed it. The wires may have been getting caught or something we did earlier in the day may have just taken awhile to take effect. I just wanted to put this out there to possible help someone else that may have the same issue in the future and give a few more options to try.

3 Likes

Hi

Welcome to the forum and thanks for the laying out all that you did. :slight_smile:

This sounds like a manufacturing/assembly defect causing a ground inconsistency.

Whatever was causing the issue, I haven’t had any more issues with it since. I will definitely make another post if the problem occurs again.

Hi @Meleahna_Williams,

If the issue occurs again please don’t hesitate to submit a ticket to our support team here: Framework | Support so they can ensure your laptop is performing as intended!

Thank you and stay safe!

2 Likes