Need help with virus protection and hardware security

Hello. I recently reset (system/recovery/reset my pc) my Framework 13 and I am now seeing strange Windows Security behaviors
1 - Device Security tells me Standard hardware security not supported.
2 - I cannot access the Virus & threat protection anymore. I get the message: “Page Not Available - Your IT administrator has limited access to some areas of this app”. This is my personal device and not deployed by any IT group.

I don’t think it was like that before (Framework 13, AMD 7460, pre-built w/ Windows 11). Would anyone be able to help me fix these issues?

Thanks in advance!

Screenshot 2024-01-27 022107

Did you perhaps reinstall the Framework driver pack again? Just to make sure you are not having driver issues?

You’ll need the one for AMD and listed on that page. Download and run it. When it is finished restart.

Regarding the inability to access virus protection, let’s talk about that after you have tried reinstalling the driver pack.

Thank you for you answer.

I have (had) reinstalled the drivers from the source you provided and it did not resolve the issue. Here’s what I’ve tried thus far, all without luck. As I have absolutely no clue, some step might be completely useless:

  • Install drivers from Framework website (not from AMD for example)
  • Check and reset TPM status
  • Check if my drive was encrypted. It was stuck. Had to pause/resume for it to complete.
  • I’ve been resetting some Windows Defender policies (recommendation from different online searches).

Let me know if you think of something else.

Much appreciated. Truly!

OK so after many different attempts using different online recommendations, I’ve given up and reinstalled Windows 11 using the Framework guidelines for the DYI Ryzen 13. So far so good. Everything works.

Still confused as to why resetting windows created this issue, but happy it is seemingly resolved.