Newly swapped in AMD board, computer won't stay on for more than a few minutes

Just swapped out my Intel main board for the new AMD one. I got 2 SK Hynix 8GB modules, HMCG66AGBSA092N (not the exact model on the knowledge base page but I think close enough), as well as a crucial P3 SSD. The swap out went smoothly from what I could tell, but now when I try to install any OS (I’m installing Fedora 39 Beta) or run anything from USB at all, the computer just hard restarts after a few minutes. It happens anywhere from 1 minute to 10 minutes into doing something. I can’t even get through a RAM checker. The laptop is plugged in while this is happening. My only other observation is my power button (finger print sensor) gets super hot while it’s on (this wasn’t happening before).

The only potential hitches I had during installation was:

  • one of my ram sticks wasn’t fully seated when I pressed it down, but I don’t think anything broke and I just re-seated it
  • the mainboard turned on while I was trying to attach the input cover, but before I fully plugged it in, so it was just on without any way to send input for a couple seconds. I just pushed the connector in while it was in this state and quickly used the power button to turn it off. I don’t think anything got damaged.

Any advice here?


Narrowed down a bit, the computer won’t restart if it’s just sitting doing nothing. It restarts almost immediately whenever an installer touches the SSD. I’m not sure about memtest, maybe it restarted because it was testing the RAM or maybe it was trying to write to disk. But I guess the problem might be my SSD? Is there like, a kernel param I can set for this?

Historically, the fingerprint reader is known to get hot when no fingerprint reader driver is loaded. i.e. The heat is expected until it has a driver loaded.

1 Like

New observation, just going into the BIOS, it didn’t last more than 10 seconds of me just browsing the settings before it froze for a couple seconds then hard restarted again. Just using the BIOS! Weeeeird

Sounds like you need to open a ticket with Framework Support…


Did you have your SSD installed at that point? If so, maybe try removing the SSD and get into the BIOS to see if the same issue happens.

Good call. I removed the SSD and ran memtest again. It still won’t last more than a couple minutes before restarting. Looks like it’s not the SSD’s fault. I’m gonna see if I can grab some other DDR5 SODIMMs and try those. Maybe the ram I got is DOA

For giggles, try booting with one ram stick only in the first memory slot, then the other slot, then the other stick only in the first slot, then the second slot. But yeah a known good stick to compare against would be helpful.

In your first statement you mentioned that the ram wasn’t fully seated, I wonder if the contacts weren’t fully meshed and you got an arc and toasted one of the SO-DIMM pads or contacts in the “slot”.

Yep, I tried swapping the modules, so they should definitely have been fully seated. But yeah, I’ll try the “one at a time” test

Sure enough, the computer crashes when either stick is in slot 0, but when either stick is in slot 1, the computer stays on long enough to pass the memtest for both sticks (~45 minutes)!

Seems to me that my slot 0 has a problem, and that wasn’t even the slot I initially messed up inserting! I have no idea how to diagnose this further. I’m still gonna get another pair of ram JUST in case these two are somehow incompatible for whatever reason, but that’s a huge step forward.


Always a major bummer to have an issue like that. But at least you got something figured out. I hope you get a quick solution once support gets back to you.

I considered the possibility that my outdated BIOS version had something to do with it.

My BIOS was in fact on 3.02, and updating it to 3.03 beta fixed some issues I had with booting Fedora 39 with 1 ram stick installed. But installing the second ram stick with the new BIOS still yields the same near-instant restart behavior. Maybe the final BIOS release has a fix?

I saw in another thread about a similar issue. Check to make sure the framework qr sticker isn’t wrapping around onto any pins in slot 0.

Took the sticker off and shifted it as far away from the pins as I could. No change.

Also tried entirely different brand of ram (crucial), still exact same behavior. RIP my mainboard.

Additionally, I had gotten Debian installed with just the one ramstick for normal usage, and when I tried the new ram modules and got the reboot, it was during the encryption unlock stage and the reboot actually killed GRUB. Had to reinstall using Debian’s rescue mode (worked like a charm). Dunno if this helps to diagnose the hardware issue or if that’s just expected when a system suddenly reboots during boot up sometimes lol.