OFFICIAL - Framework Laptop BIOS 3.06 Notification - PLEASE READ

We’ve found an issue with BIOS 3.06 where in some conditions, a laptop left for an extended period of time (days/weeks) in hibernate or shutdown with power unplugged can get into a state where it won’t charge. We have recovery steps for this in My Framework Laptop is not powering on under “If the side LED doesn’t light up” in case you run into this state. Until we release BIOS 3.07 though, we are taking down the 3.06 download and ask that you plug in power if you will be leaving the laptop alone for an extended period.


Thanks for the heads up! Any timeline on a beta release of 3.07?


Oh wow, thanks for the heads up. Good thing I use / charge my laptop quite often!


May I suggest that important new threads from Framework team members preface the title with the word ‘OFFICIAL’ or something similar. When I first saw the title, I thought it was just another post where the poster wanted to draw attention to themselves and their problem.


Alternatively/in addition, if Framework team members use a Framework logo border in their profile picture, it would make it more obvious at a glance that it’s an ‘official’ thread. Though this would require some active moderation to make sure regular members don’t have such a profile picture. Currently @Kieran_Levin’s threads are very obvious given his profile picture.

Or more simply, a new ‘Announcements’ category reserved only for the Framework team.

Don’t Framework team members already have a logo on the bottom right hand of their profile pics?


Yes but it’s not visible in the thread list.

For example:


Absolutely fair point, feesh. Updated.


For those who, like me, were wondering which version we have:

$ sudo dmidecode -s bios-version

In reading the instructions to fix this issue, it seems you need TWO USB-C expansion cards. The instructions may need to state this at the top as many may have only one USB-C card. I assume you can also plug directly into the USB-C slot inside the slot — this detail could be useful in the instructions.

1 Like

@TheTwistgibber I just want to add that I’ve found similar issue with the older version of the bios. I left my Frame.Work for more than 1 month unplugged( left it at home while I had a business trip).
And I was extremally upset today that my laptop was not able to boot up even considering the fact I have plugged it to AC. It took me 30 mins of trying to boot up and shutdown keeping laptop plugged to AC. I’ve tried ports on both sides – no differences. Only in 30 mins the laptop was able to boot. And I was really surprised, because it shows that I have only 41% of battery left. Even considering the fact I’ve completely turned it off before leaving it for 1 month and I had full battery at that time.
Here is a BIOS version I have:

And here is a confirmation from the Windows 10 Sleep Study that laptop was OFF in last days:

Don’t know what to do. And don’t know why my battery lost ~60% of it’s capacity in device that was completely shutdown. :sob:
I hope you guys can suggest me what’s going on and how to fix these issues: (no boot for 30 mins + battery lost 2/3 of its charge in “off” state in 1 month).

I had this problem, and the recommended workaround didn’t work until I disconnected RTC battery. Full report in linked post.

@dmac8086 This not a solution. If I need to disassemble it each time I leave my laptop unplugged – this is serious bug. Either in Hardware, either in BIOS. Also, it has no explanation how completely turned off laptop can lose 60% of its battery in one month. Lithium batteries have really low self-discharge rate and definetly can’t lose 2/3 of its capacity in 1 month. That means something( some hardware) sucks battery even in turned-off state. Or the battery itself is dead/faulty. :frowning:
P.S. Also, I’ve mentioned the BIOS version – it’s official 3.02 and the issue exists there. Because this topic states it’s a bug in 3.06 – which is wrong. This bug exists in official release version as well. I hope this will be helpful for Frame.Work team in order to test and identify the root cause. :frowning:

@KOSTYANTYN_RUKHLIS My response was to the original post / specific workaround proposed. I 100% agree that it’s not a solution, and for that matter, I never claimed it was a solution. It was a necessary step I had to perform before the work-around presented by the Framework team to get my laptop to boot again worked. I put the comment here so anyone else knows to try it in recovering their machine to a workable state.

The solution to the original issue will (hopefully) be present in the next BIOS release. Until then I’m mostly leaving mine on the charger when it’s not actively with me to be used.

You might not be affected by this issue, as the original post mentioned machines running 3.06 which yours clearly is not. Regardless, your issue is definitely alarming and I hope you are able to work out why that happened. It’s something none of us want to have to deal with.


If you battery disconnect in BIOS before you leave your laptop for a day or two, does the charge also deplete significantly? Also you said it lost 60% charge in a month being off (I assume 100% to 40% charge), so 60% in 30 days, approx. is 2% a day.

If you charge to 100%, do battery disconnect, disconnect the AC, shut down, and leave your laptop for 24 hours, does the level drop to 98%?