OFFICIAL - Linux and Framework Support - PLEASE READ

Why wouldn’t the process for updating the BIOS work? It’s booting from an external USB, it’s OS-agnostic.

It’s a good question, but I (accidentally) tested this yesterday.

Run the BIOS update stick with my OpenBSD drive installed: “Failed to Update”
Quick switch to my Arch Linux drive: no problem, all good.

My best guess would be that the thing somehow looks for and uses something that is on the drive itself, they do ship separate downloads for if you use Linux or Windows, after all. But as for what precisely: no idea. But if forced to guess: perhaps the thing has some checks in place to try to make sure it doesn’t mess up your boot entries or something like that, and when it sees OpenBSD it has no idea what that is, therefore cannot ensure it didn’t break anything, and fails?

1 Like

@Daniel_Agorander [Daniel_Agorander]

Thanks for the info - I appreciate knowing this an option. I really prefer an actual UNIX environment. But, as I said above, on Laptops, I can usually make FreeBSD work, but only after more than a dozen tweaks. The FreeBSD project simply does not have the staff to make all the different hardware options work out of the box.

For now, I will stick to Ubuntu overlaid with Xubuntu. That is giving me the CPU/GPU support and performs well. I am very fussy about what I install.

Other than development, 90% of what everyone does now is both online and in a browser. (I don’t game, for example.).

I do hope to find some time over the Holidays to kick the tires of FreeBSD on my new laptop (assuming it arrives ;-).


1 Like

Sounds like you’ll (hopefully) have some great holidays. :slight_smile:

For things like this, it is very nice that the Framework is so easy to open up and work in. Captive screws, standard (and included!) screwdriver, no pesky plastic clips in the chassis… So the way I use mine, I have a 1TiB NVME with Arch Linux in it most of the time, and a second 512GiB NVME with OpenBSD. Takes me 3 minutes (if that) to swap them out. (I do play recent games a fair bit, so I did give Linux the bigger of my drives.)

For me, this was the machine where I started trying out some BSDs outside of VMs, after reading reports that it actually worked fairly well (including a detailed blog post somewhere on the specific work that was done with some support from Framework to get screen and touchpad to “behave” in OpenBSD). Compared to trying to get FreeBSD to behave on my desktop computer, it was actually pretty easy. (Perils of having a gaming-oriented an quite new Nvidia graphics card…) And way easier than any other laptop I’ve even heard of that isn’t quite old.

I suspect Framework’s decision to consciously pick as many parts and chips as possible that are “known good” on Linux has paid dividends for *BSD users in this case. Since Linux was supported, it was “just” a matter of the FreeBSD project making a new intel-drm-kmod package based on a Linux upstream and then it works, etc. (Similar for WiFi, where apparently FreeBSD project went with the “use Linux as upstream” route, while OpenBSD just made their own and was therefore slightly slower to get working ones out. But on the other hand, OpenBSD was faster with getting working graphics drivers into the shipped version.)

1 Like

The EFI partition (on the internal drive, I assume) is actually used by the stand-alone BIOS updater. For me, it first failed and then, when I made more room by removing the remants of a Windows install from the EFI partition, the update worked. So if “switch to Arch Linux drive” means “swap NVMe” then difference in EFI partition size (or at least free room) between the drives may explain success/failure.


How do I find the PCI ID of my processor?

How do I find the device ID?

@chrissobel lspci