One Time Boot Menu can't get in

@Vaelatern we found an issue in the bios where when rebooting from linux you may not be able to enter the bios menu when the keyboard is in media key mode after rebooting from linux. We are fixing this in our next bios update.
You can try a few things.

  1. Try Fn+Esc to toggle the function keys to function key mode, and then reboot and try to enter the bios.
  2. Try Fn+F12 while the system is booting to enter the boot menu/ or Fn+F2 to enter the bios.

In the initial bios we shipped with, we force the function keys to function key mode while in the bios boot process. However when the system boots to windows or linux, the OS sends the bios a message to indicate the OS is booted and SCI is enabled.
However linux does not disable SCI on shutdown/reboot so then media key mode will be stuck enabled, and you will not be able to enter the bios.

5 Likes

Can confirm this fixed it for me!

Very helpful, thank you.

Doesn’t answer the possible bug where I freeze the machine by pressing F12 when there are no options available, just FYI.

2 Likes

Flash drive plugged in to USB A port with no problems once it’s up. Mounted the live ISO without any difficulty, plugged straight into an A port.

@Vaelatern Could you try one experiment for us?
I assume you are trying to boot from a USB-A drive using the framework C-A adapter. Could you remove it, boot the system to the boot selection menu F12 with the framework C-A adapter removed, and then insert the adapter and drive and see if the boot option shows up? This might help me narrow down your issue.

also have this issue and reported it to the framework team, who have (thus far) been unable to reproduce.

nothing to add other than “me too”.

Having now installed an OS once, I then shut down, removed the nvme drive containing my OS, and tried to boot again.

I was unable to replicate the F12 freeze bug any more. I attempted setting a timeout of 3 again (was 0 at start of test), same as before, and no change.

However I can replicate the flash drive, from which I was booted with a dongle, unable to boot in the machine.

Encouraged by this failure, I then removed the C-A adapters (I had two equipped). I waited until the “No bootable device detected” dialog box, inserted the C-A adapter and flash drive, and proceeded to the boot menu. There was no option listed. I attempted plugging in just before the boot menu appeared after F12, as well as just after. No change, no option listed. I then plugged in the USB A dongle in to one of the adapters, and the flash drive into that adapter, and was able to see that option in the F12 menu on the first try.

For whatever it’s worth I used exactly this dongle Amazon.com

This allowed me to select PXE as well as plug my flash drive into it.

@Vaelatern Thanks for the test. What thumb drive are you using?

The particular one I’ve ended up using as my live ISO is Amazon.com (5 years old now, unlike the dongle).

Though I’ve replicated the “can’t use it” with multiple other drives, all on the side of “been with me for years and been reliable on other machines”.

Can replicate the failure to load the flash drive where there is an OS installed. It doesn’t work plugged in to the C-A adapter, does work when plugged in via the dongle.

I’m also unable to setup my framework, as I can’t get a boot started.

I’m using this Kingston usbc (“DTDUO3C/32GB”) thumb drive: https://www.amazon.com/gp/aw/d/B010HWCEHM

I get the following blue dialog:

Default Boot Device Missing or Boot Failed.
Insert Recovery Media and Hit any key

Then Select 'Boot Manager' to choose a new Boot Device or to Boot Recovery Media
[Ok]

If I switch the drive to my top-left port (just ever Esc key), or my bottom left port (just under caps lock key), and hit enter, then I at least get to a Boot Manager screen than shows:

Boot Option Menu

EFI Boot Devices
EFI USB Devlon (KingstonDT microDuo 3C)

[up] and [down] to change option, ENTER to select an option, ESC to exit

But if I hit enter, the screen just flashes black, and then the same thing is rendered again.

I can get to the bios settings and confirm USB booting is enabled…
Question: Is there anything else in the bios settings I should ensure?

(Also, my confirmation that this stick should work: booted a Thinkpad from it)

I can get to the bios settings and confirm USB booting is enabled…
Question: Is there anything else in the bios settings I should ensure?

Ah, yeah, this was it: Secure Boot was enabled by default in the bios. Turning it off allowed me to boot from my thumb drive.

2 Likes

this was it: Secure Boot was enabled by default in the bios. Turning it off allowed me to boot from my thumb drive.

Interestingly, now that I have linux installed, this^ is no longer true. I can no longer boot to usb, despite secure boot being disabled. Discussing over on this “Legacy boot / usb boot” thread though.

1 Like

I have the same issue: F12 freezes the machine (got my laptop yesterday). F2 still works, both from the built-in and an external keyboard. The only way I can boot from a USB drive is by getting into BIOS, changing the EFI boot order to and rebooting.

Edit: I have tried every fix in this thread and none would bring the F12 functionality back.

@ctst - from this thread: Cannot load boot menu, laptop freezes - #11 by Quinn_Casey it seemed that setting both quick boot and quiet boot to enabled in the bios did allow f12 to work. Hopefully that will resolve it for you.

3 Likes

@lbkNhubert - That did it. Thank you!

1 Like

@ctst - I’m happy to hear that that worked, but @RandomUser deserves the credit. I just passed the information along. Enjoy the machine!

I just ran into this too. Thank you @lbkNhubert , @RandomUser

2 Likes

Since setting quick boot and quiet boot seems to make F12 work, it’s clear this is a BIOS bug. Has this been reported to the BIOS vendor? If not, can Framework do that? It really should be fixed.

I reproduced this issue with BIOS 3.06 and enabling both quick boot and quiet boot did make the issue disappear, so this issue is in the lastest BIOS. I realize 3.07 is going to release shortly but I’m skeptical that this has been fixed in it unless this issue was reported.

1 Like

Can verify as well that this worked for me.

Agreed. I’m hopeful this can be resolved soon-ish