Cannot load boot menu, laptop freezes

Hello, no matter what I try I cannot boot this laptop off a USB drive. I’ve seen the other threads here and here, disabled secure boot, tried different USB flash drives, tried an external USB-C hub and all the different expansion cards that came with the laptop.

Pressing F12 during boot just freezes the laptop. Nothing on the display even after ~15 minutes. Pressing F2 only sometimes brings up the bios menu. I have an OS on the NVME drive I’m trying to overwrite. That OS boots just fine if I let it, keyboard and touchpad both work. This is frustrating

EDIT: I turned off quick boot. When pressing F12 during the memory test it freezes the test at whatever %. Nothing else changes until I force it to power down.

EDIT 2: I get to the ventoy boot menu when I remove the SSD. It seems like the pair of them don’t work together…


Thanks for reporting this. Could you clarify what is installed on the internal SSD and on the USB drive?

1 Like

Windows 10 installed on the 970 EVO, I tried both a ventoy USB and a Pop!_OS usb, any combination of the SSD/USB freezes the laptop when pressing F12.

The second device under the bios boot tab is described as a EFI USB drive (Sandisk), so yes I think so.

I have an external m.2 reader, so I formatted the SSD and stuck it into the laptop. This makes the laptop default to booting to the USB, and I’m currently installing Ubuntu onto the SSD. Even with the formatted SSD the laptop would freeze when pressing F12 for the boot menu.

1 Like

I’m seeing this too, thanks for confirming

1 Like

Ubuntu 20 install failed, due to a bunch of USB disconnects. Pop!_OS install went well, it boots fine.

Even with the USB disconnected pressing F12 still freezes the laptop. I still have not seen a boot menu like some other screenshots on this forum.

EDIT: even with no drives (SSD uninstalled, USB unplugged) the freeze still occurs anytime in the firmware boot when pressing F12. I think I’ll be returning this

1 Like

Hi Quinn, sorry to hear about this issue. To help us debug, would you be able to capture a video of what you’re seeing so that we can try to reproduce it? You can send it to support directly or PM it to me if you would prefer not to upload the video publicly.

1 Like

Sure, will it post here in a little while

1 Like

Here’s the video of it freezing when pressing F12: Framework laptop failing to load boot menu - YouTube

  1. When the memory test is interrupted
  2. When the laptop first boots up after a 35sec poweroff (display flashes on and off)

I want to reiterate this behavior is the same regardless of what drives are plugged in (SSD, USB, both, or neither).

Right now with no drives installed and without pressing any buttons, the memory test completes successfully and I finally see the boot menu after a warning about no drives. Granted the menu is empty, of course.

1 Like

Nice, that fixed it for me as well


Thanks for digging in and thanks Quinn for the video. This certainly looks like a BIOS bug, and we’ll work on solving it.

1 Like

This bug is still present in BIOS 3.06

1 Like

I also have this bug, and encountered it while trying to get OS .iso’s to load off a USB stick from Ventoy made drives or drives made by etcher. Enabling quick boot and quiet boot allows you to reach the one time boot menu again, although I feel there is something going on with the bios handling boot ups, especially from USB drives. Is there a way to flash or reset the BIOS firmware somehow? Upgrade BIOS firmware for linux users?

1 Like

It seems I am also encountering this problem on Bios 3.07 → Quiet Boot Disabled and even without an USB Stick connected the laptop just freezes with a black screen when pressing F12

1 Like

I can confirm that I was able to enter the Boot Menu when Quiet Boot is disabled. Why does this bug persist from Bios Upgrade to Bios Upgrade?

1 Like

Same here. Had to turn on Quiet Boot to be able to boot from a USB stick

1 Like

On the new Framework laptop with the 12ᵗʰ Gen Intel this BIOS error still exists. BIOS version is July 2022.
Pressing F12 while having **Quiet** Boot disabled will freeze the booting process.

[temporary solution] Once **Quiet** Boot is enabled, F12 will show the boot menu without problems.
NOTE: The *Quick* Boot option can either be enabled or disabled without a problem.
Can you please look into this and find a fix?

Also seeing this on my new 12th Gen, BIOS 3.05. If Quiet Boot is disabled, pressing F12 will hang the system. F2, Del, F10 seem to work fine, just F12 has an issue.

Some other BIOS oddities I noticed while setting things up…

The fans spin up to full while in BIOS. Seems weird that the system is stressed for BIOS setup. Maybe this is nothing and a power profile just hasn’t been applied but my first thought is an overlooked busy loop somewhere.

The Timeout setting only applies if Quick Boot is enabled. I would expect the delay to still apply after the RAM test but there is no additional pause. Maybe just change the wording to Quick Boot Timeout to make it more clear?

If Quiet Boot is disabled, there is an F10 option. It takes me to an MEBx / Intel Management Engine screen that asks for a password. I didn’t think this laptop had vPro capabilities so not sure what this does.

Using efibootmgr under Linux to inspect the boot order shows a couple unexpected network boot options. I don’t have network boot enabled so not sure why these are there. Could be a security issue if the laptop is falling back to a network boot and there is a malicious service on the network.

Overall I’m very happy so far with the laptop but the BIOS quality is not giving me the warm fuzzies.

1 Like

Speaking of UEFI errors: I would like to add another observation:

If the boot order is set to “first” or “last”, how can I change the order of the devices? All I can do is enable/disable devices.

Also, it doesn’t make sense to me that I can’t enable/disable my boot devices if the boot order is set to Auto.

Overall, it seems to me that the boot order and disabling/enabling devices are somehow messed up - or maybe I’m misunderstanding these settings :thinking: