Power profile can't be changed on Kubuntu?

Just got my Framework Laptop 16 and installed Kubuntu on it. I’m having a problem where changing the power profile in the battery and brightness menu doesn’t work, here’s a gif of what happens when I try to change it:

Also, I’m not 100% sure if this is related, but the frame rate in video games seems to noticeably decrease if the charger isn’t plugged in. I would like to (optionally) have the best performance even when the charger is disconnected if possible.

Any ideas of what could be going wrong or what I can try to fix the above issues?

What version of power profiles daemon? What kernel?

The Kernel is 6.8.0-31-generic
power-profiles-daemon is 0.21-1

Very interesting result then. Can you please modify the systemd unit for power-profiles-daemon.service to add -vv to the exec line and then do a systemctl daemon-reload and systemctl restart power-profiles-daemon.service?

Reproduce the issue and then share the journal for PPD.

The current workaround is to go to System Settings → Energy Settings and then check “Power Management Profile” for the one you want to change (battery / AC power / etc) and that will force the profile to be the one you want

OK. I’ll work on that a little later today.

One more thing; after you’ve reproduced using the GUI and capturing the journal can you please also try to reproduce using the command line tool powerprofilesctl? Try to set profiles from that and see if a similar issue happens. If it doesn’t, this is a KDE bug.

My kernal is 6.5.0-28-generic (64-bit)
power-profiles-daemon is 0.21-1

I’ve tried my best to get the journal for the PPD, but I didn’t see any messages for it. (I’m not super well versed with this kinda stuff yet so it might just be my fault.)

More importantly, I tried using the powerprofilesctl tool, and it seems to work just fine! I can use it to set, list, and get the power profile(s). The interesting thing is that KDE plasma doesn’t even display the correct power profile, the slider doesn’t correlate with the actual power profile at all.

Thanks for the help so far, got any ideas what might be causing plasma not to work correctly with ppd?

It sounds like a bug you should report to KDE.

Alright, will do!

Someone else already reported this bug to KDE, and apparently it was already fixed!
I upgraded from Kubuntu 23.10 to 24.04 (with plasma 5.27.11) and it works perfectly now!

1 Like