Public Beta Test: BIOS v3.06 + Driver Bundle 2021_10_29

I’m trying to update the BIOS from a Windows 10 USB installation that I’ve used for many BIOS updates on various laptops, but when I try applying the 3.06 update (from 3.02) it says Erasing and Writing, then I get an error that says “The BIOS image to be updated is invalid for Secure Flash or onboard BIOS does not support Secure Flash”. I didn’t see any settings in the firmware menu for Secure Flash, and I have Secure Boot enabled. I also tried updating to 3.03 just in case, but get the same error.


@jcs it may be worth falling back on Kieran’s troubleshooting steps/ideas from above:

1 Like

That is EXACTLY the problem I’m having and have yet to solve.

1 Like

It’s in the BIOS.

F2 into the BIOS on startup and you can change it in there.


I used this method as well to install Windows 10 to one of the 250gb expansion drives, did the bios update from the Windows install on the expansion drive, and can confirm that this process worked. Also, now have a mobile Windows install that I can boot into for compatibility whenever I need to without touching my main OS drive, and without any of the usual limitations from portable Windows solutions. This is nice.

Strange workarounds - I couldn’t get it to work until I created the Windows bootable USB through the official Windows Media Creation Tool (or whatever they call it) running on a Windows VM on my main Linux install that I gave access to the USB stick. Whatever, it worked.

I have not noticed any strange or unexpected behaviors on either OS at this point, but I’ve only been running it a couple of hours. Early testing even seems to indicate that it’s solved a power throttling bug with the standard charger that I had noticed on my machine.

Excellent work!

(This weekend I may work on translating the linked guide above on installing Windows to a USB drive to being specific for the current version of Windows Home you can download from the Microsoft site and a Framework 250gb expansion bay, full credit and links to the original etc., but there are a couple of modifications that have to be made to the instructions and might as well make it easy for everybody.)


When you do that, check if the recovery partitions are needed at all. I believe I skipped one or both and it worked fine. That would make the guide almost trivial.

1 Like

It only allows 3 options (high, medium and low).
Low isn’t low enough for me.
I would also like the option to turn the led of completely.


You’ll have to submit that feature as a request in a future BIOS.


Thank you. How do I make a request? Do you know?


black tape or better for astronomy, layers of red tape.
Red KB lighting would be great.


Do we know if there will be options to change the way that the light works in future bios updates?

I just so happened I was working on getting boot times down as low as possible, and I thought I hit the limit. So my anecdote is going from 20 seconds cold boot to 15 seconds, and from 19 seconds resume from hibernate to under 13 seconds, reliably :relieved:.


Quick update,
I have an update on LVFS in the embargo channel, and just need permission to move it to testing, so once I get it on the testing channel the community can try it out. :smiley: :smiley:


Thanks, it was a space issue in my EFI partition. I deleted some old vendor directories and it was able to apply the 3.06 update.

1 Like

I had a similar issue with 3.03. I ended up resizing my EFI partition because it was only like 30MB (probably due to an issue with the imaging tool/methods I used… or else I missed a tick box somewhere. Whoops!).

I think it’s advisable to not go any smaller than 128MB; 300MB is Microsoft’s standard size. You’re not going to miss the space.

1 Like

Does this driver pack fix the Windows 11 issue with Intel SST driver or will an updated driver pack be issued by Framework?

Windows 11 Upgrades Blocked by Intel SST Audio Driver | Tom’s Hardware (


I use ~512MB on all of my devices, there really isn’t any reason to skimp on this since it’s really never going to be a giant amount of space compared to how much capacity HDDs and SSDs have nowadays.


@Kieran_Levin Any update on LVFS? Or when you expect to make progress on it?


Bios 3.06 is currently in the LVFS testing channel.
I did see a failure in Manjaro Linux on the channel which we need to look at.


@Kieran_Levin is it still on LVFS testing? I still only see the dbx update when I enable it; am I doing something wrong?

[d@greebo ~]$ fwupdmgr enable-remote lvfs-testing 
║ Enable new remote?                                                           ║
║ The LVFS is a free service that operates as an independent legal entity and  ║
║ has no connection with Fedora Linux. Your distributor may not have verified  ║
║ any of the firmware updates for compatibility with your system or connected  ║
║ devices. All firmware is provided only by the original equipment             ║
║ manufacturer.                                                                ║
║                                                                              ║
║ This remote contains firmware which is not embargoed, but is still being     ║
║ tested by the hardware vendor. You should ensure you have a way to manually  ║
║ downgrade the firmware if the firmware update fails.                         ║
║                                                                              ║
║ Enabling this functionality is done at your own risk, which means you have   ║
║ to contact your original equipment manufacturer regarding any problems       ║
║ caused by these updates. Only problems with the update process itself        ║
║ should be filed at                             ║

Agree and enable the remote? [Y|n]: 
Authenticating…          [-                                      ]
Authenticating…          [***************************************]
Do you want to refresh this remote now? (Requires internet connection) [Y|n]: 
Downloading…             [***************************************]
Downloading…             [***************************************]

Successfully enabled and refreshed remote
[d@greebo ~]$ fwupdmgr get-updates 
└─UEFI dbx:
  │   Device ID:          362301da643102b9f38477387e2193e57abaa590
  │   Summary:            UEFI revocation database
  │   Current version:    33
  │   Minimum Version:    33
  │   Vendor:             UEFI:Linux Foundation
  │   Install Duration:   1 second
  │   GUIDs:              c6682ade-b5ec-57c4-b687-676351208742
  │                       f8ba2887-9411-5c36-9cee-88995bb39731
  │                       59145971-a32d-5465-9497-cfb56b4704be
  │                       c9f47f69-d72a-55b7-b19c-a261a4b0ca53
  │   Device Flags:       • Internal device
  │                       • Updatable
  │                       • Supported on remote server
  │                       • Needs a reboot after installation
  │                       • Only version upgrades are allowed
  └─Secure Boot dbx:
        New version:      77
        Remote ID:        lvfs-testing
        Release ID:       6101
        Summary:          UEFI Secure Boot Forbidden Signature Database
        Variant:          x64
        License:          Proprietary
        Size:             7.1 kB
        Created:          2016-08-09
        Urgency:          High
        Vendor:           Linux Foundation
        Duration:         1 second
        Flags:            is-upgrade
        This updates the dbx to the latest release from Microsoft.

Edit: For completeness:

[d@greebo ~]$ fwupdmgr get-remotes
├─Linux Vendor Firmware Service (testing):
│     Remote ID:          lvfs-testing
│     Type:               download
│     Keyring:            jcat
│     Enabled:            true
│     Checksum:           a62eadf7695edb4e5ae4450bac2e9f52a2d28761e062cd1b3415ecf1905c499b
│     Age:                5.32m
│     Priority:           1
│     Filename:           /var/lib/fwupd/metadata/lvfs-testing/metadata.xml.gz
│     Filename Signature: /var/lib/fwupd/metadata/lvfs-testing/metadata.xml.gz.jcat
│     Filename Source:    /etc/fwupd/remotes.d/lvfs-testing.conf
│     Metadata URI:
│     Metadata Signature:
│     Report URI:
│     Automatic Reporting:false