Random hard freezes fw13 amd7840u win11

the issue stopped completely after the ram had been swapped

1 Like

That’s promising, how long have you gone w/o an issue?

Hopefully this isn’t the proper solution. So many applications are electron/browser based these days, that you may not even be able to disable it reliably.

Found a solution (I think).

I changed the AMD iGPU plan to match what I set in AMD Adrenalin. For example, when setting the iGPU to Gaming mode in Adrenalin (to get the full 4GB of dedicated iGPU memory), I also went into the BIOS to ensure that the BIOS setting is also set to Gaming.

By default, the BIOS setting is set to Auto and Adrenalin is set to Productivity.

I noticed that when the BIOS is set to Auto but Adrenalin is set to Gaming, I would have the freezes. It is possible that there is some BIOS or Driver error that causes the Automatic preset to switch or error out even though it should be match the Adrenalin setting.

Let me know if this works for anyone else!

I have had an issue where my microphone input (Audio-Technica AT2020USB) sounds terrible- crackling and poor quality after waking from hibernate mode. Unplugging and replugging the microphone USB doesn’t work, tried different ports on my dock, USB hub and directly into the computer via USB-A card, and the I even tried removing the device from device manager and then finding the device again and letting it reinstall drivers (using Microsoft ones that it finds by default). None of this was successful, but if I restart the computer, it starts working normally with good quality again.

Strangely enough, when this happens, I can switch to other audio-input devices which are also using the Microsoft drivers, and they don’t have the same issue. And there’s no warning that it’s sounding crackly on the input because the computer output (and live monitoring mix from the microphone) sounds fine, so I basically have to jump into “Sound Recorder” at the beginning of the day to check that my microphone isn’t crackly, before I get going on virtual meetings where I won’t know unless people complain. So far it’s annoying and I can’t reliably reproduce it, it’s only been 2-3x in the past month.

1 Like

I don’t know for sure this is fixed, because it’s only been 3 days, but I’m curious how many people who are seeing crashes have the Realtek drivers installed.

I was already on the December AMD drivers which did not fix the crashing.

On the 23rd I installed the Realtek drivers from Framework (previously I was using the Microsoft built-in audio drivers), and then updated to the newest Realtek 9597.1 drivers I could find in the Microsoft Update Catalog (Microsoft Update Catalog).

Since then, I haven’t had a hard freeze. Though I’m sure right after I post this I’ll probably end up having another. :joy:

Edit: Switched the Microsoft Update Catalog / Realtek driver link to one that would let you download it instead of the details page.

Edit 2: yep, too good to be true, just had a crash after 8 days.

I’m on an 8 day uptime streak with AMD 23.12.1 and win11 pro 22631.2861
I want to say crashes stopped after the windows update, but I’m not sure.

I’ll have to check my mic next time that happens. For me it was only the output. IIRC one time it happened I was on a discord call and apparently my mic was fine but the output of everything was bad.
For reference I had the FW drivers installed initially but now my drivers for “speakers (realtek audio)” are using microsoft drivers 10.0.22621.1 dated 5/6/2022

Since doing the AMD drivers update a week ago and Windows update, I feel like my stability took a step back. Other than sleep issues (inability to stay sleeping and dead batteries with high drain overnight while sleeping, necessitating a switch to hibernate only), I had a pretty stable Windows 11 pro on the original drivers. I have since done AMD driver updates twice and in addition to the crackly mic input intermittently, now every time I wake from hibernate this past week, the taskbar doesn’t work (you can see and click on any app/window but it doesn’t switch to the app and bring it forward) until I unplug and replug my Thunderbolt 4 dock (tried both my Dell and Lenovo docks with the same issue). After unplugging and then replugging the taskbar works as expected. But it reduces the joy of one dock cable if I have to unplug and replug Everytime I use the computer.

For what it’s worth, about 6 days now since I’ve had a hard freeze after installing and then updating the Realtek driver. Again, not sure it’s definitely a fix but so far so good here.

Edit: yep, too good to be true, just had a crash after 8 days.

I had no issues previously but somehow over the past week or so I started getting crackling / popping audio seemingly at random times, but definitely noticeable when you wake from sleep or hibernate. Tried various realtek drivers and it doesn’t seem to make a difference for me at all.

Just recovered from another BSOD. Another DPC Watchdog Violation error. This one actually pointed to another file alongside NTOSKRNEL. AMDKMDAG.SYS.

Running the latest Adrenalin drivers.

Windbg calls out the following

SYMBOL_NAME:  dxgkrnl!DXGADAPTER::SetPowerComponentIdleCBWorker+22a

MODULE_NAME: dxgkrnl

IMAGE_NAME:  dxgkrnl.sys

IMAGE_VERSION:  10.0.22621.1254

STACK_COMMAND:  .cxr; .ecxr ; kb


FAILURE_BUCKET_ID:  0x133_DPC_dxgkrnl!DXGADAPTER::SetPowerComponentIdleCBWorker

OS_VERSION:  10.0.22621.1

BUILDLAB_STR:  ni_release


OSNAME:  Windows 10

FAILURE_ID_HASH:  {25ca888a-406c-e8a0-26b1-b2b0fa0a1558}

I’m in the same situation and have those two files responsible for my BSODs. Out of curiosity, do you have an HDMI expansion card inserted?

Nah. Have two USB-Cs in the top two slots (1 and 3), a USB-A in the bottom-left (2), and a DisplayPort one in bottom-right (4).

I just DDU’d my GPU drivers, gonna run without them for a few days and see how that goes actually. If it bluescreens again, then I can see it possible to rule out AMD drivers at fault (could be power management perhaps? another driver at fault or some incompatibility not picked up, if not potentially hardware related). If it doesn’t, then I can safely say it’s AMD driver/firmware related.

UPDATE: Disregard part of that. Ended up installing the graphics drivers (Framework ones again) since I had issues with the display not turning on when waking from sleep and being unable to get an output working.

Have just opened a support email with Framework themselves too so will update if anything comes out of that.

Ah k, so you have a DP expansion card in the same port as my HDMI card. I am doing an experiment to see if the BSODs stop if there are no display expansion cards inserted. So far so good but it has only been 1.5 days.

This is the last act of desperation I can think of to try. I recall in some other thread someone mentioned support said bad expansion cards can cause this sort of BSOD.

1 Like

Oh. That I didn’t know. Shame that outside of trial and error that there isn’t an easier way to figure out that until it happens. Haven’t had any display stuff plugged in to the laptop yet, but that’s good to know. Kinda makes me wonder then if it’s possible caused by the driver, or something throwing a wobbly because the DisplayPort card has a fault there or something.

A follow up to my post from a month ago: The new AMD drivers did seem to help at first, but then I got a few BSODs.

I gave up and booted OpenSuse Tumbleweed. Not one crash since, and I’ve been using this machine daily, for many hours a day for web browsing, CAD, and some Steam games (mostly Valheim).

If the problem is a wonky part somewhere in the hardware, it appears that Linux doesn’t ask it to do things that it can’t.

I’m waiting for Framework Support to get back to me. They’ve asked me to run the laptop on their driver pack, without expansion cards which I am doing. I’m fully behind Framework’s mission, but after losing work twice to BSODs yesterday, I can’t help but feel the AMD product was rolled out before it was fit for the masses.

Unfortunately, I’m not in the position to be a beta tester for them, I need to know I can rely on my laptop for the purpose of my job so naturally feel very disappointed that they haven’t openly acknowledged what is an obvious problem, even if it’s just to say “we don’t know what’s causing it, but we know about it and we’re working on it”.

I’m hoping this can be resolved soon, so far their driver pack, AMD’s driver pack, both on fresh installs of Windows 11 hasn’t worked.

1 Like

Not necessarily. I’m on arch linux since day one and I’ve been having random GPU freezes (the rest of the system was still working), but not since updating to the “unstable” linux-firmware-git package. There seems to be a beta firmware for our APU in there somewhere, because since that I’ve had no GPU freezes anymore. Maybe that’s why you’re not having the issues, since tumbleweed is also using the newest packages available, afaik?

Has any other batches had these issues on other BIOS versions?

I have had a response from Framework to through troubleshooting steps (uninstall expansion cards, open the laptop and send pics and make sure things are seated correctly), etc, but issue with these BSODs is that they’re randomly triggered. My first two and latest two bluescreens had approximately a week between em.

If it is caused by firmware, that’s only something AMD and Framework could fix with an update for us depending on where the issue lies