Random hard freezes fw13 amd7840u win11

Has any other batches had these issues on other BIOS versions?

I have had a response from Framework to through troubleshooting steps (uninstall expansion cards, open the laptop and send pics and make sure things are seated correctly), etc, but issue with these BSODs is that they’re randomly triggered. My first two and latest two bluescreens had approximately a week between em.

If it is caused by firmware, that’s only something AMD and Framework could fix with an update for us depending on where the issue lies

To add some additional context since I’ve also been running into the Watchdog error and have also been working with Framework Support.

I am currently testing a config of just one stick of ram in slot 0/Framework only drivers (no AMD website drivers)/Windows Updates applied/scratch windows install. I am beginning to suspect the RAM itself might be the issue as the other stick I had in slot 0 was problematic. Both slots were originally slotted with Framework ram. I’m still testing the system as reproducing the failure consistently is basically impossible.

My personal theory has evolved to be that the AMD board is very very sensitive to RAM issues, issues that don’t show up on memtest86 (both sticks passed fine through the system). Hopefully I can report back in a few days and have some confidence that this RAM stick/slot 0/driver config is happy and then try the ram stick in slot 1 to very that the mobo board is otherwise good.

While I appreciate the Framework support team, this process has made me come to the conclusion that this product can not be used in a corporate or non-hobbyist capacity at this time. The diagnostic capabilities of the average user here for this specific problem is beyond the pale, the downtime for a business use case as well. I’m not sure what the solution is as I applaud e-waste reduction, but a support path needs to exist here where the company can eventually grow into a broader market.

Conversely, I sent an HP laptop in for repairs multiple time for similar issues that never got resolved to the point where I ended up replacing the device entirely as a lemon, so it’s not like all mfgs get it right.

Edit: To clarify, my Framework 13 is a from Factory pre-built, with 32gb of ram. I wanted to avoid any potential issues going the DIY route :smiley:

Is this a common issue with the fw13 (7840u)… I just received one and without even turning it on I am now considering returning it… Linux is not an option for me, unfortunately. I am a student, I can’t have a bsod in the middle of an exam :tired_face:

I’d say give it a chance. You have a 30 day return window. I’ve had my amd fw13 for about 3 months now. Not once have I had a bsod in windows 11 after installing the the driver kit.

So you may not end up with any issues at all.

1 Like

If it is sensitive to RAM like that, then I’m outside of the return window and the only way I’d be able to return it would be via issues that can be documented in memtest86 to cause a warranty return. It could be a bad batch, or it could be as simple as bad drivers, but my attempts to troubleshoot this has hit the end of my skill level. When my PC had bluescreens, it was easy to pinpoint the cause and get it stable (in those cases, RAM speeds being too high and overstressing the CPU in that case). But in a laptop, that is a bit more limited. Laptop BIOSes don’t let you change the RAM speeds to see if it is the motherboard selecting an unstable timing/clock. I’m speculating now though.

If it is a fault with the actual hardware, then warranties should cover it once it’s proven to be the case. If it’s driver/software related, have to wait for an update (unless there’s a previous known good driver we can stick with). I haven’t tested it without expansion cards, because I’m waiting to see if my laptop will BSOD again after DDU’ing the Adrenalin drivers and trying again with the Framework supplied ones.

I ordered my FW13 7840u at the end of December and received it the other day. While waiting for the laptop to acclimatize (winter), I came upon this thread. It upset me greatly as the machine my FW13 replaces has been having a similar DPC watchdog violation (though it is on boot, causing boot to hang). The machine being replaced is a Ryzen 5 3500 or something similar. It’s an Asus Vivobook.

I turned on my FW13 today and made note of something. I wonder if anyone has tried regressing their drivers back to the original installed version. While we don’t have the OEM driver (the date on first boot for the AMD driver is either 9/24 or 9/27), I wonder if rolling back to the last WHQL drivers from this time period (that’s 8/2 by my eye) would change anything? They are available under “Previous drivers” on AMD.

I have yet to get a BSOD with a few hours uptime on OEM and bundle drivers from the KB. I am installing 11/1 WHQL drivers from AMD now (driver only install) and will report back on stability after 5 days, I guess. I also installed GRC’s InControl to suspend feature updates in Windows 11 for the time being. In fact, I bypassed the online Windows setup and paused updates before configuring my WiFi. So as far as I know, there have been no Windows updates on my machine.

Edit: I have also not updated the BIOS although the unit seems to have shipped with 3.03.

An update to my experience.

Support asked me to remove the AMD drivers and re-install the Framework driver pack - the issue still persists, if anything, is more frequent than it was before.

They asked me to remove expansion cards, remove the SSD and remove the memory in slot 1, enter the bios and report back whether or not it hung. It didn’t hang.

There is clearly an issue here affecting a lot of AMD users. I am really disappointed they have not acknowledged this issue for the sake of transparency and so consumers can make informed choices before choosing AMD with Framework.

I’m waiting to see what Support say, but I’ve lost waaaay too much time to this now and will probably ask for my money back. It’s such a shame, I really want Framework to succeed, but they need to be more transparent with their customers.


I too am seeing random hard freezes on my amd framework in windows 11… so far three times over about 20th of use.

I previously thought it only happened on battery power… just after posting of course it decides to hang whilst plugged in.

I also have the framework driver package and haven’t updated it.


It might be helpful if we document what we were doing when the crashes occured. For example, crashes while gaming are less worrisome than crashes while idling on the desktop, or crashes while web browsing. Plus it could have some future value in trying to track down the source of this issue. Just my two cents.

Best of luck all. I have yet to see the DPC watchdog violation, and in fact Event Viewer seems to have quieted down entirely, generating just an error or two on boot. I don’t see any critical events in event viewer, save one unclean shutdown due to Windows Update hanging.

I just had a crash with my fw13 amd7640 on Fedora 39.
2x32GB RAM and 1TB SSD.
Suddently I had my mouse/keyboard stopping working, the screen which turned black and back. I had to force a reboot. First time it happened since I received my Framework 2 weeks ago.


For me, the crashes have exclusively happened under low workloads. The ones I can recall have been:

  • Using Firefox, just browsing, not watching videos with a handful of tabs
  • Using VS Code with Docker running in WSL (most frequent activity when BSODs occur)
  • Editing a tiny vector graphic in Affinity Designer

Like I say, all lightweight workloads where the system isn’t being pushed. In my experience, Framework’s driver pack seems a lot more volatile than AMD’s provided drivers.

Support have asked me to run the laptop on one stick of RAM, 8GB for me, very painful haha


One thing that I find somewhat encouraging is that I have yet to see this issue reported at all under linux. If it really is the case that one driver set is less stable than the other, these two things in combination seem to suggest that it might be an issue with the Windows drivers.

Of course, open source AMD “drivers” in the mainline linux kernel don’t have feature parity with the closed source drivers, so it’s also feasible that the offending hardware is not in use at all on a stock linux installation.

Are you running the latest drivers from AMD on your machine? It could also be useful to compare which driver version we’re running. Perhaps one is more stable than the others? I have only been using my FW13 a few days, but the 11/1 WHQL set (drivers only, no Adrenalin) seems to be working for me so far. I’m not much of a good sample at the moment.

Hopefully you can get your machine back to full spec soon.

Here is something which might permit some additional info collection for FW support. It could also cause your system to hang though, so be careful.

Another FW13 AMD user here with persistent, frequent BSODs / random freezes. I’ve not looked into what’s going on because it’s the first Windows machine we’ve had in the house since, uh, about Win 2k. It’s freezing under fairly low load conditions (running Libre office, editing a single page document, scrolling). It’s reached the point of making the laptop nearly unusable, since today it’s frozen twice in a 5 minute period (freeze - hard reboot - BSOD - reboot and apparently working…).

Framework really need to respont to this, urgently. My wife’s not into computers and bought into the framework concept coming from the Mac ecosystem and she is not happy right now.


Which batch? Have you contacted support? Have you tried updating your BIOS?

I am using the latest 3.03 bios…

I disabled the “Radeon Software Startup Task’ from the startup apps… it hasn’t frozen since I did that.

I can run word, browse, play games etc… I did that for 24hr without a lockup.

I then manually started the AMD Software app and about 40mins later the machine locked up.

I will run the machine without the Radeon software for a bit and see if it locks up.


1 Like

Following up with my current status. I have a 7840U, non-DIY, 32gb (which is two sticks of ram).

I have had crashes under similar workloads as Random hard freezes fw13 amd7840u win11 - #115 by Stephen_Wright Specifically BSOD of DPC_WATCHDOG_VIOLATION

Through extensive testing and process of elimination with support, I believe a single stick of RAM is faulty in my laptop. I am still testing as I want to ensure that slot 0 and slot 1 of the mainboard do not have an issue and it’s just a specific stick of RAM.

Some helpful tools

  • View reliability history - This is quicker/easier to show history of crashes/errors than digging through Event Viewer on Windows
  • BlueScreenView from NirSoft - Blue screen of death (STOP error) information in dump files. - An easier way to look at MiniDumps/BSOD to get an idea of what happened after reboot.

Interestingly neither Memtest86 or Windows Memory Diagnostic found any issues. Memtest86 does not work well with the screen, if left alone for long enough it will auto run and you can later examine the file written back to the USB drive to see the result.

Edit: To clarify, I’ve been running the system for 5 days on a single stick of ram, with the “bad” stick removed, swapping which slot the “good” stick is in 2 days ago. I have had no crashes, using the normal workloads. Drivers are the Windows 11 and Framework Driver bundle. Bios is 3.03


Well then, let’s see what RAM everyone is using.
Crucial 5600 2x16 CT2K16G56CS5
windows 11 22631.2861
AMD 23.12.1
Slot 1: USBC
Slot 2: HDMI
Slot 3: USBA
Slot 4: USBC
Haven’t used the laptop much this week, so no blue screens for me, but am starting to narrow down my audio issues. Seems to be a sleep problem (thinking drivers) as when I hibernate, it fixes them.
Unrelated, but does anyone else find it funny that when you install AMD’s driver package and go to search it by bringing up start (win key) and searching “amd” the only thing you get is “AMD bug report tool”? I had to manually add a shortcut to radeonsoftware.exe to be able to bring their software up in windows search.

Suffered from this issue and removed my HDMI expansion card and replaced it with another USB-C passthrough. Right now I am rolling 3 USB-C expansion cards and a USB-A card.

Since I removed the HDMI expansion card – I have not experienced a blue screen yet. It has been around a week since I removed it. Keeping my fingers crossed.

I am running
Kingston Impact Fury 5600 2x32 KF556S40IB-32
Windows 11 Version 10.0.22631 Build 22631
AMD 23.12.1

1 Like

My issue was completely resolved upon installing a supported kit, i tried it with the 8gb hynix kit to confirm which is like $26 on ebay. It you want to roll the dice on that i learned my ram was the issue after testing it in another laptop. Good Luck guys!