Random hard freezes fw13 amd7840u win11

will report back with updates!

I’ve been having this exact same issue. My main suspicion was that it was my use of 4800mhz RAM (as was framework support’s, so they wouldn’t help me any further unless I got 5600mhz), but if other people are getting it with 5600mhz, that’d sure save me money. Here’s my dumps, if it helps. Dumps - Google Drive

I got a response from support, and so far I’ve only been asked to re-seat the memory and provide specs for my RAM and SSD since I didn’t purchase those from FW. Also to note it here, I have a 1TB SK Hynix P31, and the rather popular 2x16 Crucial 5600MT/s (CT2K16G56C46S5). I did inform them that I ran memtest for a good while and the memory seemed to check out. I also shared with them the same updates I posted earlier in this thread.

One suggestion for narrowing things down further (in the same e-mail where I was asked to provide more hardware info) was to remove expansion cards in case a faulty card was responsible. Given that my Win11 install has been stable for 10 days, and that I’m essentially looking for a crash to test a hypothesis, I haven’t done that yet to avoid eliminating multiple variables before the next possible crash. Nevertheless, I guess removing expansion cards might help some of you. I’ll update this thread once I get a response (or a BSOD!).

2 Likes

Framework support decided to blame the fact that I’m “running unsupported ram” on the issue, which I personally think is much further from the issue. I replied saying that there are multiple people, which there are, having the same issue with the official 5600 MT/s kit. I’ll keep you guys updated.

1 Like

Same issue here; I got the 5600MT/s RAM from Framework just in case there were any weird compatibility issues. I’ve had a couple hard freezes in Windows 11 occur randomly, same as folks are describing here. I haven’t waited too long to reboot after the freezes occur so I don’t think there were any relevant events logged. I’ll try to wait next time, though I don’t know how long makes sense to wait; typically when a hard freeze occurs on other hardware I’ve worked with, it’ll stay like that for hours/days until you reboot it manually… FWIW I started with the Framework driver set, but upgraded the AMD drivers.

I haven’t waited too long to reboot after the freezes occur so I don’t think there were any relevant events logged. I’ll try to wait next time, though I don’t know how long makes sense to wait;

For what it’s worth, usually after about 2-3 minutes of the hard freeze it then bluescreens for me as a DPC_WATCHDOG_VIOLATION.

1 Like

I was just about to write that it seems like my issue has disappeared since I didn’t have any freezes since my op. However, it just happened again. I waited 3 min and the fw bluescreened and rebooted. Here is the event viewer log:

Log Name: Microsoft-Windows-Kernel-EventTracing/Admin
Source: Microsoft-Windows-Kernel-EventTracing
Date: 16/11/2023 09:55:46
Event ID: 3
Task Category: Session
Level: Error
Keywords: Session
User: SYSTEM
Computer: framework
Description:
Session “ReadyBoot” stopped due to the following error: 0xC0000188
Event Xml:



3
1
2
2
14
0x8000000000000010

54


Microsoft-Windows-Kernel-EventTracing/Admin
framework



ReadyBoot
C:\Windows\Prefetch\ReadyBoot\ReadyBoot.etl
3221225864
276824064
0

Same issues here and so far support has not responded to my reply, gonna open another ticket if i dont get a response.

I’m also getting the DPC_WATCHDOG_VIOLATION BSOD on Windows 11 with my AMD Framework 13.

I’ve noticed that it only ever happens when I’m on battery and usually 5 - 10 minutes after resuming from sleep.

The system will freeze, usually the mouse first and the keyboard will either lag or stop responding. Then after sitting frozen for around a minute or two the system will blue screen with the error:

DPC_WATCHDOG_VIOLATION

The error dump varies, here are a few of the different errors I’ve found in the Windows maintenance log:

Problem signature
Problem Event Name:	LiveKernelEvent
Code:	1d4
Parameter 1:	0
Parameter 2:	5
Parameter 3:	ffffcf0a9de7b110
Parameter 4:	102
OS version:	10_0_22631
Service Pack:	0_0
Product:	256_1
OS Version:	10.0.22631.2.0.0.256.4
Locale ID:	2057

Extra information about the problem
Bucket ID:	LKD_0x1D4_COMMAND_TIMEOUT_0x5_UcmUcsiAcpiClient_UcmUcsiCx!UcmUcsiCx::GenerateUcsiFailureDump
Problem signature
Problem Event Name:	LiveKernelEvent
Code:	a1000001
Parameter 1:	1
Parameter 2:	0
Parameter 3:	0
Parameter 4:	0
OS version:	10_0_22631
Service Pack:	0_0
Product:	256_1
OS Version:	10.0.22631.2.0.0.256.4
Locale ID:	2057

Extra information about the problem
Bucket ID:	LKD_0xA1000001_amdfendr!unknown_function
Server information:	914e99eb-6aef-4364-983d-9b1ec43abb0f
Problem signature
Problem Event Name:	BlueScreen
Code:	133
Parameter 1:	1
Parameter 2:	1e00
Parameter 3:	fffff8023431d340
Parameter 4:	0
OS version:	10_0_22631
Service Pack:	0_0
Product:	256_1
OS Version:	10.0.22631.2.0.0.256.4
Locale ID:	2057

Extra information about the problem
Bucket ID:	0x133_ISR_amdgpio2!unknown_function

I’m running the most up-to-date drivers from AMD directly for both chipset and GPU.
Windows 11 is fully up to date
I’m using Framework RAM
Running BIOS 3.03.
I’ve checked all the internal connections and reseated the memory and SSD.

I haven’t raised a ticket yet but will do so.

I have been getting random crashes on my AMD fw13 too. Today I updated my drivers using the AMD autodetect tool, but got a crash just now after a few hours of up time.
This time it went to a BSOD rather than just hanging indefinitely and made a minidmp.
Here is the callstack from the dump using windbg.

[0x0]   nt!KeBugCheckEx   0xffffa9818332ac88   0xfffff80456a12d55   
[0x1]   nt!KeAccumulateTicks+0x3d5   0xffffa9818332ac90   0xfffff80456a12421   
[0x2]   nt!KiUpdateRunTime+0xd1   0xffffa9818332acf0   0xfffff80456a104b1   
[0x3]   nt!KeClockInterruptNotify+0xc1   0xffffa9818332aea0   0xfffff80456a0feda   
[0x4]   nt!HalpTimerClockInterrupt+0x10a   0xffffa9818332af40   0xfffff80456b24c4c   
[0x5]   nt!KiCallInterruptServiceRoutine+0x9c   0xffffa9818332af70   0xfffff80456c18ada   
[0x6]   nt!KiInterruptSubDispatchNoLockNoEtw+0xfa   0xffffa9818332afb0   0xfffff80456c19347   
[0x7]   nt!KiInterruptDispatchNoLockNoEtw+0x37   0xffff940b270d6a30   0xfffff80456a8f032   
[0x8]   nt!KxWaitForLockOwnerShip+0x62   0xffff940b270d6bc0   0xfffff80456a443e6   
[0x9]   nt!KeAcquireInStackQueuedSpinLockAtDpcLevel+0x36   0xffff940b270d6c20   0xfffff80454e1aba7   
[0xa]   dxgmms2!VidSchDdiNotifyDpc+0xc7   0xffff940b270d6c50   0xfffff8045aab31b9   
[0xb]   dxgkrnl!DxgNotifyDpcCB+0x99   0xffff940b270d6cc0   0xfffff804a3174d17   
[0xc]   amdkmdag + 0x534d17!amdkmdag+0x534d17   0xffff940b270d6da0   0x0   

Judging from the callstack, the AMD driver does seem to be the cause in this case.

Hi all. I was encountering BSODs, and found a solution (at least for me). Basically, they only happened on battery and when the PCI Express Link State Management was set to Maximum Power Savings on battery (the default). Since changing the setting to Moderate, I have had no further issues.

You need to open “Edit Power Plan”, then “Change Advanced Settings” and then modify the PCI Express setting.

4 Likes

I just had another one. I just edited the Power Plan as you’ve described, let’s see if it helps. Thx for sharing!

Btw, are there any news from people who have contacted fw support with regard to this issue?

Thanks for this tip. I just encountered the DPC_Watchdog_Violation BSOD crash, while on battery. I just made that Power Setting change. I’ll report back!

Yep, same issue here! Hoping Framework or AMD address this ASAP. Happens sporadically for me, so I cannot reproduce reliably.

I’m guessing this is a universal issue, right?

I’ve had my AMD 13 for about 2 weeks and have had the same lockups described here. Each time, the mouse stutters, then the whole system freezes. I mostly use the laptop for browsing the web, so it’s no surprise that it has always happened when I go to open a new tab in Edge. Edge uses HW acceleration so I wonder if the GPU drivers are involved.

It has happened while plugged in as well as on battery. I have the latest BIOS, latest AMD drivers and Win11. I am running 2x16GB g.Skill 5600 CL40 RAM and a Solidigm SSD. I have run the Win11 RAM test in the thorough mode and it found no problems. I will try changing the PCI Express Link State next and see what happens.

1 Like

I have had mine for about a month and I have the same issue. Sometimes the display turns into a bunch of color blocks so my guess is it’s the AMD graphics driver. It only happens on Windows.

Edit: After 24h of using the PCI Express “fix”, it’s crashed 3-4 times. So, uh, that doesn’t work, unfortunately.

I have been in close contact with support on this issue, there isn’t much to report back yet as I am waiting on my supported ram kit to come in. Is anyone else using 4800Mhz ram that is experiencing this issue?

Thx @sgilderd for the suggestion. I’ve been having these freezes everyday at least twice since I got the laptop (5 days ago). However, I guess there has been a decrease in the frequency as I got 4 freezes on the second day after building the laptop up.

I just modified the PCI express settings and I’ll comment back in three days or so to give a feedback. Hope it works out!

Edit : it just froze twice already halfway through the morning…

I got my fw 13 diy edition yesterday and had it freeze this morning while just web browsing. It also went to blue screen and then shut down.

I was on battery power also.

Windows 11 pro, kingston fury 5600 2 x 32 ram and wd black SN850X 2tb ssd.

Just updated the amd drivers and will see how it goes…

Same experience here, initially. Random stuttering, freezing and eventually a blue screen. Only one event produced a full MEMORY.DUMP file.

Windows 11 Pro, Kingston fury 5600 2 x 32 RAM and Samsung 980 Pro 1 TB SSD. No tweaks other than following the knowledgebase instructions for allocating more RAM for video. Main computer used about 4 hrs/day for web surfing, videos and light gaming.

This was an opportunity to learn the basics of WinDbg to analyze the minidump crash files. The results consistently pointed to a faulting graphics driver.

Two solutions seem to have worked.
First, installing the latest AMD Adrenaline software downloaded directly from AMD. No blue screens since.
Second, installing OpenSuse Tumbleweed Linux as a dual-boot setup. It just works, although it did take some research and fiddling to get the touchpad and fingerprint reader working satisfactorily. Has not crashed once though. Happily, Wayland and KDE work beautifully with this incredible hardware, such a leap forward from the old ThinkPad.

3 Likes