Reset fingerprint scanner

I reinstalled my OS and when I went to re-enroll my fingerprint, I’m getting this error message:

fprintd[4545]: Device reported an error during enroll: Finger is too similar to another, try use a different finger

It seems like the scanner remembers my finger from the previous installation. Is there a way to make it forget this permanently so I can re-enroll? I am running manjaro.

Possibly use drive wiping tools to wipe the disk completely and try again.

1 Like

When you say you reinstalled, did you wipe the old installation, and start again, or did you just install on top of?

If you wiped it away, then the issue is with the fingerprint hardware itself, and is known by Framework. They are working with Goodix to find a solution.


Yeah it was a full wipe. Is there a thread I can follow with regards to this hardware bug?

There is a thread about libfprint that has a script that might help you.

1 Like

Wanted to update that this script worked perfectly. Thank you!

I’m trying to run this script to clear out the fingerprint reader’s memory, but am getting an error:

Traceback (most recent call last):
  File "/home/ryebread/Downloads/", line 13, in <module>
    require_version('FPrint', '2.0')
  File "/usr/lib/python3/dist-packages/gi/", line 126, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace FPrint not available

i’m not sure what it means by Namespace FPrint not available as i have fprint installed


using the appimage program from this post resolved the issue: Fingerprint scanner compatibility with linux (ubuntu, fedora, etc) - #214 by Devyn_Cairns


After switching from a broken Manjaro to Ubuntu 22.04 and struggling with clearing the fingerprint memory, I was able to clear and reset fingerprints using the fprint guide from Arch wiki. Specifically,

$ fprintd-delete "$USER"

I then used the Gnome user settings to re-enroll my fingerprints.

Unlike Manjaro, which uses fingerprint authentication for all login and sudo privileges, Ubuntu only uses fingerprints for login.

Interesting (to me) note: I just re-installed Manjaro alongside Ubuntu 22.04 (which has fingerprint authentication enabled). I was able to enroll my fingerprint in Manjaro without having to run the above first, which surprised me.

I ran the AppImage and this is what I got. Problem still not fixed.

Did you run the AppImage with sudo? Seems like that might be the problem, maybe.

1 Like