[RESOLVED] 12th Gen Won’t POST. All 12 green and BGGGGGGG

I was quite happy with my Framework laptop until it stopped booting up after I took it on its first 7 hour flight or first flight ever. OS is Fedora 37. Installed with WD Black SN770 2TB Nvme and 2x32GB Crucial NB 3200Mhz memory.

I used it during my flight for about 3 hrs and had about 20% battery left. Closed the lid(auto sleep) and put it back in my bag. When I landed at the airport I tried to used it to charge my phone and found it won’t boot. The power button lit and screen is black without backlight.
After about 15 seconds the side status light came blinking.
First W then 12 Greens. After one Red, 1
Blue then 7 Greens. So, the POST code is 00000001 or 0x01? Dead right after starting the CPU?


I thought it was memory problem so I removed one side, swapped sides, removed nvme etc. Even tried to boot without memory at all and still got the same status lights, all 12 Green and 1 Blue + 7 Greens.

Is the CPU dead? Did a burst of cosmic ray go thru the CPU and killed it? Am I that lucky?

I’ve tried to reset the bios twice but no luck.


Maybe try to hard reset your BIOS by deconnecting the main battery and removing the RTC battery for 10 minutes…

Other than that, yeah Support is your friend, especially as it smells of a hardware problem…

On the bright side, yes you may have an extraordinary luck with cosmic rays lol ^^

1 Like

Based on what you’re describing, this sounds like a hardware malfunction. Please reach out to support for hardware assistance.


Got replacement mainboard. Everything works now!