[RESOLVED] Battery claiming drastic drop in health after updating to BIOS 3.03

I got my Framework 16 a number of weeks ago (batch 4) and everything was fine until recently. Now the battery claims to be at 71% health, which is a pretty drastic drop from the 99% it was at before. I had the charge limit set to 95%, but powerdevil (KDE) is aware of that and updates the numbers accordingly. Besides, 71% is quite a ways off from 95%.

I can’t be absolutely certain, but I think this happened when I updated to BIOS 3.03. I noticed the battery health issue about a week ago and I updated the BIOS about a week ago. Pretty coincidental timing. And a precipitous drop from ~100% to ~70% in a few days seems physically unrealistic unless I got a complete lemon of a battery. I reverted the charge limit to 100% but it’s still not charging past 60Wh.

Is anyone else having this issue? Did it happen at the same time that you updated the BIOS?

A BIOS update likely should not affect your battery. The only case would be if the battery charge level was set by the BIOS to be way lower which likely didn’t happen otherwise there would probably be way more posts about this. This is likely not caused by the BIOS update (I’m not 100% sure. Maybe there may have been conflicts with the updater and your settings?).

Battery health from 99% to 70% is nowhere near the levels a battery is supposed to degrade.

If you have a copy of windows, I would suggest running powercfg /batteryreport to see if windows is reporting the same decline in battery health. Otherwise maybe another operating system to make sure that your Linux install isn’t reading the sensors wrong.

If both windows or another linux distro says that the battery is at 70% health or a drastically lower battery capacity from design capacity, I recommend reaching out to support and get them to send you a replacement battery cause your current battery is likely defective.

Hope you fix your issue!

On Linux you can
$ upower -e
to display the power devices, copy the line containing the word “battery”"
$ upower -i pasting the line you just copied

If the battery is still degraded, I would recommend setting the charge limit to 100% and to a full discharge cycle

1 Like

KDE’s info center said the last full charge was just under 60Wh. I’m not completely certain but I’m pretty sure that info is coming from the hardware - the values are exactly the same as what upower reports. I had left it plugged in while shut down at least once and it never got above 60Wh.

But today when I reset the charge limit to 100% and left it plugged in and shut down for a few hours, it charged back to 85Wh and now the battery health is reported at 100%. It definitely seems like something screwy was happening. I still think it was related to the BIOS update given the timing, but it works now so :person_shrugging:

1 Like

If it never gets to go to 100% (or 0 for that matter) the coulomb counter in the battery can drift quite a lot.

It is not entirely impossible that the bios update did something that confused the battery controller during the bios update but not extremely likely. Ultimately the issue was the battery controller being confused and not the bios.