[RESOLVED] Cannot render AWS Workspace


I have a Framework Laptop 13 AMD Ryzen™ 5 7640U, DDR5-5600 - 32GB

OS - Tried both Rocky Linux 9.3 and Ubuntu 22.04.3

My work requires me to dev in an AWS workspace. I am currently unable to login to the workspace from the framework laptop. I have tried both the web interface and the linux native app. I am able to authenticate but the desktop is not able to render.

On the web interface, the console is throwing ‘Error while changing resolution’ errors and in the app it is throwing ‘Unknown device / gl’ errors.

I have no issue from my windows PC. I have tried both Rocky Linux and Ubuntu, I really don’t want to install windows to try it on that OS also.

Has anyone seen or been able to work around this?


Welcome to the community!

Did some digging on this as I am not a user of AWS Workspace. Feels like it a potential AMDGPU compatibility issue. Worse, searching their docs didn’t indicate anything useful, either.

Let’s see if we can get a better handle on what is going on.

  • Focusing on Ubuntu 22.04.3, which kernel are you on by chance?
  • When trying to login and seeing the failure, please have a terminal open with the following running: journalctl -f (This will provide you with some real time feedback as to what the actual error is and may give us a direction to take this.
  • If it is as I suspect, AWS Workspace presenting a compatibility with the brand new hardware, it will show up in that log output.

Hi Matt,

Greatly appreciate the quick response. This one was user error on my part

Apparently my workspace was setup as a PCoIP, and the Ubuntu 22.04 client, (apparently along with the web client) only support WSP. I installed the older 20.04 Ubuntu client and I am able to connect.

Apologies for the time waste


No worries, delighted this has been resolved! :slight_smile: