[RESOLVED] dGPU not suspending under Debian 13 (Trixie/testing) .. I think

Context: up-to-date, using amdgpu firmware from the linux-firmware git, tested both kernels 6.7.9 (from unstable/sid) and 6.6.15. Xfce 4.18. power-profiles-daemon 0.20 on power-saver.

/sys/class/drm/card1/device/power/runtime_status is forever at active, even with Xorg not running, as well as during ‘rescue mode’. nvtop reports no dGPU activity. Tried telling lm-sensors to ignore the dGPU [1] which did drop the idle power usage I was seeing by roughly half but didn’t let the dGPU suspend. However, it did lead to things taking a couple seconds to load when they did use the dGPU (tested with vkcube and glxgears) and waiting for the 5s timeout, so perhaps this is just an issue with the amdgpu driver in these kernels not reporting power state changes? I don’t currently have an easy way of testing 6.8.x or newer 6.7.x to verify.

[1] Suggested here by motsky80

Have you tried using this as well?

I hadn’t, as I was manually checking the sysfs files that script does. However, I am apparently blind and hadn’t realized that card0 is the dGPU, not card1. I was certain I had verified this days ago. card0/device/power/runtime_status is indeed reporting suspended.

Apologies for the now-apparently dumb question.

Ahh yeah. It’s reversed in Debian based distros for some reason. Glad you got it sorted. This post will probably help out someone else so it’s all good.