[RESOLVED] EndeavourOS won't boot on AMD with secure boot enabled

When upgrading my framework 13 to the Ryzen 7040 mainboard, I got an error that I couldn’t find anywhere online. So I’m documenting it here, now that I have the solution:

EFI Hard Drive (SJB8N709511908Q5S-SHPP41-2000GM) boot failed.

The solution was to disable secure boot, then the error message disappeared and everything is working fine.

Interestingly, this seems to affect EndeavourOS, but not Fedora. While troubleshooting, I tried booting EndeavourOS on a live USB, and that had the exact same issue. But when I tried Fedora on the same USB drive, it booted just fine.

Some other details:

  • the SSD is a 2TB SK Hynix P41 Platinum
  • my ram is G.Skill F5-4800S3434A16GA2-RS
  • I upgraded from Intel 11th gen i5 to Ryzen 5 7640

This is because EndeavourOS doesn’t ship images signed for Secure Boot, while Fedora (and some other major Linux distros like Debian, Ubuntu etc) does.

6 Likes

I think that what probably happened is that:

  1. when I installed it on intel 11th gen, I got a different error message, googled it, and found the solution
  2. I forgot that I had disabled secure boot back then, and since the Ryzen mainboard is so new, there weren’t any search results for this exact error message

Glad this was resolved.