[RESOLVED] Issues following fingerprint reader and BIOS update guides for AMD

I’ve just assembled my new Framework Laptop 13 with AMD Ryzen 5 7640U. I’ve been following the guide closely getting Fedora 39 Beta booted up, and have encountered 2 problems not addressed in the guides.
First, when following the guide to get the fingerprint scanner working, things go reasonably smoothly until I try to run

sudo fwupdtool install --allow-reinstall --allow-older goodix-moc-609c-v01000330.cab

which thinks for a second before returning

Waiting… [************************************** ]01:11:59.846 FuEngine failed to add device usb:01:00:04: failed to claim interface 0x00: USB error on device 27c6:609c : Resource busy [-6]
failed to get device before update reload: failed to wait for device: device 23ec719b6aabc2d2dac5176c232f0da7a21881b0 did not come back

I can live without the fingerprint scanner for a while, but I encountered my next and more critical issue when attempting to upgrade to the latest BIOS.
The first step in the Linux BIOS update guide is to run

sudo nano /etc/fwupd/uefi_capsule.conf

To uncomment/comment some things. However, running this command for me simply opens up a blank nano file because


Doesn’t exist. The contents of




and nothing else.
Any help would be appreciated.

Fedora Linux 39 (Workstation Edition)
Framework Laptop 13 AMD Ryzen 7040 Series
Ryzen 5 7640U


Vendor: INSYDE Corp.
Version: 03.02
Release Date: 09/27/2023

Thank you!

When updating (with Debian 12 however), I didn’t have to modify a file like that, just enabling the testing repo worked. I would try just skipping it.

When the device is busy, it’s been utilized. Reboot your computer and it should no longer be in use. I had to retry the installation of the cab file a few times get it to flash.

Use the EFI USB method to update your BIOS firmware, personally could not do it with fwupd and fwupd maintainers seem to be aware of that problem. If you want to help them out before updating, checkout this issue on their Github : Failed to connect to daemon · Issue #6308 · fwupd/fwupd · GitHub


Welcome to the community, @sagbobbit!

As Shijikori points out, this will likely be resolved with a reboot. I’d reboot and try again.

This was an error in the guide not explaining Ubuntu LTS and Fedora, and it has been corrected. You will jump past the uefi_capsule section and dive right into:

(Fedora users, start here - Ubuntu LTS users, continue here) With the battery slightly drained below 100%; 98 or lower is good, connect to AC power and run the following command:

fwupdmgr refresh

fwupdmgr get-updates

fwupdmgr update

This will take awhile and you can expect it to reboot on its own. Do not force the power off as this will interrupt the process - allow rebooting to happen naturally.

3.03 is no longer in the beta status and will be available as a stable release without lvfs-testing, just follow the steps above.

1 Like

Thanks. I’d already tried rebooting several times but one more time did the trick, fingerprint scanner is working now (at least in theory, because I haven’t been able to actually sign in with it but that’s troubleshooting for another day). BIOS update went smoothly with EFI method. One thing to point out @Matt_Hartley - the BIOS update guide specifies

  1. Disable secure boot in BIOS (tap F2 while booting, navigate to Security → Secure Boot, and set Enforce Secure Boot to Disabled. Press F10 to save and exit.)

while, at least in my version of the BIOS, it was under something like Boot Options, and not under Security. If you want I can reboot to BIOS and look again to see exactly where it is. It’s a small thing but it caused me to have to hunt for a while and other people might not be able to find it.

Thanks so much.

Appreciate the feedback, I’ll see what we can do to further dial that in with the instructions.

Fingerprint reader should work, per the guide under Users for Ubuntu 22.04.3 and Fedora. Both GNOME.

I had the same issue with the fingerprint reader on my AMD Framework. From the behavior, I think some process was starting that kept taking over the fingerprint reader. I tried several times to boot up and race to the terminal and run the command, but it always got cut off part way through.

I ended up booting into recovery mode and booting into a root shell to run the update. Then it worked perfectly. I rebooted into the GUI and the fingerprint reader works now.

1 Like

Experiencing a very similar issue to OP here on ryzen 7840, bios 3.03, fedora 39. I’d love to be able to get this issue fixed and this is the only thread I could find describing it…

@Jeremy_Kastner Could you explain what ‘recovery mode’ is and how I can boot into it? I’m aware of rescue mode but not sure if that’s the same thing

same, stuck on the fingerprint update with the same error when try to up date it

Added to the KB article:

NOTE: Disable Secure Boot before you update your fingerprint firmware.

  • Boot into BIOS by tapping F2 just before the Framework splash screen.

  • Arrow down to Administer Secure Boot. Press enter.

  • Arrow down to Enforce Secure Boot. Press enter, select Disabled, press enter.

  • Press F10 to save and reboot. With Yes selected, press Enter.