[RESOLVED] Kernel 6.4 hang at boot TPM Bug Confirmed

Confirmed this fixed my boot hang at “ima: Allocated hash …” with TPM enabled in BIOS.
Thanks much.

1 Like

Confirmed here too.

Still the bug needs to be solved as this workaround would need some digging for newcomers.

Maybe we should link this discussion into the wiki of the various distributions starting with Arch (as is notoriously appreciated distros-wide.).

@Koma Framework Laptop 13 - ArchWiki


I can confirm I had this issue on the gentoo distibution kernel (gentoo-kernel-bin) 6.4.3, and adding the tpm_tis.interrupts=0 resolved the issue. I’ve also noted it in the Gentoo wiki here: Framework Laptop - Gentoo Wiki


This looks to be fixed in the latest Linux kernel release 6.4.4:


“tpm/tpm_tis: Disable interrupts for Framework Laptop Intel 13th gen
tpm/tpm_tis: Disable interrupts for Framework Laptop Intel 12th gen”

The kernel parameter “tpm_tis.interrupts=0” won’t be needed after upgrading to that kernel.

1 Like

After upgrading to kernel 6.4.4 from the Arch testing repositories, and removing the “tpm_tis.interrupts=0” kernel parameter, I can confirm that I didn’t experience this issue on the Framework Laptop Intel 12th gen i5-1240p model.


Appreciate all the helpful details. Can we get a summary of each distro and release affected? I want to see if this affects Arch only or other distros as well. Please reply with:

Release (rolling releases like Arch just respond with Arch again):

Kernel: 6.4.0 - 6.4.3
Distro: Arch
Release: Arch

1 Like

Kernel: 6.4.4
Distro: arch
Release (rolling releases like Arch just respond with Arch again): arch

I can confirm kernel 6.4.4 fixes the issue

1 Like

Kernel: 6.4.2
Distro: Gentoo

I found success with this solution. Disabling the IMA kernel option and rebuilding solved the problem (.config diff).

1 Like

Kernel: 6.4.4-200.fc38.x86_64
Distro: Fedora
Release: 38 (KDE Plasma)

I can’t boot the above kernel without the tpm_tis.interrupts=0 argument even though it’s 6.4.4.

I have a Framework Laptop 13 12th gen i7-1260p on BIOS 3.0.4.


Kernel: 6.4.4.-200.fc38x86_64
Distro: Fedora
Release: 38 (Workstation)

Had to tadd the tpm_tls.interrupts=0 argument to get it to boot. This was not broken previously. This is with a 12th gen I7-1260p with BIOS 3.06.


The fixing patches for framework laptop got cherry picked for Arch 6.4.4.
The patches for Framework laptop are part of the official kernel 6.4.5:


Confirming fedora 38 6.4.4 is broken and that adding tpm_tis.interrupts=0 to the kernel args via grubby fixed it

1 Like

My FWL 13 with the Intel Core i5-1240p just got the 6.4.4 update on Fedora (KDE spin) and won’t boot that kernel. I could temporarily disable TPM but my system dual-boots with Windows 11 which I use for college so I’d rather only do it as a last resort. Hopefully it gets fixed in a later kernel release. Thankfully GRUB makes it easy to boot into earlier kernels.

You can use tpm_tis.interrupts=0 kernel boot parameter to fix it without disabling TPM in BIOS.

Updated my Fedora 38 Workstation install to 6.4.4-200 and was getting a hang at boot on my 12th gen i5 FW, disabled TPM for the time being since I’ve only ever run Fedora. I have an external SSD with Windows 11 for client work and it works fine.

Added the tpm_tis.interrupts=0 via grubby worked for me also.

1 Like

Is anyone else finding this is helping for 6.4.4 on Fedora 38?

1 Like

Just started up my Framework 12th gen i7, running Fedora Linux 38. It’s hanging on startup, all I see is the Framework logo on black screen. After shutting down and restarting I get a kernel chooser list with 4 Fedora Linux options plus the UEFI settings. The first two kernel options are for 6.4.4-200.fc38.x86_64 38 (Workspace Edition) and 6.3.12-200.fc38.x86_64 38 (Workspace Edition). Neither of these starts the OS. The third option is 6.3.11-200.fc38.x86_64 38 (Workspace Edition). This one loads the OS as normal, but when I restart the laptop tries to load 6.4.4-200 again and fails, so I have to go through the whole process again.

Is this a fixable thing? I can’t see any talk about problems with 6.3.12 or 6.4.4 but I’ve tried this quite a few times now and it reliably fails.

Any thoughts or advice?