[RESOLVED] Kernel 6.4 hang at boot TPM Bug Confirmed

Please try this from the terminal and reboot:

sudo grubby --update-kernel=ALL --args=“tpm_tis.interrupts=0”

1 Like

Merging to the existing thread. (done)

Many thanks @Matt_Hartley. I’m afraid that didn’t improve the situation but I see now that it’s a biggie so I’ll await developments.

Kernel: 6.4.4.-200.fc38x86_64
Distro: Fedora
Release: 38 Workstation
Framework: i5-1240p

Had the same bootproblems, but “sudo grubby --update-kernel=ALL --args=“tpm_tis.interrupts=0”” solved it for me!


This should work for anyone single booting Fedora.

Anyone else replying, I need:

Release (rolling releases like Arch just respond with Arch again):

Super helpful if you could share the needed details mentioned above. Appreciate it - helps us with tracking this down.

And we have confirmation: 217631 – Kernel 6.4 failing to access TPM on Framework Laptop 12th gen

Pinning this.

1 Like

Sure @Matt_Hartley. I hope I’ve got this right.

Kernel: Linux 6.4.4-200.fc38.x86_64
Distro: Fedora Linux
Release (rolling releases like Arch just respond with Arch again): 6.4.4-200.fc38.x86_64 38 (Workspace Edition)

I’ve tried that tpm_tis.interrupts=0 thing a few times, it definitely isn’t taking for me.

1 Like

This is looking promising:

1 Like

Yeah, it got confirmed for official 6.4.5, after the fix in Arch in 6.4.4 through patches. I’m eagerly awaiting it for Tumbleweed, as we didin’t get specific fix, similarly to Fedora. tpm_tis.interrupts=0 works for me, but Hybernation disappeared from KDE shutdown menu (not sure if related, might be something from 6.4.x).

1 Like

Appreciate the update.

Kernel: 6.4.4.-100.fc37
Distro: Fedora
Release: 37 Workstation
Framework: i5-1240p

Booting into 6.3.12-100 worked.
I suggest changing the title to something “hang at boot” related since basically any fedora framework user (who updates their system) is affected at this point.

1 Like

Okay, on Fedora 38 on 12th Gen mainboards.

This workaround confirmed working for me on multiple 12th gen boards:

  • Boot into previous kernel from grub menu.
  • Terminal, run sudo grubby --update-kernel=ALL --args="tpm_tis.interrupts=0"
  • Reboot into 6.4.4 and it hangs for a split second, then arrives at the expected screen successfully.
  • This was done without external displays attached or anything other than power to the laptop.

Anyone who is experiencing this after running the above command and rebooting, please list the following:

  • 11th, 12th or 13th gen?
  • On GNOME, about, what CPU is listed?
1 Like

That worked for me @Matt_Hartley. The only difference this time was that I noted what you wrote and disconnected my external display before rebooting. Perhaps coincidence, perhaps not.

1 Like

Running into this on a new install today. (Framework 13, Intel)
Installed Fedora 38, everything is good (kernel 6.2.9)
Did a full dnf update, which installed kernel 6.4.4
Hangs with black screen on boot, if I select the newer kernel.
Still boots fine on 6.2.9

1 Like

ubuntu mainline (https://kernel.ubuntu.com/~kernel-ppa/mainline/)
is good starting with 6.4.6

6.4.0-6.4.3 hangs
6.4.4 and 6.4.5 don’t exist (failed builds)
6.4.6 runs

(with TPM available in bios and without tpm_tis.interrupts=0)


Awesome! Appreciate the assist! :slight_smile:

I should have added that I am using Fedora 38, gnome 44.3 as well, 12th Gen unit… Command I used: sudo grubby --args="tpm_tis.interrupts=0" --update-kernel DEFAULT

1 Like


After a software update from Fedora, my Framework 12th gen got stuck at the “Framework” splash screen during boot.

By holding down the power button to turn off, then pressing it again to turn on, it gave me the option to boot using an earlier version of the kernel (6.3.something). Once logged in, I used terminal command from this thread sudo grubby --args="tpm_tis.interrupts=0" --update-kernel DEFAULT and restarted. My laptop now boots into kernel version 6.4.4-200.fc38.x86_64 just fine.

Thank you! This is why I love my Framework. If there’s a problem with Linux I know I’ll be able to get help with it really quickly.