[RESOLVED] Keyboard stopped working 12th

I’m on windows 11 on a Framework 13 1260p.

I was uninstalling VMware and it prompted me to restart to fully uninstall it. When I did, the keyboard wouldn’t work. The backlight still worked, but none of the keystrokes were recognized in windows. I used the on screen keyboard to navigate to device manager. It was giving me an error code 19 and saying that there was a problem with the registry. I can navigate to the bios and use that fine, but I’m afraid to disable secure boot to enter a live Ubuntu environment since it could reprompt me to enter my bitlocker password and I don’t think I’ll have access to the onscreen keyboard.

EDIT: After doing some more research. I’ve found the solution thanks to this forum post. If you have the same problem as me when uninstalling VMware, follow the guy who had the same issue in the forum post and you should be good.
Ten Forums

1 Like

You might want to try to reset the embedded controller—which is in charge of the keyboard—just to see whether it is the cause of your issue.

There are two ways to do so:

  1. Hold the power button down for 20 seconds. You should see the lights on the sides flicker when the EC restarts.
  2. Leave the computer off and unplugged for 30 seconds to 1 minute.

Held down the power button and the side buttons flashed. I started up windows, but I still had the same problem. I suspect that there is something wrong with the registry since I’ve already tried to reseat the keyboard connection, reinstall the driver pack, and disable and enable the keyboard in the device manager.