[RESOLVED] Laptop was on sleep, battery drained. Now starts, but monitor stays black

After being in sleep mode during the night, my intel 11th gen starts, but monitor stays black

Sequence of events

  1. Yesterday, I worked on laptop, then closed the lid before putting it in my bag
  2. Today, when powering it on, the button was red
  3. I plugged the laptop with fw-provided USB-C charger
  4. Powering it on, button is white, but monitor stays black, and side LEDs change colors (blinking red, green, blue, then solid red)

HW/SW context

  • 11th gen
  • BIOS 3.10
  • Ubuntu 23.04

Troubleshooting steps

  1. Tried to remove memory, put back on, nothing changes
  2. I know computer is running since I can SSH it from another device, and I can have display with HDMI connector
  3. When running xrand --query, only 1 screen appears, my external monitor (thru HDMI)

What next step do you recommend?

Troubleshooting update

  1. I was able to have the internal screen work by going to BIOS (by pressing F2) when booting while still having HDMI monitor also plugged in
  2. After switching to tty3, I saw a bunch of errors, drm ERROR A/DDI A/PHY receive:

Still not able to consistently reproduce nor have screen working when booting w/o HDMI monitor plugged in

After a battery drain, maybe the laptop was doing the memory training again, thus a black screen for dozens of seconds depending on the quantity of your RAM.
But I might be wrong.

1 Like

Just as a point of reference (since I did this yesterday, last night):

My ubuntu 22.04 ryzen, w/ 3.03 bios – I closed the lid all day yesterday (unplugged, after ~1hr use off battery, booted 100%battery) … by evening (est. from 10am-8pm) it was down to 93%; next day (around noon) it was down to 83%.

1 Like

more errors appearing today (while I was trying to sudo poweroff, appearing on my HDMI-connected monitor)

Hi @Matt_Laurenceau ,

can we try and get the error messages from the previous boot?

journalctl --boot=-1  > ~/previous_boot.log
1 Like

Here you go, online!

New troubleshooting item.

By using the trick (doesn’t always work, but I’m happier when it does) to have HDMI monitor plugged in, and going into BIOS while starting, I was then able to use my laptop in standalone, with screen working.

When I then tried to move from GUI to a tty console (with ctrl-alt F2, ctrl-alt F3, etc.), it never worked, screen stayed black.

Is it a good lead to id root cause?

btw have you tried ctrl + alt + F1

whenever this happens?

1 Like

My bad, it’s F1/F2/F3 indeed, I’ll fix the previous post that was misleading

Indeed, ctrl-alt+F1 goes back to GUI mode on Ubuntu 23.04 (login screen, while F2 goes to current session, F3 to F6 go to tty ascii terminals)
And today, all of them (F1, F2, F3…) work … on HDMI-connected monitor.
Embedded monitor still black, preventing me to have a standalone laptop (BIOS trick didn’t work today, I have to be attached to external HDMI monitor) :thinking:

Any idea about root cause?

  • Definitetly looks HW
  • GPU? Embedded display?

It’s looking like a hardware issue if xrandr can’t see it. Can you try fedora live to be sure?

thanks, :slight_smile:


  • What specific tests do you want me to perform with it?
  • Will it enable to ensure it’s HW indeed?
  • Will it help us to poinpoint the faulty component? (GPU, display, cable, battery, other?)

Fedora live 39 tests.

  • Booted fine
  • HDMI external display worked first, the embedded display when system was fully started
  • After rebooting, displays were black, and by pressing Escape, saw the following errors

There is no xrand command by default, didn’t test

Some more leads:

And later on

What looks faulty?

  • CPU?
  • GPU and/or embedded monitor?
  • bluetooth too?

GOOD NEWS, embedded dispay always works now!

Support shared a couple of recommendations:

We apologize that you are having issues with the Laptop. Let me assist you.

Can you attempt the following:

  1. Please try to remove the bezel. Check if the issue will disappear.


  1. Try to​ Reseat the display cable on the mainboard


  1. Shine a flashlight near the webcam module pointing the light downward at the display. Check if you can see any images

  2. Send us photos of the following if the above solution does not work

  • a photo of the entire display with the bezel removed
  • a photo of the display cable and display connectors on the mainboard
  • a photo of the entire mainboard and its components.

And step #1 did the trick!

I actually performed it twice.
First time did nothing, but readjusting the bezel a second time (after fully powering down) was successful: I’ve been booting my laptop about 5 times since, in various states (plugged, unplugged, cold boot, reboot…) and the embedded display always works now :slight_smile:

I have now idea why the bezel could randomly prevent the display to function (could the magnets really mess hardware up?), but I’m so relieved that I don’t need to know right now, I’ll enjoy my laptop way more!

Thanks a bunch to FW Support, Brent and team!