[RESOLVED] No video with supported format and mime type found

I am getting an error when trying to view many videos in Firefox other than on YouTube on my AMD laptop. Here is an example on the Framework website:

I found instructions to install ffmpeg, additional codecs and hardware accelerated codecs here: Howto/Multimedia - RPM Fusion

However, it is not clear to me whether ffmpeg, additional codes and hardware accelerated codecs are dependencies or if they are independent solutions, nor is it clear what I actually need to install.

I am new to Linux on the desktop and I don’t want to install anything but what is the minimal necessary to play video in Firefox. What should I do?

Fedora 39
Framework 13 AMD

1 Like

Seems to be a Fedora problem. Maybe related to https://community.frame.work/t/amd-fedora-39-beta-and-firefox/

Other than being related to “video”, the symptoms don’t seem related to me. I am not experiencing any crashing or performance problems when watching video on YouTube.

If it is a Fedora problem, I’m hoping the Framework team can provide a resolution as Fedora is a supported distro.

Hi @gaben,

Did you enable the third party repositories at installation?

Before I begin having you run various commands, I’d like to understand how you changed the default installation?

Just did a clean installation, selected all the defaults per our guide, played multiple YT videos in Firefox. Can you walk me through what may be different with your configuration?

I downloaded Fedora 39 to a USB stick and did a fresh install. I enabled 3rd party repos and updated the bios to 3.03. Other than that I haven’t done any configuration other than what is possible through the GUI.

I have a Batch 1 AMD, if that matters.

On further investigation, I’m able to play video in Chrome without installation of any other software, so this must be a problem related to Firefox’s default setup under Fedora.

I think fedora by default uses a flatpak firefox that does not connect to ffmpeg for whatever reason.

There are several things you can try:

  • install the rpm firefox via dnf install firefox or firefox-wayland
  • install firefox from flathub (in the software center), then run
flatpak install flathub org.freedesktop.Platform.ffmpeg-full


I tried both of these and the behaviour didn’t change. I will continue to use other browsers as a workaround and monitor this thread if anyone else is able to document a solution.

1 Like

Removed wrong info. Correct is in link below.

Matt, could you clarify that you are testing the right thing? YouTube is working correctly. It is only other videos (HTML5?) videos that are not working correctly. The parent post has a link to a page with a video that produces the error.

1 Like

Ooof, it’s been a day - too many tabs open. Was working a YT bit a moment ago. It’s been a weird day. Sorry about that.

This should get you going successfully.

sudo dnf groupupdate multimedia --setop="install_weak_deps=False" --exclude=PackageKit-gstreamer-plugin

Now refresh this page and the video will load:

Confirmed on a clean installation of Fedora 39, AMD Ryzen 7040 Series.

Should there still be issues, add in this group:

sudo dnf groupupdate sound-and-video
1 Like

This worked without having to add in the group!

1 Like

Delighted to hear it! Marking resolved.