[RESOLVED] Performed HDMI rework power saving mod, still power draining

First time posting on this site, so apologies for anything missing in my post.

I performed the HDMI Expansion Card Power Saving Rework on my 1st Gen Expansion Card using the guide given on Framework’s website. After adding the jumper, I ran the firmware update and can confirm the both Image 1 and 2 state 3.0.16 build 105. When I initially plugged my expansion card into my laptop, I also attached a Type C USB power meter to see if there was any power draw without a monitor connected. The mod seemed to work initially with zero current being sent to the card.

I connected a monitor to the HDMI card to see if it still worked, and it did. This was all while my expansion card was connected to my power meter. But after I disconnected my monitor from the HDMI card, I noticed the power meter showing the card pushing current in the opposite direction. It was the same amount of current

that was being sent before the mod. It still draws power after several attempts of unplugging and re-plugging the HDMI card without a monitor connected.

I checked over my work, re-flowed solder on both ends of my trace, checked to make sure that the trace wasn’t touching any exposed vias on the board or other pads, and re-flashed the HDMI card. But I’m still getting power draw from the HDMI card when no monitor is connected.

Did I solder the jumper wrong? Did the firmware update screw the HDMI card up? Is it my power meter acting up? The HDMI expansion card still works as normal, but I’m not seeing the power benefits. Any help or advice would be appreciated.

I am also attaching photos:

  • Photo 1: Power draw before the mod

  • Photo 2: Power draw in opposite direction after disconnecting from monitor

OS: Windows 11
Release: Windows 11 22H2
Laptop: Framework 12th Gen i5-1240p

If you just plug in the HDMI card without the cable, does it read 0 A? Also, what BIOS version are you on?

My second photo shows 0.025A with no monitor connected after the mod.

My BIOS version is HFW30.03.04.

BIOS version should be 3.04, 3.05, or 3.06. If you haven’t updated to 3.06, you should do so. On mine, it immediately drops back to 0 A when the HDMI cable is removed so it may either be an issue with the rework or just the BIOS. Can you attach a photo of your rework?

Unless I’m not looking in the correct location, on Framework’s site, there isn’t a BIOS update for the 12th gen Intel Core board. Framework Laptop BIOS and Driver Releases (12th Gen Intel® Core™)

I meant to attach photos of the rework but Framework only allows 2 photos for a new user.

  • Photo 1: Exposed HDMI expansion card board with new trace added

  • Photo 2: Close up of the rework I performed from my microscope (the scratches were from removing conformal coating when I wanted to re-flow the solder on both ends of the trace)

Link for 3.06 BIOS: 12th Gen Intel Core BIOS 3.06 Beta

1 Like

I’m not 100% sure based on this photo but it looks like the wire isn’t making contact with the IC. But that could just be due to how much I zoomed in. Try the BIOS update and see if it fixes it.

I updated to BIOS 3.06 but I am still pulling 0.26 Amps. I apologize for the lack of contrast on my microscope photo. Both ends are bonded, as I am able to bend the rest of the cable on the board without the ends moving.

At this point, I will remove the current jumper and replace it with a new one later in the day. I will update with my progress.


I removed the previous jumper and re-soldered a new one as shown below.

The card is still showing on my meter that 0.025Amps being sent to the laptop when no monitor is connected.

The HDMI card still works when connected to a monitor.

I guess I’m just trying to find an explanation as to why my meter shows power flowing in the opposite direction when no monitor is connected. Before my mod attempt, my meter showed 0.025Amps flowing to the card (“>>>>”) while no monitor was connected, as shown in my initial post . After both attempts of adding a trace, on my meter it shows 0.025Amps flowing from the card back to the laptop (“<<<<”). This tells me I at least have a solid connection between the two solder points I created and did something.

I also could be reading my meter wrong, or its defective. I have a new one ordered coming this week just in case.

Sorry for the late update.

I found it was my USB C tester after I purchased a new one.

Thanks again to @TheTRUEAsian for initially helping me out and Framework for providing these community forums.

Now that I know this worked, I plan to perform this on another HDMI card for a personal project.