[RESOLVED] Using Framework 16 with Kamvas 12 display - no display output

(Sorry, since it involves two devices, I wasn’t sure whether to ask on Framework or ask on Huion)

I am attempting to use my FW 16 with my Kamvas 12 display. However, the Kamvas 12 simply remains in sleep mode when attempting to connect to HDMI.
(Note: Input works, it’s only display output that is not working)
I also get errors saying “Ack Failed (-110)” and “Failed to register partner alt modes (-5)” when I plug the display in.

(The display light is red when it is in sleep mode. The picture is not very good, but the display is on top of the keyboard)

I have also tried this on a fresh Windows install (after installing FW16 drivers, HUION drivers, Radeon Software, and a web browser) and on Ubuntu Live. The display is always detected, but remains in sleep mode.

(Also, even though it is detected, all operating systems list the wrong set of resolutions available)

The display also supports connection through USB-C. The display is simply not detected when trying to connect it this way (I’ve tried varying ports with expansion cards, varying ports without expansion cards, and the GPU port)

I’ve also tried the other following things:

  • Varying which ports I try to plug into
  • unplugging/plugging in expansion cards
  • Switch resolutions and refresh rates
  • Resetting the Kamvas 12 display
  • Changing RAM allocated to the GPU in the BIOS
  • Messing around with varying xrandr/arandr settings
  • Setting the DRI_PRIME environment variable when using Linux
  • Repeatedly reinstalling drivers

Lastly, I have tested both the Framework 16 and Kamvas 12 with other devices to see if they work with other devices
(testing Framework 16 HDMI port with TV)

(Testing display with Switch)

It is only when I attempt to connect the two devices (Framework 16 and Kamvas 12 display) directly to each-other that it fails to display anything.

I’ve exhausted my ideas of things to try, so if anybody else has any ideas, they would be greatly appreciated
(sadly, this may be hard to reproduce unless you have the same devices)

While HDMI mode still doesn’t work for some strange reason I will never know, my boss let me borrow another USB-C cable to try it with, and it worked!!!

1 Like