[RESOLVED] Wayland dumped core on wake

I kept noticing that after my Ryzen FW13 would be asleep and then I’d log in, all my programs would be closed. I thought I was going crazy, but then I checked journalctl and I see that I’m experiencing core dumps on wake

Nov 01 17:33:34 fedora kactivitymanagerd[71673]: The Wayland connection broke. Did the Wayland compositor die?
Nov 01 17:33:34 fedora systemd[1]: systemd-coredump@1-76012-0.service: Deactivated successfully.
Nov 01 17:33:33 fedora systemd-coredump[76013]: [🡕] Process 71458 (kwin_wayland) of user  1000 dumped core.
  Module libpipewire-module-session-manager.so from rpm pipewire-0.3.80-1.fc39.
  Module libpipewire-module-metadata.so from rpm pipewire-0.3.80-1.fc39.
  Module libpipewire-module-adapter.so from rpm pipewire-0.3.80-1.fc39.
  Module libpipewire-module-client-device.so from rpm pipewire-0.3.80-1.fc39.x86_64
  Stack trace of thread 71458:
  #0  0x00007f3444fbea99 _ZN4KWin12DrmGammaRampC2EPNS_7DrmCrtcERKSt10shared_ptrINS_19ColorTransformationEE (libkwin.so.5 + 0x3bea99)
Nov 01 17:33:33 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@1-76012-0 comm="systemd" exe="/usr/lib/systemd/systemd" host>
Nov 01 17:33:33 fedora systemd[1]: Started systemd-coredump@1-76012-0.service - Process Core Dump (PID 76012/UID 0).
Nov 01 17:33:33 fedora audit: BPF prog-id=147 op=LOAD
Nov 01 17:33:33 fedora audit: BPF prog-id=146 op=LOAD
Nov 01 17:33:33 fedora audit: BPF prog-id=145 op=LOAD
Nov 01 17:33:33 fedora kernel: Code: 55 4c 8d 6f 08 41 54 53 48 89 d3 48 83 ec 78 48 89 bd 70 ff ff ff 48 89 b5 68 ff ff ff 64 48 8b 04 25 28 00 00 00 48 89 45 c8 <48> 8b 46 20 48 89 07 48 89 f7 e8 b8 d1 fd ff >
Nov 01 17:33:33 fedora kernel: kwin_wayland[71458]: segfault at 20 ip 00007f3444fbea99 sp 00007fffeaaec3d0 error 4 in libkwin.so.5.27.8[7f3444d70000+357000] likely on CPU 12 (core 6, socket 0)
Nov 01 17:33:33 fedora audit[71458]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=71458 comm="kwin_wayland" exe="/usr/bin/kwin_wayland" sig=11 res=1

I think I saw something online about this being caused by amdgpu.

Any advice? For now I’ve switched back to X11 and am not experiencing any problems.

Hi @J3d ,

what’s your fedora version? And are you using KDE?


I faced similar wayland crashing issue. After the latest bios update today, the wayland crashing issue is gone. Not sure if you are already on Bios 3.03?

I’m on Fedora 39 KDE spin (Plasma v. 5.27.8, KDE Frameworks v. 5.111.0, kernel 6.5.8-300.fc39.x86_6). I’m also running with the amdgpu.sg_display=0 added as a kernel param to fix the white screen flashing issues.

And I’m definitely on 3.03 because I couldn’t even run Fedora KDE on the 3.02 BIOS. I updated the BIOS via flash drive before reinstalling and 3.03 solved most of my problems except for these core dumps.

This feels like a good candidate for bug filing. :slight_smile:

Bug filed: 2247634 – Wayland dumps core on wake on Ryzen Framework 13

1 Like

I ran X11 for a while and then recently decided to try Wayland again after upgrading to Fedora 39 GA and the latest kernel. I’ve been running Wayland for 2 days and so far no core dumps. So crossing fingers that this got fixed.