[RESPONDED] 1TB expansion card disconnects randomly

Having a similar issue with the 250GB expansion card which has Linux Mint installed. It has no warning and will typically happen after a command completes successfully. I’ll be unable to open or run any programs, drives will display i/o errors, and all icons disappear as they are removed from memory. The only way out is a forced shutdown. Typically I have no other devices connected aside from my internal NVME when this happens.

1 Like

FYI: I just noticed the expansion card got disconnected when I rebooted & plugged in a docking station. Can anyone try to reproduce?

1 Like

Yep I just reproduced it again and it disconnected right after I plugged in a docking station.
FYI: This is the docking station Im using:


Noticed the same thing with NixOS. I haven’t tried other ports yet.

Note in my case the issue manifests as a USB dis-/re-connect, as shown in the dmesg.

I actually haven’t experienced the issue again recently, but I haven’t done any long slow writes to it since then

Is yours also plugged directly into the laptop, and is is mounted/in use when it disconnects?

Update and possible good news!

I just recently got around to testing my new card. Definitely not a temp issue, also didn’t seem like it particularly cares if/how much your writing to the disk. Stress testing didn’t make it consistently fail faster. Only seems to fail eventually when writing, regardless of how little is written (just status log upd8s from bg processes are enough)

I was thinking it was a faulty mobo… but as I researched linux/usb disconnect problems in general and btrfs unsafe eject/re-insert issues, a few people seemed to suggest instability was common with some usb controlles with linux, a few suggesting common power management problems with usb controllers putting devices in use to sleep erroneously.

Potential workaround/source of issue

Seeing how power management issues was mentioned, I checked the bios and changed my settings from max battery to non-turbo performance.

bios -> Advanced -> Boot performance mode = Max Non-Turbo Performance

Didn’t expect anything out of it since it looked like a cpu setting to me, but I have gone a full day with no erroneous disconnects. Haven’t rebooted again yet, but seeing I made it this long when I usually cant get more than a few hours, I’m hopeful.

If your are also experiencing random usb disconnect issues, check if your bios is set to boot to max battery and switch it to performance or turbo if so. Let me know if that had any affect.

Potential STR

In a similar note, if you are bored and don’t have the issue but would like to help confirm STR (Steps To Reproduce), try the following

bios -> Advanced -> Boot performance mode = Max Battery

and see if your suddenly affected (issue usually occurs for me sometime between 5 sec and 3hrs after I start using the 1tb ssd). Note the issue only makes itself self-apparent if your writing to the device (since the fs goes ro). Also note that though my issue was noticed with the ssd expansion cards, it could still be a more generic usb problem affecting other devices.

If you want to passivly monitor if the issue has been triggered, you can watch dmesg for unexpected disconnect events via
dmesg --follow | grep -iE 'USB disconnect'

Finally, note I have only gone 24hrs without the issue, during low usage, and in a single boot cycle. It could just be a coincidence. I was grasping at straws for ways to conclude it might not be a faulty mobo so I wouldn’t have to send it back for a replacement. Even if this does work around my problem long term, its possible that not working in max battery mode is because I have a faulty mobo rather than some linux usb controller power management driver issues.


Day 2, power cycle 2. Still no issues using the same low load as before. Tomorrow I will try booting into my gentoo install on the 1tb ssd which will have a full load of the os (still kinda light usage, but a lot more than now).

I think this bios setting change is working.

Day3. No dice. Disconnected itself randomly before I got a chance to umount day 2s test.

With the bios setting change reliability is improved drastically, allowing me to make it through entire days instead of just a couple hours. However, it still eventually fails.

The combination of the fact this bios setting change improved its reliability, the fact it still eventually fails, in addition to everything I already know from previous tests, and the fact some people are running persistent linux on ssd card without issues, really pins the issue down to my mainboard. I think increased voltage or something of performance mode is helping to mask an underlying faulty hw issue

1 Like

Thank you @Shy_Guy for sharing all of yours tests, I really appreciate and I hope the problem will be solved before I receive mine.

With my laptop, I have the habit to not use the internal hard drive, and to use en external USB SSD key with my GNU/Fedora system fully encrypted (and another key to make a backup). This permit me to always have my key with me, with the possibility to run my system on many other computers/laptops if needed.

As you guessed, I’ve want the same with the Framework, I’ve not ordered internal drive, but 2x 256GB expansion cards. I hope your problem will be quickly fixed, because this will seriously affect my Framework usage too.

For folks who are seeing this occur, could you share:

  1. The BIOS version you are on.
  2. The OS you are using (if on Linux, also the kernel version)
  3. What Expansion Cards and other peripherals you have plugged into each Expansion Card bay.
1 Like
  1. 3.07
  2. Windows 11
  3. 256 GB. I usually have a USB headset connected or a docking station. But it still happens when they’re disconnected.
  1. BIOS 3.06 (I will be updating soon to see if it changes)
  2. Linux Mint 20.3 5.14, also occurred on 20.2 5.12 and 20.2 5.14. Originally I would notice because my OS would stop working (I booted from my expansion card at that time), but I’ve since migrated the OS to my internal M.2 and still experience the disconnects (my auto-mount fstab rules to mount partitions at /media/docs and /media/gamedisk will suddenly be inaccessible as it disconnected and remounted at /media/b/docs and /media/b/gamedisk). I have not used the laptop undocked in Windows 10 enough to confirm whether this occurs there as well.
    EDIT: This has occurred in Windows 10, my D: and E: drives for my two external partitions on the 256GB disconnected and reconnected mid-notetaking (no data loss because they remounted in the same spots before I went to save, thanks windows!), I had no other devices plugged in except 3 USB-C cards.
  3. Just the storage expansion and three USB-C cards, no peripherals

Thanks for information @john_doe @Be_Far.
May I know if you connect AC adaptor next to SSD expansion card when issue happened? Which means the SSD and AC is attached in the same side of laptop.

This has happened both with charger connected and disconnected, but at the times when the charger was connected, it was on the same side as the expansion card.

My charge port (usb-c) is on the opposite side of the SSD expansion card. But same as @Be_Far this happens whether it’s charging or discharging.

I’ll throw my 0.02 in, this is occurring on any OS I have installed on the External drive, Each install was done using the default settings aside from an Overprovisioning partition, so a mix of Fat32, EXT4, and BTFS. I will be in the middle of an action, such as opening a webpage, and the screen will go bank and start throwing a slew of errors to the tune of: “Systemd-journal 395 failed to write entry.” and then all the errors of the OS trying to gain RW access again. Does not succeed, and requires a hard reboot to come back.

At first, I thought it had to do with the use of TLP, but it has occurred on instances without TLP.

  1. 3.07
  2. Pop!OS 21.10 (5.15.5 (The one that ships in the ISO)
    2a) Mint 20.3 Edge (5.13.0-25, 5.15.10,5.15.5, 5.16.5, 5.16.10)
    2b) Fedora 35 (5.16.9-200)
  3. 2x USB C, 1x USB A, and 1x 256GB SSD. The only items I’ve had plugged in at the time of occurance has been the power cable or the power cable through a Belkin Ethernet to USB-C (Linked below).


Can confirm that it isn’t related to using TLP, I just had the disconnect occur on Windows 10 on my internal M.2, will be editing my post shortly

I use the 1TB card for my Steam drive. Sometimes it disconnects and reconnects, causing all kinds of errors from Steam. Sometimes Steam, as well as any other program running from that drive, crashes completely.
Using Windows 11.

Same here.
Bios: 3.07
OS: Windows 11
1Tb expansion card, 2 type c and 1 type A. No peripherals attached to those.

I use a 100gb NTFS partition on the 256 for a few steam games I want to be able to play on Windows as well as Proton. I notice the disconnects because my automount fstab rule that I set up to stop crashes (there was a tutorial) will suddenly not be in effect as my file manager saw it disconnect and remounted it in a more default behavior.