[RESPONDED] 1TB expansion card disconnects randomly

I’ll throw my 0.02 in, this is occurring on any OS I have installed on the External drive, Each install was done using the default settings aside from an Overprovisioning partition, so a mix of Fat32, EXT4, and BTFS. I will be in the middle of an action, such as opening a webpage, and the screen will go bank and start throwing a slew of errors to the tune of: “Systemd-journal 395 failed to write entry.” and then all the errors of the OS trying to gain RW access again. Does not succeed, and requires a hard reboot to come back.

At first, I thought it had to do with the use of TLP, but it has occurred on instances without TLP.

  1. 3.07
  2. Pop!OS 21.10 (5.15.5 (The one that ships in the ISO)
    2a) Mint 20.3 Edge (5.13.0-25, 5.15.10,5.15.5, 5.16.5, 5.16.10)
    2b) Fedora 35 (5.16.9-200)
  3. 2x USB C, 1x USB A, and 1x 256GB SSD. The only items I’ve had plugged in at the time of occurance has been the power cable or the power cable through a Belkin Ethernet to USB-C (Linked below).


Can confirm that it isn’t related to using TLP, I just had the disconnect occur on Windows 10 on my internal M.2, will be editing my post shortly

I use the 1TB card for my Steam drive. Sometimes it disconnects and reconnects, causing all kinds of errors from Steam. Sometimes Steam, as well as any other program running from that drive, crashes completely.
Using Windows 11.

Same here.
Bios: 3.07
OS: Windows 11
1Tb expansion card, 2 type c and 1 type A. No peripherals attached to those.

I use a 100gb NTFS partition on the 256 for a few steam games I want to be able to play on Windows as well as Proton. I notice the disconnects because my automount fstab rule that I set up to stop crashes (there was a tutorial) will suddenly not be in effect as my file manager saw it disconnect and remounted it in a more default behavior.

I was having a problem with a 1 TB expansion getting a random write error which looked like it was ejecting and then reconnecting. This would happen while I was running a python program which was constructing sqlite databases from raw data. The program would encounter a disk write error, a windows notification would show up saying that there was a problem with the drive, and the event log would show 2 errors:

  • diskerror_2022-02-22-warning

  • {Delayed Write Failed} Windows was unable to save all the data for the file D:\FirebaseAnalytics\bs2\db\bs2_20220207.db. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

  • The IO operation at logical block address 0x1ca6ad8 for Disk 2 (PDO name: \Device\00000199) was retried.

What fixed the problem for me was changing the windows USB drive policy setting from “Quick removal” to “Better performance”. (Device Manager / disk drives / USB Disk 3.2 SCSI Disk Device properties / Policies Tab)

The error occurred for me both on Bios 3.02 and 3.07. My other expansion cards are a USB-C card and 2 USB-A cards. I have the Windows 10 Framework Laptop Driver Bundle 12_16_21 installed. It was only changing the policy setting that has fixed the error for me. I’ll note that I didn’t get the error when performing a CrystalDiskMark test. It only happened when running my python program.

1 Like

@brianshmrian your solution didn’t work for me. Within 10 minutes enabling the option the drive got disconnected.

1 Like

3.07 (typo; corrected)

Win10Pro fully updated
Intel Driver Utility fully updated

250Gb card exhibits this.

With USB C on the two back, and a 250Gb on each front.

With USB A on left, USB C on right, and 250 on both front.

With A&C on front and both drives in back.

C on both front, hdmi/sd/usba on left and drive on right

And basically the mirror/reverse of the above listed orientations.

I believe my issue is in the device, not the laptop.

I plan on attaching a drive through the passthrough USB C bay and testing at some point.

I use one drive for my Steam library, and have had it disconnect in game as well as with Windows simply idling.

I have not checked deeply into the logs.

It might be the removal policy thing could fix it; might’ve been idly defragging when the disconnect occurred. It did eventually reconnect, and report an issue when detected again. I stopped using it for the time being.

I’ll try the removal policy edit.

I was having this issue as well with Elementary OS installed on my 1TB expansion back in December. I got so annoyed by it that I just stopped using the drive :frowning: Does anyone know if they more recently manufactured 1TB expansion drives still have this issue?

The problem does not seem to be OS-specific, but I’m using:

  • Elementary OS 6 Odin
  • Built on Ubuntu 20.04.3 LTS
  • Linux 5.11.0-37-generic

I’ve just started having this same issue.
Internal NVME drive is Win11.
1Tb Expansion card running Ubuntu 20.04 (to save the pain of having them on the same disk) is in the top-right slot and has started going RO since yesterday after I installed it on the 8th March. Which is 2 weeks of use.
Are these cards not designed for high i/o or something else?
Oh, and this one I have doesn’t contain the thermal pad suggested in the link about card throttling.

There’s a Bios 3.08?

Bios 3.08 will be released soon.

Kieran said that they were having some issues upstream of framework that they couldn’t solve, once that gets solved it’s ready to release.

I typod. 3.07

I’ll go edit my post. Sorry I didn’t catch it. Thanks for catching it! :sweat_smile:

  1. 3.07
  2. Debian GNU Linux 11.3, Kernel 5.16.12-1~bpo11+1
  3. Last time it happened: 2 USB C cards left and right nearest to the screen, 1 USB A card left, 1 1TB card right.


The disconnect happened to me again after two months without a problem. This is with the “Better Performance” USB Disk Option enabled. That option worked so well for me for so long! I’ll report back if this becomes a regular disconnect.

As always, I was running my python program which parses a bunch of json data and puts it into a sqlite database (both the data and db are on the 1 TB expansion card) when Windows popped up a message saying that the disk disconnected.

The system event log has these 3 warnings:

Source: disk
Date: 4/5/2022 8:50:04 AM
Event ID: 153
Description: The IO operation at logical block address 0x219ae50 for Disk 1 (PDO name: \Device\00000056) was retried.

Source: disk
Date: 4/5/2022 8:50:04 AM
Event ID: 157
Description: Disk 1 has been surprise removed.

Source: exfat
Date: 4/5/2022 8:50:56 AM
Event ID: 141
Description: {Delayed Write Failed} Windows was unable to save all the data for the file \Device\HarddiskVolume5; the data has been lost. This error may be caused if the device has been removed or the media is write-protected.

System Information:

  1. Bios 3.07
  2. Windows 10 Pro 21H1 19043.1586
  3. Left-Back: USB-C with power plugged in, Left-Front: USB-A with a Samsung Galaxy S7 plugged in, Right-Back 1TB expansion card, Right-Front USB-A with nothing plugged in.

Edit: I just had another similar disconnect after 10 days of smooth sailing. Oh actually, I only had the power plugged in. The other slots were unplugged but the same.

Same issue happening with me.

  1. Bios 3.02
  2. Windows 11 Home 10.0.22000 Build 22000
  3. 1TB expansion card, bottom right slot. Other slots are power/USB-C on top right, HDMI top left, USB-A top right.

Any updates on this problem?

Would like an update as well. Windows has begun disconnecting it every half-hour of use or so, Linux has been mostly okay.

I’ve been seeing this too, first on a 256MB card, then on the 1TB card I ordered to replace it.

  1. 3.07
  2. Ubuntu 21.10 5.14.21-051421-generic
  3. Currently, just the 1TB card and three USB-C cards, with power plugged into the northeast port. The 1TB card is in the southwest bay, but I’ve tried other bays too and hit the same problem.