[RESPONDED] 1TB expansion card disconnects randomly

Is there a tester programme I can sign up for, for this? Rather intrigued by this issue…but I don’t have a storage expansion card to test with. (The TBW endurance is low for the price point…and the price seems to be set largely because of the form factor uniqueness)

Has anyone tried the following test case on Windows and Linux (?):

  1. Start a large file transfer, say, 500GB. Copy to the expansion card (Single file), AND
  2. Start another large file transfer, say, 500GB. Copy from the expansion card (Single file)
  3. Then put the laptop to sleep…while both files are still copying.
  4. Wake the laptop up once the laptop entered into sleep.
  5. Should still be copying at the point.
  6. Now hibernate the laptop.
  7. Then wake up from hibernate.
  8. Should still be copying.
  9. Repeat steps 3 to 8 until end of copy.

Also, potentially inject a step 6.5:
6.5: Physically remove the expansion card, and re-insert the card into the same slot.

Ideally, 6.5 shouldn’t trigger anything strange as the system is supposed to be in a hibernated off state…but you never know.

Also, there’s the question of power source changes (say, flip-flopping between internal battery and USB-PD) during file copy. As well as hotplugging other devices into / out of other slots.

My instance of this would occur regularly from 3-5 days of using the OS, so just about long enough to get all of the settings, customizations, and installations through. In fact, I have a setup external SSD that had just started to exhibit the issue, With some guidance, I could grab any logs needed.

One item that might “help” this along is I would install the OS, and the applicable software, and then install about 30-50 GB of steam and GOG games onto the external SSD. On the 256 GB version, this would leave somewhere about 180 GB “free” (Swap to match RAM at 16GB< ~ 10% Over provisioning).

The use case over those 3-5 days would be general use, some social media, some youtube, and some gaming, there might be 2-3 shutdown/reboot cycles in that time, most of them during the first day to get stuff installed/updated/configured. This would be roughly 12-14 hours of use each of the 3-5 days. The error usually cropped up during the pause/load/buffer of a new youtube video in a queue. After the first occurrence, it would occur again within the next few hours, without warning or cause, opening up the issue to occurring on resumption, or entering sleep.

Items that did not seem to effect the occurrence: Running a checkdisk or FSCK scan on boot/reboot. Swapping between the OS on the internal and external SSD, the port the external SSD was in. Utilizing a thermal pad installed in the 256GB model like described for earlier 1TB models.

1 Like

This reproduces semi-regularly for me, always with the same use case: hosting a WSL2 distro on the disk, so a large VHDX on exFAT. Since I don’t have a consistent repro for this, are there any useful logs/ETW traces that I can get to help troubleshoot this? I did confirm via opening it up that my expansion card doesn’t have the thermal pad, so I’m considering just trying that as well.

1 Like

This issue is still preventing me from properly using the drive. I’m going to do some more sustained r/w and heat testing to see if it will cause issues.

Update 1: formatted and installed Ubuntu 22.04 on it as a benchmark. I did about an hour of configuration (mostly messing around trying to heat it up) before I suspended it and on wakeup was met with drive write errors and a full system crash. Took it apart and it didn’t seem too hot at all. My theory is the sustained read on system resume caused this one.

I’ve located a friend with a Thunderbolt 3 port on their laptop (14” Lenovo Yoga with an 11th gen i7), and they’re willing to do some writing in documents on the drive, so I’m handing it over to them for the next test.

1 Like

This happens completely random for me. I use the drive as a storage on Windows 11 - formatted as NTFS. It can happen while I am browsing the web, watching a movie, or when it’s left idle. In either case Windows Explorer opens automatically to show the drive.

I wonder if this is a voltage / powered hub/dock needed thing or not. Similar to the SDR thread.

It seems that the 3.09 BIOS has corrected this issue for me. Haven’t seen it creep up since installing whereas I would see it 2-3 times a day before. Moved my game installs and using WSL on it as well, no issue since the BIOS Update. It may be early to say but Good Job Framework!!


Thank you for reporting this, I’ll keep an eye out on mine this week.


Will install that later today. If this works I’ll be very happy!


With the reports of 3.09 “fixing” this, I tried with the install that was doing this regularly. Logged in, updated the OS, and started updating some games for the screen to go blank and start throwing the disconnect, and read only errors.

I’ve re-installed the OS, and have started to perform the use case described in my previous reply to see if it was a situation of once borked, always borked. Hoping that the BIOS update ‘did’ fix this, but not holding my breath considering the inability to reproduce for the manufacturing partners.

As an update, this BIOS update has not solved the issue for me. Error happened quicker than I am used to it doing so. Same as previous, Lockup of GUI, Dump to Terminal, spam errors onto the screen.

Edit: For context sda3 is my root partition.

Same issue here…it’s almost gotten worse with the 3.09 BIOS update.

Framework - batch 5, I think ?
CPU: i7-1185G7
HDD: 2TB WD 850 (with latest firmware)
OS: Windows 10 Pro, 21H2, build: 19044.1826
1TB add-on, have tried ALL 4 ports with similar random disconnects (even when it’s not even being utilized, i.e. I heard & get a notification on USB), get that diskpart.inf “warning” in the Windows Logs but don’t point to anything other than the device

This has gone on long enough…I think. How come there’s no fix for this yet?

This 1TB expansion card’s only positive thing is the form factor…that it fits into a Framework expansion slot. But it’s less reliable, slower (due to the interface speed), lower TBW and more expansive than a 1TB SN850 or a 1TB 980 Pro. Like, on a ‘value’ side of things…this card has extremely poor value as it stands at the moment.


I’d be curious to hear if people have similar problems with other USB drives. I think I’ve had a USB backup drive disconnect once or twice, but I don’t use them often enough to notice (and I wasn’t analyzing this problem back then.)

The 1 TB expansion card is only disconnecting every month or two for me even with it plugged in constantly and used every day to store and process ~1GB of data.

The reason I bring this up is that I keep wondering if the problem isn’t in the drive itself, but rather in the Framework’s USB connections.

BIOS 3.09 did not fix my issue. I’ve had my 250GB connected through a USB-C card for about two days, and it just dropped and reattached.

My overall experience has been that this is independent of charger connectivity, storage card location, and other attached peripherals. Sustained reads seem to trigger it more often than when it is left idle, but it will still trigger at idle (such as this most recent one).

Batch: 6
CPU: i5-1135g7
RAM: 1x16GB
HDD: 2TB SN750
BIOS: 3.09
OS: Win10 Pro
Expansion Cards+connections (clockwise from back left):
Full Power Magnetic Charging Card → charger
USB-C → storage
USB-C → Ethernet hub → peripherals
USB-C → TB3 cable → ADT-Link R43SG-TB3 → GTX1650S

Now that the 12th gen boards are in the wild, does anyone have a 1TB expansion card to use / test with?

Wonder if the 12th gen boards also have disconnection issues…or not.


Definitely wanting to know that same!

Curious as well! This would narrow the problem down to being the 11th gen framework itself or the drive.

I’m getting to a point where I would like to jump onto the 12th gen bandwagon…but need to know what I’m really getting myself into ahead of time.

Anyone else have a problem with the 256 and 1tb expansion cards just randomly disconnecting? I’m running windows 11 and it happens every once in a while when idle or when accessing files on the drive. It’s kinda annoying because it crashes all the programs and games that I have on them. Any help is greatly appreciated.