[RESPONDED] BIOS version 12th Intel CPU and troubles getting the display port extension card recognized

Hi, I’ve got a Framework 13 with the 12th Gen Intel i5-1240P. Currently, I’m
having trouble on Linux to get the display port extension card recognized (seems to be a
common problem, as far as I can tell). First I wanted to check if my BIOS is up
to date.

says the

No New BIOS at this time. The Factory-Installed BIOS (3.04) is the latest version

However, my BIOS version is 3.05.

$ sudo dmidecode -s bios-version

Is that article just out of date?

Then I also found a couple of BETA release for the 12th Gen BIOS.

will there also be a stable release soon?
However, I couldn’t find anything related to the display port adapter there.

Regarding the firmware of the display port extension card I found this:

Unfortunately, I need windows for that as far as I can tell?
I’m running Arch Linux on kernel version 6.8.2-arch2-1.


  1. is that BIOS overview/support article out of date?
  2. is it known when there will be a stable BIOS release for the 12th Gen Intel? (assuming that the current one is actually 3.05, not 3.04)
  3. any pointers on getting that display port extension card recognized in Linux?

Thank you

1 Like

3.05 was a factory installed newer version, I have no idea what exactly is different but ive been told 3.04 was/is ok.

Ive jumped from my factory installed 04 to 08 (using EFI) and worked fine. any video related things where due to my own mistakes (plugs not connected or device not on/standby) aka, it worked first try… meaning, expect your system to reboot a couple of times to fully update all the firmware. its not only the Bios that gets an update, its the subsystems aswell, requiring reboots.

12th Gen Intel Core BIOS 3.08 Beta Release - #21 by Kieran_Levin points to the latest 3.08 BETA msi installer (with a fix for some framework laptops that where detected as not a FW laptop?!?) so that be their latest supported install method.

If your like me, and prefer the EFI method: 12th Gen Intel Core BIOS 3.08 Beta Release - #209 by jmariondev He pointed out, that the files are still there. There where some issues apparently, so they pulled the URL from the post, but you can still try. I do have to mention I also dual boot windows, and used windows to firmware update my HDMI module before I attempted the bios updates (I do not own a DP module, dint use windows to do any other firmware updates)

The discrepancy of version 3.04 and a factory installed version 3.05 is weird, but okay. Thanks.

Yes, I prefer the EFI method, too. Especially, because I only have Arch Linux installed and I’m not dual booting with Windows.


There where some issues apparently, so they pulled the URL from the post, but you can still try.

I’m hesitant. It’s great that it worked for you and others but I really need that laptop. Though, I guess the update just fails and the laptop isn’t bricked? Do you know what exactly these issues were?

So my HDMI module works fine and it’s the one I’m mostly using. But just a couple days ago I wanted to use the Display port module and noticed that it does not work. And it’s not even recognized.

if I run

dmesg -w

and plug in the HDMI module, it shows up there and it’s recognized as HDMI expansion card.
If I plug in the display port expansion card, nothing happens; it doesn’t show up there.

1 Like

Echoing Max, dmesg -w or even journalctl -f while your plug in your HDMI expansion card should register it. If it’s not, I’d run lsusb and see if it shows up there.

If not, and this is happening on multiple expansion bays, sounds like a bad card needing to be RMA’d in a ticket.

I am quite sure that I used lsusb too and couldn’t find the Display port expansion card there. (The HDMI shows up just fine, obviously – as it is working).

I’m currently travelling and didn’t bring the display port expansion card because it didn’t work, so I can’t 100% verify now.

Where do I go to open a ticket to get a working display port expansion card?