[RESPONDED] Booting Debian

It’s headed to testing from sid, but blocked by a glib 2.0 package upgrade apparently. In any case the Bookworm version is almost identical and works fine in my experience, no need to build it from source.

I’ll try it, the sid version right now would break a lot, it would e.g. remove gdm3, gnome-shell etc. So better to compile by hand than this.

and that’s the reason I can’t compile it (on testing). Great.

So haven’t followed through the entire thread, only part of it, but just installed Debian tonight after getting mine. Did base install of Bookworm on encrypted ZFS root, upgraded to testing via the ethernet card, since I hadn’t realized I needed to add non-free firmware package for the wifi, added amdgpu firmware package and installed on testing via tasksel the KDE desktop, and it’s all (so far in VERY limited use) worked just fine, including prompting for ZFS password to unlock and finish booting.

That’s very curious. Since Bookworm, non-free-firmware is a separate repository and by default included in all boot media and if not deselected during installation, installed on your system.

But with ZFS, always keep in mind this is quite the controversial topic and support is not that official. For all I know it needs to be patched to every new kernel, so I’m not sure if that may cause issues in the future. Also I don’t really see any reason why it should be used over btrfs, which is officially supported and developed in-kernel.

I shouldn’t have been that surprised, I just hadn’t considered I needed to install the firmwares, I knew the non free ones have some Debian folks not liking them so should have figured they wouldn’t be installed by default.

And yes, I’m completely aware that ZFS on Debian is definitely not an officially supported platform. Also probably why I couldn’t load the module in the live CD situation with Secure Boot installed, probably because the initramfs that was signed/loaded didn’t include that module since I had to install it from the internet.

And no, even in Debian repos, it doesn’t need special kernel patching or anything, it’s all standard packages and kernel modules these days. I’ve been running it for over a year on my desktop and old laptop.

For my own self, I just need to figure out how to boot through grub an arbitrary snapshot. Once I finally sit down and do that, it’ll be almost bulletproof, even if an update or something b0rks, I won’t need a live/rescue image boot if I’ve done a recent snapshot, I just boot the recent snapshot and I’m back up and running.

That is very curious. I can’t find any information on the specifics in the release notes, but if I understand the General Resolution correctly, that was taken to decide whether and how to include non-free firmware, this isn’t intended behavior. Proposal E should have won that claims

The included firmware binaries will normally be enabled by default where the system determines that they are required, but where possible we will include ways for users to disable this at boot (boot menu option, kernel command line etc.).

When the installer/live system is running we will provide information to the user about what firmware has been loaded (both free and non-free), and we will also store that information on the target system such that users will be able to find it later. Where non-free firmware is found to be necessary, the target system will also be configured to use the non-free-firmware component by default in the apt sources.list file. Our users should receive security updates and important fixes to firmware binaries just like any other installed software.

So if the installer indeed did not install the firmware - I suspect it did, but as explained it’s highly outdated so it can’t work - this is most likely a bug you should report.

Also, maybe you wan’t to just disable Secure boot anyways, especially if you want to use hibernation. Besides the fact that it’s completely useless until you delete any pre-existing keys and sign everything with your own keys, but hibernation with secure boot currently is impossible.

Well…I didn’t use the installer. As mentioned I installed ZFS root, but I didn’t link to the instructions I followed in this thread, so Debian Bookworm Root on ZFS — OpenZFS documentation

In there, it uses debootstrap to bootstrap the “installed” system on the internal NVMe. So technically it wasn’t installed, exactly. Since that only does the base system, it didn’t know to install additional firmwares/etc. Maybe I should put in a PR and add a note for folks to consider if they need to install those, before rebooting.

So, it isn’t any kind of bug, it’s a “I did something totally non-standard, and didn’t install them when I should have”.

And I suspect the reason I couldn’t install via the instructions is that the zfs package wasn’t installed, so the booted initramfs didn’t have the zfs module in it, so the module wasn’t signed that way, and so it couldn’t load with Secure Boot enabled.

Yeah, if you do things your own way you better know what you are doing.

Mostly I do. Or at least I know how to perform searches and where to go to ask (usually) the right questions to figure it out.

HI Richard,

This is why we have recommended distros - meaning distros where their docs and overall support is good to go out of the box. Debian, while doable with some tweaking, correct firmware and other consideration is possible, it’s much easier to consider something like Fedora 40 which just works.

That said, there may be some helpful details here, although this is largely targeting FW13.

I know. But Fedora is definitely too much bleeding edge in my opinion for me to be comfortable with and Ubuntu is just a bad distro. That’s why I refuse to use any of them. I was just asking here because chances are the highest here that someone is/was trying the same. Also, hopefully anyone trying it with the upcomming batches will find the information helpfull to get their distro of choice up and running. I’m hoping since many time_t-transitioned packages are hitting testing every day, the Debian devs will have more time for other things and will find the time to add newer firmware to their repositories.

So honestly, Debian stable worked just fine for me on first boot, although as I said, it was very minimalist “install” via deboostrap on ZFS method. Even with 6.1 kernel from stable. Although it wasn’t with a full graphical environment, is that what you meant? The 12.5 Live DVD/USB image from Debian -- Live install images is what I booted, and everything including the GUI was fine. I suspect had all the non-free firmware packages though.

Well, my biggest issue must have been the bug with btrfs that prevented the system to be mounted rw and thus refusing to fully boot. But I got a taste of how terrible an actual Debian Stable installation will behave. I first wanted to install Debian through the Spiral Linux ISO as they are better optimized for setting up btrfs and stuff but otherwise are just Debian. I wanted to download a file from the web, but during that process firefox crashed, sending the whole system into a reboot. And since the same happened with the Debian 12.5 ISO, you can bet that anything graphically “demanding” will be an issue. Maybe you’d be able to force your system no not use the iGPU at all and rely on lavapipe - at least I think Debian can fall back to that when hardware rendering isn’t available - but as it’s just a Vulkan software render, you’d have to make like 99 % of all graphical software run in a zink-lavapipe combo to be able to translate any OpenGL to Vulkan and then render it on CPU. But no idea how far you could come.

I’ve got no experience with BTRFS, so can’t comment on that. I think “normal” Debian install is just ext4, maybe try that?

It’s weird, I’ve always had a good experience with Debian, although it’s generally been CLI/server/VMs. Only been doing desktop the last year or so, since I’ve refused to switch to Win 11 to keep gaming since Steam Proton has been working pretty great. Granted, as I said, my installation wasn’t through the direct installer, so maybe that’s part of it.

It is, But why should I? It’s working perfectly fine.

And of course the Debian experience is always great. But you can’t forget what Debian is meant for and what it’s not. If you want to use it on the latest hardware, you’ll obviously have to put some work into it. That’s a use case they’ll never support with Stable. And the fact that their firmware package is almost a year old is hopefully just bad luck and they won’t just update them once every release cycle for all branches.

Ah, I see, wasn’t fully reading all the context in the thread earlier on, just skimming it. Thought you were still having some troubles.

1 Like

The weekly builds of the live ISOs should have the Calamares installer: Index of /cdimage/weekly-live-builds/amd64/iso-hybrid

What’s wrong with the regular debian-installer though?

If you mean that very oldschool looking one that you can boot into? Custom partitioning is much easier with Calamares. I’m not even sure if it’s possible to create btrfs partitions with that other one.

And yes, by now they may have it. Back when I tried it was missing, most likely because calamares wasn’t available in testing at that point for whatever reason.

Yeah. I like the oldschool one. There’s a graphical mode but it’s essentially just a graphical version of the text-based installer. It does support btrfs but I’m not sure if it supports some of the more advanced features of btrfs like subvolumes. I’m using ext4, LVM, and encryption (LUKS) and the regular installer handles that fine. I’ll have to give Calamares a try the next time I install Debian :slight_smile: