[RESPONDED] Brief report: Debian 12 bookworm working on Framework 13 AMD Ryzen 7040 Series

This is a brief post to report that installing Debian 12 (Debian -- Debian “bookworm” Installation Information) works fine on my Framework 13/AMD 7040.

Some details:

  • Mine came with the 3.03 bios, so I didn’t have to update it.
  • Wayland has some issues with brightness increasing and decreasing; xorg works well instead.
  • Full disk encryption working fine, it’s one of the options the simple debian graphic installer presents. I chose not to have a separate /home partition, since it seemed like additional complexity I didn’t particularly want.
  • Audio and bluetooth seem to work so far.
  • I settled on GNOME, since I found other desktop environments too small to read. You could probably configure KDE, though, so this is probably just me being a bit lazy
  • I’ve used Ubuntu for the last few years, and despite a few annoyances with snaps, I do appreciate their last mile efforts to get stuff to work. But I do trust Debian implicitly, definitely a notch more than Ubuntu, so I’m glad this seems to be working so far.
  • Haven’t had the chance to really test this yet; bugs may arise, etc. If I find any particularly egregious I’ll probably go back and update this.

Related posts: https://community.frame.work/t/guide-debian-12-bookworm-works-great-on-13th-gen-intel-framework-13/35432, https://community.frame.work/t/guide-debian-unstable-sid-on-the-framework-laptop/11539

Appreciate you sharing your feedback on this. Thanks :slight_smile:

Hello, can you maybe help me?
I installed Debian 12 (KDE) today on my 1 TB Expansion card. The install worked fine, but after i type in my password on the login screen, the screen goes dark and i can´t type anything.
I can only shutdown when i press and hold the shutdown button.
I tried Ubuntu and i worked out of the box.
Do you have any idea what the Problem is and how to fix it?

Probably out of date GPU firmware. Try booting with nomodeset and then upgrading it.

1 Like

Also, KDE is using Wayland by default. Maybe try selecting Plasma on Xorg in the menu which pops up when you click on a little gear when you are asked for your password. Or try some other desktop environment.

What did you mean by that ? What is the issue ?

I mean that, when I first loaded Debian into it, GNOME presented me with GNOME on Wayland by default. On it, the brightness level “flickered” or ebbed and flowed reasonably quickly. I didn’t look deeply into this, but rather though to log out, and log back in using GNOME on Xorg instead, which can be chosen by clicking a gears icon when logging in (and your decision is remembered). Hope that was helpful.

Welcome to the community, @CptJackSpatz

Mario’s advice is the best course of action for Debian.

How does one go about updating the GPU firmware?

I’m having frequent (daily) freezeup on my system. I’m using a dock (Monoprice Thunderbolt 3 dock) which I imagine has something to do with it, because sometimes the freezes are accompanied by a black screen. I turned off automatic suspending but that didn’t help.

Also the flickering brightness is the due to the ambient light sensor. I just blacklisted the hid_sensor_als module in /etc/modprobe.d and rebuilt my initramfs and that problem stopped for me. (There’s potentially a less brute-force way to turn it off, like a menu option somewhere, but I couldn’t find it and couldn’t be bothered. If someone finds it let me know)

  1. Clone kernel-firmware / Linux Firmware · GitLab
  2. Create /lib/firmware/updates/amdgpu
  3. Copy everything from amdgpu directory in checkout over to newly created folder
  4. Rebuild your initramfs.

When I try that, I get these kernel messages and no GPU acceleration:
[drm:amdgpu_pci_probe [amdgpu]] ERROR amdgpu requires firmware installed
amdgpu: See Firmware - Debian Wiki for information about missing firmware

Removing the /lib/firmware/updates/amdgpu directory and recreating my initramfs eliminates the problem

An unhelpful error message. It doesn’t tell me what led it to believe there’s no firmware installed.

It sounds like some debian specific kernel patch conflicts with the updates directory functionality.

I suggested updates directory to avoid conflicting with what is provided by debian.

In that case you might just need to place in /lib/firmware/amdgpu.

1 Like

I tried installing linux-image-amd64 from the bookworm-backports repository and my freezeup problem hasn’t come back since.

Maybe a coincidence. Might happen again in a day or two. I’ll report back if it does.

Thanks for describing how to grab updated firmware Mario :slight_smile:

1 Like

The ambient light sensor can be controlled from Settings/Power/Automatic Screen Brightness. It seems to default to ON. I was also bothered by the flickering brightness. It wasn’t terribly obvious but became a niggling irritant. Turning it off stopped the flickering.

1 Like

Thinking about installing Debian too. If I install the latest kernel from the backports, do I need to do something manual for the firmwares or do both come together?


First of all, thanks for this report, which helped me so much when I installed Debian 12 on my Framework 13 AMD Ryzen.

I also had to manually install amdgpu firmware from the upstream linux-firmware repo to /lib/firmware. However, copying over simply into /lib/firmware/updates/amdgpu did not work at all, which was confusing. On the other hand, copying directly into /lib/firmware/amdgpu worked indeed.

That happened probably because both Kernel 6.1 (stock Debian 12) and 6.5 (from bookworm-backports) had other bugs when detecting the firmware path. After upgrading Kernel to 6.6 or 6.7 (from trixie or sid), the firmware path /lib/firmware/updates/amdgpu was detected correctly as expected.

Odd. I’m running Debian Sid on my Framework 13 AMD, the latest kernel on it is 6.6.15-2, and it stills doesn’t detect the path /lib/firmware/updates/amdgpu, when rebuilding the initfsram, only /lib/firmware/amdgpu.

Hasn’t been a big deal though. VAAPI acceleration works fine and so does the few games I’ve thrown at it.

Maybe i had a similar issue, but cant remember if it was the same moment the screen went black. The problem was caused by SDDM, the display manager from KDE. Installing the more robust Lightdm resolved the issue.