[GUIDE] Debian 12 (Bookworm) Works Great on 13th Gen (Intel) Framework 13

I don’t see other reports of Debian 12 on the 13th gen Intel FW13, so I’m sharing observations from my first two days of use, including a full workday.


  • Easy install.
  • Works fine.
  • GNOME font scaling (not fractional display scaling) makes the FW13 display usable for me.
  • Power consumption meets my expectations.

(I put all the links from this post here, and cited them with bracketed numbers in the text below, because Discourse has me on probation.)

“Why Debian?” you may ask! I appreciate Debian’s stability and community governance. Once it’s set up, the system just works. The people behind it aren’t foisting snaps on me [0], putting advertisements in the MotD [1], or trying to cripple downstream forks [2]. Framework don’t officially support Debian, but Debian is (approximately) upstream of Ubuntu, so the official Ubuntu support benefits Debian users as well.

That said, using the stable release channel of Debian on current-generation hardware often requires extra setup work. With past new laptops (Thinkpad T450s and T480), I’ve needed to use backported kernels and various tweaks for the first 1-2 years (until the next stable version of Debian comes out). I’d expect the same journey with a current-gen Framework, but last month, Debian 12 (Bookworm) entered the “stable” channel with a recent 6.1 kernel, which is great timing.

Installation experience

I installed Debian from a USB flash drive (debian-12.1.0-amd64-netinst.iso). The default graphical installer just booted and worked. Debian recently started including proprietary firmware blobs with the installer, which saves a few minutes of finding and loading them. In my 9 years using Debian, I’ve never had an easier time with the initial installation.

General hardware observations

Nearly everything just works after installation. I tested (briefly but with success):

  • Ports (only ordered USB-C and USB-A expansion cards)
  • Keyboard (except brightness keys, see below)
  • Touchpad
  • Speakers
  • Built-in microphone
  • Wired headphone jack (including in-line mic on wired earbuds)
    • I hear a small ‘chirp’ through headphones when the audio chipset turns on (to play audio) and off (after several seconds of no audio playing). Not a big deal.
  • Wifi
  • Bluetooth
  • Camera
  • Automatic display brightness
  • External display (DisplayPort over USB-C cable)

Only the brightness adjustment keys needed further setup work. Right now, we get either automatic display brightness (using the ambient light sensor) or brightness keys (by blacklisting the ALS kernel module). I followed the Ubuntu instructions [3] to enable the keys.

I didn’t try the fingerprint reader, mostly because fingerprints provide relatively weak security, but also because there’s a known firmware issue [4].

Display observations

At no point during installation was text too small to read. During boot, you see a few seconds of tiny text in the grub menu and console, but I can read it if I must. (There are documented fixes for this on the Debian wiki [5] but I didn’t bother to try them.)

Once you’re booted to GNOME, display scaling defaults to 200%, even on the login page. It’s very easy to read, but bigger than I want most of the time. So, I decreased display scaling to 100% and then adjusted font scaling in GNOME Tweaks.

Font scaling factor Equivalent PPI Subjective eye strain
1.00 201 lots; readable but very small
1.25 161 some; still a bit small
1.37 147 a bit; can use for hours
1.50 134 none; very comfy for reading

(Why 1.25 and 1.37? That’s when Firefox jumped to larger text on web pages.)

Above about 1.50, the layout of GNOME-native UIs starts to get a little weird. Spacing between elements is especially weird at 2.00. If you want to go that big, 200% display scaling (with 1.00 font scaling) may be better, because it preserves all the UI element proportions.

What about fractional display scaling? I tried it. It made my Firefox blurry and my Electron apps blurry. I could troubleshoot this one app at a time, but font scaling just worked better, so I switched back to it. Font scaling already looks tack-sharp in all the programs I’ve tried. Despite its name, it scales most UI elements (buttons and menus) in addition to fonts. If you aren’t a severe UI nitpicker, it’s a totally usable experience. (I further tweaked the zoom / text size in a few apps, but I do that even on a low-DPI display.)

Power consumption observations

These are a few quick data points. I didn’t take repeated measurements. I don’t claim that this is representative of the FW13 overall.

At idle with nothing open

First thing after installing Debian, I let the system idle for a minute, and observed this on GNOME’s “Balanced” power profile (reported by powertop):

Consumption Display brightness
3.55 watts minimum
4.69 watts middle
5.66 watts maximum

(Note that I don’t have any of the power-hungry expansion cards, just USB-C and USB-A inserted.)

For the rest of the power consumption testing, I applied nvme.noacpi=1 from the Ubuntu setup guide [6] and rebooted.

On standby

Testing standby power drain overnight, I saw 4% drain in 7 hours 13 minutes. That’s about a week of standby on a full charge, by far the best I’ve had on a Linux laptop. (My Thinkpad gets only a few days).

While actually working

I worked today like this:

  • A mixture of setting up my IDE, programming, and using several JavaScript-heavy work apps in Firefox. Also using Thunderbird, Signal, Element, Joplin, and a few terminals. Most of these stayed open the whole time.
  • No video/voice calling.
  • About two-thirds display brightness.
  • Wired external keyboard and mouse connected for part of the time, but nothing else plugged into the laptop.
  • Only USB-C and USB-A expansion cards.

In these conditions, I saw (each measured over a 2-hour period):

GNOME power profile Observed dattery drain Projected runtime 100%-0% Projected runtime 90%-10%
Balanced 15% per hour 6 hours 40 min 6 hours 0 min
Power Saver 13% per hour 7 hours 41 min 6 hours 55 min

So, between 6 and 7 working hours if I’m gentle on the battery chemistry. I could squeeze more runtime by thrashing the battery (100% charge and deep discharge), keeping fewer apps open, working in a darker room, and so forth.

Is this good or bad? It feels good for a 61 watt-hour battery and a 16-core Intel CPU. I would get a USB-C power bank if I needed more endurance, but I generally don’t.

Some kernel messages I saw on boot

[    1.227906] tpm tpm0: [Firmware Bug]: TPM interrupt not working, polling instead
[    9.312539] iwlwifi 0000:aa:00.0: firmware: failed to load iwl-debug-yoyo.bin (-2)
[    9.312564] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware

I haven’t troubleshooted these yet. Wi-Fi works fine (across 4 different networks so far).


This is about as smooth as it gets with Debian. I’m a happy camper! I’m resisting the urge to make this a hardware-focused review or a “Dear Nirav,” wish list. :slightly_smiling_face: Overall, Framework are delivering on their ambitious mission. May they keep doing it for a long time.

Related resources

  • Ubuntu 22.04 on 13th Gen Manual Setup [7], which partially applies to Debian. I didn’t use all of this, but I did:
    • Enable fractional scaling (then regretting and not using it)
    • Disable ALS to enable brightness keys
    • nvme.noacpi=1 for “the best suspend battery life”!
  • Debian Wiki: Installing on FW13 12th Gen [8]. I didn’t make any of these tweaks, but others may want to.
  • Anarcat review of Debian 12 on 12th gen [9], a very in-depth review of the same distro on the previous-gen FW13. Anarcat uses i3 instead of GNOME.

Great guide. Not sure if you experienced any issues with it, but one user found the TPM issue was affecting their installs - posting a link to their experience on Debian here to augment your great guide.


Thanks for the well-formatted and exhaustive write-up. Debian gets slept on sometimes and Bookworm is great.


@cmart did an outstanding job of with this. :slight_smile:

1 Like

Hello, I installed Debian 12 today (before reading this post :sweat_smile:) and I can confirm everything said by @cmart, it was a pleasant experience overall.
I’ve tried both the font scaling and the fractional scaling, and I personally prefer the latter because in my opinion suits better a scenario with multiple displays and resolutions. Yes, some apps may appear blurry, but i find ways to fix them (e.g. env variable MOZ_ENABLE_WAYLAND=1 for Firefox, and code --enable-features=UseOzonePlatform,WaylandWindowDecorations --ozone-platform=wayland for VSCode). As of today, I’m happy with fractional scaling. If using dark mode, I suggest also to set application theme to Adwaita-dark in gnome-tweaks in order to fix some application bars that are remaining in light mode.
I can confirm also that the fingerprint reader is working properly out of the box. I’ll paste some example commands here if anyone is interested having it:

sudo apt install fprintd libpam-fprintd
fprintd-enroll -f right-index-finger
sudo pam-auth-update

Lastly, I have a “scrolling” issue with Firefox on the touchpad (too fast and unnatural) that I resolved with a dirty workaround in about:config, by lowering mousewheel.default.delta_multiplier_y from 100 to 50. I’m not particularly happy of this solution because when i use a real mouse the mouse wheel is annoying and super slow. If anyone has a better solution, please let me know!

I am hoping debian 12 is also going to work on AMDs Phoenix platform (ryzen 7040 series), but great to hear that it is working well on Intel’s 13th gen. Enjoy!

Great Guide! I’ve been running Debian 12 on my Framework 13th gen i5 for about a month. Everything except the fingerprint reader works perfectly, and since I could care less about the fingerprint reader, I’m a very happy camper.

Note: I think the fingerprint reader requires a firmware update.

1 Like


I would like to know why the Linux distribution DEBIAN is not among those proposed.

If I install DEBIAN on a 13" laptop, will I encounter compatibility problems with certain components?

Thanks in advance!
Best regards,

Ubuntu and Fedora are the only *officially supported distros. For other distos you have to search the forum or the internet.


1 Like

Hi! Thanks for the write-up.

I’m trying to dualboot Windows 11 and Debian 12. I just received my 13th gen Intel FW13 today and installed Windows 11 fine. Everything is working. I created a USB installer for Debian 12 (I tried both the smaller netinst version and the bigger DVD version). When I tried to install, I reach the “detect network device” page and it says it can’t find an Ethernet card. If I select “no Ethernet card” it blocks me from continuuing and says “go back and select a driver.” If I select the Intel wifi driver it returns me to the “detect network device” page.

I can’t setup wifi in the installer and I can’t progress past this point. Has anyone else run into this issue? Thanks!

While I don’t officially support Debian, I’ll ask questions that may help the community help you. This will assume the DVD version:

  • Are you using a Framework or similar USB-C based Ethernet card? If yes, remove it. If no, then next step.

  • Do you have a skip the network configuration option?

Another option.

We test and have great success with Ubuntu 22.04.3 and Fedora 38. If you would rather avoid Ubuntu, Fedora is a solid release using out guide.

Thanks! I don’t have an Ethernet card. And I could not find a skip network configuration option, although perhaps there is a keyboard shortcut to make this happen that I am unaware of.

I did end up installed Ubuntu 22.04 following the guide and that allowed me to install without network configuration and is working great. :+1: Definitely prefer Debian over Ubuntu, but this is fine for now.

As I grow my team, I want to find ways of expanding our distro inclusion. Debian and a few others are on the list. But to do it right, takes cycles. Appreciate your willingness to utilize Ubuntu in the near term. :slight_smile:


Did you make sure to download the Debian image with firmware? Here are the instructions for the 12th gen.

Hey, thanks! As of Debian 12 (Bookworm), the installer contains all firmware so it’s no longer necessary to use the non-free installer to get firmware.

Update: I decided to see whether I could skip the network configuration step and proceed with the install. So, I created a fresh usb media using the same ISO and went through the install again. This time, it immediately detected my wifi and I did not run into the network config error I encountered before. The rest of the install went smoothly and I was able to install Debian over my Ubuntu partition. I also followed the Ubuntu 22.04.3 guide and was able to set everything up, just tweaking a few things specific to Debian.

So far, Debian is working great! Works just as well as Ubuntu had been working. :tada:


Hello. I didn’t want to create a new topic so posting it here.

TL;DR: Debian bookworm works out of the box on Framework 13 with Intel 11th Gen (so far).

First a bit of background: I’ve had a Framework 13" with a 11th Gen i7 (1165) for more than 1 year now (since May 2022). I used it mostly for (embedded) software development.
Until now I was running Ubuntu 22.04 LTS (+Gnome), but I wanted to try another distro than Ubuntu (and I needed to clean up a bit my OS also…).

So I installed Debian bookworm (+xfce as desktop): installation ran smoothly (everything worked out of the box) and it took me only a couple of hours to have the laptop running, xfce configured as I wanted and my other programs installed. On a side note, I discovered the joy of dev containers in VS Code very recently which removed the need of installing (cross-)compilers (among other things) locally.


Thanks for creating this very informative thread.

Are there any issues with suspend and/or hibernate on 13th gen? Suspend, hibernate and also suspend-then-hibernate are features that I use every day, so knowing that they work perfectly out of the box would go a long way to allowing me to use a Framework in the future.

How’s the power drain in suspend? I know there have been issues with high suspend power consumption in prevoius FW13 gens.

With my 13th gen (fresh Debian 12 install, 2 USB-C and 2 USB-A expansion cards) it’s about 0.6% per hour. It’s low enough that I haven’t felt the need to set up hibernate.