[RESPONDED] CPU Usage goes to 25% upon idle, drops instantly when moving mouse

So this is probably not really a framework specific thing, maybe it has something to do with the AMD 7640U in my 13’’ Framework but i googled around and everything is mighty unspecific and my google Fu just isnt doing it.

I got two points of data.

  • When i leave my laptop on Charger, the display goes dark after 10 minutes.(so far, normal powersaver behavious) I noticed that then, after a short while, the fans are spinning up and keep on spinning. When i wiggle the mouse so the SDDM prompt shows up it calms almost instantly
  • i got this KDE applet that shows me that the CPU usage was around 25% but the temperature stayed same-ish.


While i googled around i found something called atop that gave me some logs but i either lack the knowledge to read it or my interpretation is plain wrong. All i got was that powertop itself has short 60% usage spikes and the plasma-systemmonitor i left in the background spiked for a datapoint but thats it. dmesg had nothing for me.

My main problem is that i know just enough about Linux to be dangerous but in truth, even after years of using it as main work machine and mobile laptop, I know nothing. I cannot diagnose my problem, I dont know what do look for or which words to use to properly describe my problem.

I am running a frankenstein of KDE Neon with Kernel 6.8.1 (installed with mainline). But the ‘problem’ existed before. KDE Neon, based on Ubuntu LTS 22.04 worked fine for me up until now in all things. My power consumptions on battery seems a bit high because its usually over 8 Watts but thats everything i can complain about.

Quick data i have at hand

Neofetch --off

OS: KDE neon 6.0 x86_64
Host: Laptop 13 (AMD Ryzen 7040Series) A5
Kernel: 6.8.1-060801-generic
Uptime: 4 hours, 27 mins
Packages: 3156 (dpkg), 16 (flatpak)
Shell: zsh 5.8.1
Resolution: 2560x1440
DE: Plasma 6.0.3
WM: KWin
WM Theme: Breeze
Theme: [Plasma], Nordic-bluish-accent-standard-buttons [GTK2/3]
Icons: oxygen [Plasma], breeze-dark [GTK2/3]
Terminal: konsole
Terminal Font: Hack 20
CPU: AMD Ryzen 5 7640U w/ Radeon 760M Graphics (12) @ 400MHz
GPU: AMD ATI c1:00.0 Device 15bf
Memory: 6243MiB / 27746MiB

There is also this oddity of quite high cpu times for kwin_x11 and Xorg but again i know not enough to reliable extract any meaning out of it.

Screenshot of Htop caption

Likely a kwin issue, have you tried other window managers to see if issue persist?
still no harm in testing with vanilla fedora 39 Live, just to rule out it’s not a hardware related issue.


As said, only enough experience to be dangerous. I will try the window manager tomorrow and report back.

Fedora is giving me 3.5w on idle out of the box after updating once and no amount of tweaking ubuntu with my expertise ever got me that…

I recommend everybody just run that, anything else makes no sense tbh

I found a new clue after you guys mentioned Fedora and i thought a bit more about KDE. First of all, i like KDE but if Fedora might be better…so be it.

But for future reference, and i have yet to confirm this, but it seems the SDDM-Greeter is at fault

Some people speak specifically about VMs with AMD CPUs but in the end it is apparently the blinking cursor of the password field. The screen might go dark but there is still a picture projected…with a blinking cursor.

So far the theory…pretty annoying and a waste of everyones time if this is the case. But at least nothing malicious.

1 Like

Is it possible this is just an artifact of boosting?

When the cpu is all the way clocked down and mostly sleeping something basic may look like 20% but as soon as you move the mouse it clocks up to be snappy and the same thing it is still doing suddenly looks like a lot less than 20%.

Kinda depends on what exactly that percentage is reporting.

Then again 20% of that ting even kneecapped all the way down to 400mhz is still kind of a lot for doing nothing (assuming it is actually doing nothing). In my power efficiency testing the 7840U capped at 400mhz still had a higher cb15 score than the good old 6600U in my old x260(rip).

I am by now quite sure its really the SDDM thingy, i have tested a little around yesterday and as soon as i press super+l and the lockscreen appears the usage goes up (according to the kde applet). I originally noted this problem because my girlfriend was complaining that my otherwise quite laptop suddenly starting making fan noises while sitting on a couch table, doing literally nothing. The annoying thing is, there were workarounds but aren’t available anymore according to the notes.

But you point has merits if it would be the usage alone, but then the fans wouldn’t spin up wouldn’t they? (my picture above doesn’t reflect this because it was slightly colder yesterday evening when i made that screenshot)

Yeah that kills my theory.

After trying that one work around that sets rendering to software in sddm.conf.d the problems seems to be away.

So, as expected, nothing framework specific. Another day of running software at your own risk.