[RESPONDED] Crucial RAM compatibility issue with 12th Gen i5

I’ve been through 2 new sets of Crucial CT16G4SFD832A.C16FJ with my framework laptop and it won’t boot with any of those sticks. I went out and bought a random SODIMM at bestbuy that wasn’t on the compatible parts list and it worked fine, but none of the on spec crucial sticks work. Using linux but should be irrelevant as I can’t get BIOS to load with any of the crucial sticks.

Does anyone have experience with this? Should I replace with the single rank model? Do the docs need to be updated?

This ram would be compatible:

Sounds like you’re using this as a guide:

We want to make sure it’s referencing this:

The NewEgg link above has compatible ram. If it’s not working, it may be the ram.

We also sell compatible ram: https://frame.work/marketplace/memory-storage

The part you linked is the exact part I ordered, except I bought the 2x16 pack:

Any reason to think this wouldn’t work? Note that I’ve been through a replacement set already which still doesn’t work.

No reason I can think of. If BIOS isn’t loading with it, I’d definitely be looking to exchange that ram for working sticks.

Right, but I’ve already exchanged them once and the new set still don’t work. I’ve tried another brand and it works perfectly (it was just a random stick from bestbuy tho, and not the capacity I wanted so I’m taking it back). Should I just try another brand? It’s odd that one of the types of RAM listed as compatible don’t work no? How do I know another on spec RAM won’t just do the same thing?

Odd indeed. As long as it’s the correct spec, exactly as listed on the RAM compatibility page, should be fine.

Beyond that, without hands on that problem RAM, it’s difficult to say unless a batch of their RAM was mislabeled or something. It’s tricky as we don’t have hands on those sticks to test.

I am glad to hear you were able to get it working with the other brand of RAM.