[RESPONDED] Error waiting for DMUB idle: status=3

What you guys’ graphics memory allocation setting in BIOS?
I was having the same problem and noticed maxed out memory on integrated graphics. Changed the memory allocation from “Auto” to “Gaming” and I haven’t seen the issue since.
It’s hard to verify this was the cause, but it’s worth a try.

Hmm, I’ll check if memory is maxxed next time this happens. What utility are you using to check?

I do have mine set to Auto as well iirc.

I’m on Fedora using nvtop. It got to a point where the history graph it displays would get “choppy” and that seemed suspicious. I think Auto was allocating 500MB to graphics, now it’s allocating 4GB, I think.

I haven’t had this issue pop up in a while (although I have been rebooting frequently due to wifi not working on resume), however last night I managed to trigger it twice when an external display device had a bad connection. And it seemed to be completely frozen, although I didn’t try to ssh to check. If I have time today I’ll try to repro.

Getting the same issue on FW13 Ryzen while testing HDMI (I can only have 640x480). After I tested the second port, I probably had a bad connection and got the issue : sluggish mouse (but not so the keyboard), maxed video memory, and flesh error message (with status=2). Will try the BIOS setting.

After a BIOS upgrade (from 0.0.3.3 to 0.0.3.5), diagnosis of POST codes and fixing it by reseating the DDR, set BIOS to gaming mode again, checked nvtop to see there is plenty of video memory, I still managed to trigger the same issue connecting the HDMI expansion card to USB3 on the right…

I noticed vscode seems to trigger it.

I also get status=2.

I started using Lapce and it doesn’t appear but if i start using vs code again it triggers after a short while.

The system can paint one frame every 30s when this happens so I have to force reboot the machine.