[RESPONDED] AMD Framework 13 running Ubuntu 20.04 hangs right before login

Hi there, I’m hoping someone here more knowledgeable than me can put together some of the clues I’ve found and see if my Ubuntu installation is salvageable or if I’ll need to do a complete reinstall.

A couple of days ago I was playing a game in Pico8 which then became completely unresponsive. I then went to force shutdown by long-pressing the power button. When I rebooted, the laptop started up but eventually came to hang on a black screen with an underscore in the top left corner, with no ability to enter anything on the keyboard.

I was able to boot into all 3 different liveUSBs I tried: the Ubuntu install USB, a systemrescue USB and a Tails USB.

I was able to access my root filesystem and copy my entire home folder onto an external drive for backup. I just started trying things at that point: using ddrescue and fsck which both came back with no errors, as well as logging in as root in ubuntu recovery and trying apt-get update and apt-get upgrade, which didn’t help either.

From this I feel like I can be pretty confident that the hardware is working and that the nvme drive is also functional, and I am able to login as root in ubuntu recovery mode, so I’m at a bit of a loss. I’ve got a bunch of video and screenshots of various error messages I’ve encountered but I’m afraid they wont be much use as I wasn’t paying close attention to what exactly I did to generate them.

I am officially completely out of my depth here and would appreciate any help I can get. Thank you!

If the kernel is loaded, you may be able to use the sysrq keys to dump some information to your screen: Magic SysRq key - Wikipedia
Dunno if you will be able to actually use it though. But it helped me in the past identify bad disks and so.

Okay so this actually was interesting. I tried this at the current place my laptop is stalling and it worked somewhat in that sysrq-h actually does bring up the options available. Unfortunately all the other options output something like this:

[ 84.726142] sysrq: This sysrq operation is disabled.

Interestingly though while sitting on this screen other things are very slowly happening: a little afterwards while writing this another line appeared:

[247.852665] i2c_hid_acpi i2c-FRMW0005:00: i2c_hid_get_input: incomplete report (7/65536)

I’m not sure if that helps diagnose anything but I have a feeling this is related to Wayland because I was curious and went and undid a change I made earlier from this article on fixing wayland login issues on ubuntu 20.04 where in ubuntu recovery as root I did:

nano /etc/gdm3/custom.conf

and uncommented the lines

#More Verbose Logs

By re-commenting the lines back to how I found them previously and then rebooting I ended up back with my original black screen and notably it did not respond at all to sysrq-h or any other sysrq key combination.

What seems to happen here is the hid device → Human interface devices. So IMHO it is wayting for a keyboard or mouse or so.

Eventually upgrade to Ubuntu 22.04 to see if the drivers are better or so.

Welcome to the community, @Luke_J,

I want to make sure you followed our guide, using 22.04.3, not the very old 20.04?

Sounds like the hardware is working based on success with live booting USB keys successfully.

You were able to play games in Pico8 console, then became unresponsive. It’s odd that it is affecting getting to the login screen. Feel like something may have been tweaked in some fashion. Generally hanging like this happens with older kernels or if something else was tweaked somewhere.

We can try to see if you can get into a recovery mode, but it is far, far, far easier to just reinstall.

Hi, yes I did follow the guide and was using 22.04.3. I think I got confused while looking at old threads. I probably had tweaked something accidentally when poking around trying to find a solution to my computer not properly connecting to 5ghz wifi networks (which I believe is already known by the FW team and is being patched in a coming ubuntu update)

I am totally open to testing different things and sharing any error messages that come up as I’m pretty curious now about what exactly I did to break my installation. On the other hand I don’t want to waste people’s time just out of curiosity.

Just a couple of questions about reinstalling: If I reinstall Ubuntu 22.04.3 would my entire partition be wiped or would the /home folder remain? I already saved everything there on an external drive so its not the most important. Additionally I’ve also seen conflicting information on the best/safest way to make a copy of my current disk image while discarding empty space in the partition: unfortunately I have a 1.8TB root partition and only a 2TB backup drive with a 1.8TB partition available which means dd can’t make a full size disk image.

Actually, if you tell the installer to not format the /home partition, it will not format it.
This however requires you to define the partitions manually. But be sure it is a partition on the disk, not a directory. If you have a directory, you have to copy it onto another external disk and restore it afterwards.
For the disk image, no clue. I never take disk-image backups. Loss of time and space.
I only backup the data I need (/home and /etc) - the rest is performed by an installation way faster. Also - most of the important data is synced to my internal nextcloud instance anyway.
From experience, it is much faster to re-install a fresh ubuntu, configure nextcloud and grab a coffe … until the home-directory nextcloud directory is synced back.

What Jorg said is correct. That said, you absolutely should have your home backed up - life happens and losing data is no fun.

Myself, I have my home backed up every single day.

If it was me:

  • Backed up home, always, always. Trust backups.
  • Then you’re free to try and use the install by not telling it to format, but never trust it entirely. Get this wrong, that’s it. Hence, always have backups. OS’ fail. :slight_smile:

The beauty of linux is - you can concatenate the commands together. Add gzip to the mix and as root:

dd if=/dev/internaldisk | gzip > /extdisk/home_backup.img.gz

However, to be honest - you only need to backup /etc for reference, and all under /home.
And I would not use dd for that. A tar would be largely enough.

sudo tar zcvf /extdisk/home_backup.tar.gz /home
sudo tar zcvf /extdisk/etc_backup.tar.gz /etc

As @Matt_Hartley mentioned, always do a backup. And I do a backup before upgrading/changing anything on disks, and I verify that the backup is actually good.

As regular backups, I use borgbackup - it deduplicates and I can tell it which files not to compress (most pictures/videos etc. will not get smaller).

1 Like