[RESPONDED] Fingerprint Reader Cannot be Claimed - Ubuntu

Hi all,

I have had some issues with the fingerprint reader on the Framework 13 13th Gen i5 DIY, mainly that it cannot be used.

I first installed Kubuntu 22.04LTS, which did not recognise the “Shenzhen Goodix Technology Co.,Ltd. Goodix USB2.0 MISC” as a fingerprint reader at all.

Next was Ubuntu 22.04LTS and Ubuntu 23.04, which gave an option for adding a fingerprint to my user, however show that it could not be claimed.

For the avoidance of doubt, there are no updates available via fwupd.

In all cases, I went through the setup guides and completed the tweaks as described on Github.

I also found a post here with a solution of removing fprintd completely and reinstalling. This made no change.
There was also a note from Matt who mentioned using a slightly different Kernel than the one I had installed on 22.04 LTS, so I switched over to that, but no change.

Anyone else with this issue, or any further pointers to troubleshoot?


Hi @AlexU ,

Have you tried resetting the fingerprint? by downloading and executing the app from this thread?


Thanks for the response, @Loell_Framework :slight_smile:

I forgot to mention that I did try that on 22.04, and have just tried it again now:

Made no difference to the User Fingerprint Enrollment either time, unfortunately.

Have the exact same issue.
Just got my Framework 13 today. Fresh install of recommended LTS Ubuntu 22.04
Been fighting with this all day. Tried the same links. no firmware updates. tried the appimage as well. Nothing. No luck here with Fingerprint scanner at all

1 Like

hi guys @AlexU @Doublethink

It looks like it’s a known issue,

can you guys file your respective support tickets, we will be asking for the reader’s serial numbers as well. see this guide in getting the serial number of the reader.


1 Like

What we would like is to have the serial for the input kit. We’re in data gathering status right now as we drill down on this. Thank you.

the Guide above looks like a guide on how to replace the Input kit.

Would these be the serial for the input kit?

We want to capture from the underside of the keyboard, for the specific input serial.

1 Like

Assume the serial has to be one of these?
Doesn’t exactly say on the bottom of the keyboard which serial is for which component. These are all the ones i found.

Tried updating firmware via fwupdmgr update however new was found.
ran lsusb and see that Goodix fingerprint reader is discovered, however OS doesn’t appear to be able to connect to it when i try through GUI. additionally if i try via fprintd to register fingerprint it says either “device is in use” or “use fwupdmgr to update driver”

I have the same issue as the others here: new Framework 13, Ubuntu 23.04 install, no Windows install, no fingerprints ever enrolled. I’ll open a ticket as well.

Support ticket ongoing, and I’ll update if/when there is a fix :slight_smile:

Have one as well. No luck as of yet.

FYI for all:
Support mentioned that
They have identified the issue with this batch for fingerprint readers and the firmware team has informed them of a firmware update forthcoming via LVFS. no specific dates on the release

All, please join this thread: Fingerprint reader failing to register on 13th gen - #89 by Matt_Hartley for updates and what we’re doing to resolve this.