[RESPONDED] Framework 13 AMD Wifi

I’ve tried to do my due diligence here but haven’t found much on wifi issues aside from “install the drivers” and “make sure the wifi card is installed properly.”

I first installed Ubuntu 22 on my Framework 13. Everything worked out of the box. BIOS was already 3.0.3. A few days later I upgraded to Ubuntu 23. One or two things broke, and it seemed power consumption was higher, but nothing major. A month later I broke some other stuff, and decided to reinstall Ubuntu 22 due to the power consumption (as well as an issue with the hdmi port, which I wasn’t sure came from upgrading). Up until this point, wifi worked as expected.

After the reinstall, only 2ghz networks show up. No 5ghz. I couldn’t find too much in quick searches, but was in the middle of trying to setup dual boot with windows 11. So I continued with that. Windows 11 can’t connect to any networks, and doesn’t even show anything wifi-related in settings. So, I’ve installed all drivers on both systems. Everything ran successful; finger print reader, etc. Just, no changes on the wifi front. Still only 2ghz on linux, and nothing on windows.

I’m not really sure how to go about troubleshooting this.


Odd issue.
I don’t know if I can offer much help besides checking standard things. Your FW13 AMD is prebuilt or DIY? How long have you had it? And just to confirm, you have the AMD RZ616 Wi-Fi 6E card?

For windows, you did follow the guide and installed the FW Driver Bundle, yes? Might be worth trying to install again. Just because no wifi is mentioned as an issue if you don’t get the wifi drivers. Windows 11 Installation on the Framework Laptop DIY Edition - Framework Guides

For Linux, I’d suggest trying a LiveUSB drive for a fresh untouched install of Ubuntu 22.04 LTS (or Fedora 39 since it’s also officially supported).

DIY, since December. It has the card, and yes I’ve tried installing the drivers multiple times.

Hi @GG_S ,

welcome to the community, do you have any spare machine that can also run Ubuntu 22.04 live?

to compare output with nmcli?

nmcli -f ALL dev wifi

do you bluetooth devices as well? and are they working fine?

Afaik nothing changed, but I stopped using the laptop for two weeks, then ran the driver install again, and now it works on Windows… Just thought I’d update for anyone else who has the issue

1 Like

Thanks for the update @GG_S