[RESPONDED] Framework 13 won't turn on

Opened a support ticket but figured I’d ask here in case of faster response.

I unplugged and shutdown my laptop this morning to head to the airport and now it won’t boot up. The laptop was fully charged and had been plugged in and used for days prior. Approximately off for 3 hours.

Pushing the power button does nothing. No lights. Plugging in to an outlet does nothing. No lights on any of the four expansion bays. I’ve tried both plugging them into an expansion card as well as directly into the bay. The cable works with other 65w devices and has worked in the past to charge the laptop.

I didn’t pack the screwdriver so… opening the laptop up doesn’t seem possible but I am willing to overnight some kind of screwdriver replacement if anyone can point me to a viable replacement.

EDIT: So… Good and bad news… the laptop now powers on again… Not sure what happened to cause the fix…

Where are you? IFixIt sell a small driver set that will do and very useful for future use.

Then maybe a mainboard reset


Perfect! I’m in the US and was able to order this.


Not sure which model FW 13 is in use here?

That said, it sounds like it was completely discharged and the battery needed a few minutes (attached to power) to catch-up enough to properly power on.

If this repeats, it may be a bad battery as even closed and not suspended/powered off, it should take longer than 3 hours to fully discharge.