[RESPONDED] Fresh install of Manjaro painfully slow

Just Installed Manjaro i3 on my 12th gen pro model and everything is painfully slow. Typing is a 2 second delay and opening and closing terminal is quite a task. CPU is chilling at 00-01. 1.3G of ram is being used at idle and pegs to using all 30 gigs when doing anything. I’ve already ran pacman -Syyu and that didn’t help. Any advice? I also tried both installs using proprietary and open source drivers.

1 Like

We’ve tested the official XFCE image on 12th gen about 3 weeks ago, I have not tested i3 (community edition). I will download it now and test it.

We provide best effort support for Manjaro, Pop OS, Linux Mint with official support for Ubuntu and Fedora. So I will see what I can do to replicate this, but it may be a matter for their forums as there may be something that is happening with the distro itself.

I’ll know more shortly if I can replicate this experience.

In the meantime:

  1. Save a list of foreign packages (AUR akind)
pacman -Qmq > ~/foreign-pkgs.txt   
  1. Remove all packages built from AUR.
sudo pacman -R $(pacman -Qmq)
  1. Reboot the system
  1. Update your mirrorlist
sudo pacman-mirrors -c all -p all
  1. Run a full system update
sudo pacman -Syyu   
  1. Reboot

Thank you. I have done all that. No change. I did notice that the issue is only on the desktop. The greater runs perfectly fine and I have no issues with booting. I will try again with the xfce version

1 Like

not sure if this is talking about CPU percentage or CPU clock speed, but it sounds eerily similar to what other users are seeing in this thread:

you may want to read through to see if anything mentioned there can help, or try out a different distro all together if you’re already trying the xfce version of manjaro just to see if its an issue with the OS or the hardware.

1 Like

I did have a chance to install a fresh copy of Manjaro i3, yeah, it’s really “off” and was not working well. It was totally unusable. Might be worth reaching out to the Manjaro forums as they could have some insights.

I then wiped it and did a fresh install of Manjaro XFCE, worked flawlessly.

We provide pretty solid compatibility with Manjaro XFCE, however, we simply don’t have the hours to diagnose a Manjaro spin like their i3 release.