[RESPONDED] Headphone jack intermittent noise?

If it’s consistent while plugged into a power source maybe try a different brick? Maybe of a few different wattages as well? If it’s consistent with the default (60-65w? I don’t remember) brick, it’d be interesting to see if it happens with say, a 30w one.

1 Like

I hear static on my headphone jack quite consistently. I hear it in both channels, but the left channel is slightly worse. Occasionally it disappears, but I haven’t seen any correlation with the charger so far. (Running Ubuntu 21.04)

1 Like

@Jerry does it happen all the time? And on your speakers and headphone jack output?

1 Like

The higher I have my volume, the higher the chances of hearing the static on headphones and the speakers.

1 Like

I’m also hearing a bit of static, using headphones plugged in directly to the jack. It seems like switching to 16 bit output from 24 bit output (windows 11 audio settings) makes the static stop but it’s quite hard to tell overall.


Anyone else experiencing the static running Windows may want to try the new driver pack: Public Beta Test: BIOS v3.03 + Driver Bundle 2021_08_31

While troubleshooting another issue I installed it and static was there before the update, and was gone after installing and rebooting. Of course, it could be coincidence but my unit seems to have the static almost all the time so this is promising.


well, it is only coming from the left channel and sounds more that the source of the output is not grounded correctly.

Audio hardware is very sensitive to power so things must have separate power sources and be grounded separately.

from what I am reading is that anything with power use on the same side as the headphone port makes the static.

1 Like

I have also been hearing intermittent crackling/static from the headphone jacks. Card configuration has had no noticeable impact on the sounds.


I hear the static noise while I try to adjust the connector pin that is plugged-in to the port. I have to fiddle with it for a good few seconds to find the right orientation for the static to go away. Even after that, the headphone volume is too low. I turned up the system volume and my headphone’s volume control and it is still far too low. The volume issue might be a driver issue but something is certainly up with the port itself.


The static on my headphones has mysteriously disappeared for several weeks. The only things I changed recently were updating to kernel 5.13 and editing alsa.conf to enable microphone Ubuntu 21.04 on the Framework Laptop - #58 by Atul_Ingle

1 Like

Alright I have a recording that demonstrates the static issue. At the 2:00 mark I replay the video after I find the sweet spot of fiddling with the headphone pin and the audio becomes a little clear but still not crystal clear I think. The thing I noticed is that the voice channel seems to be messed up while watching the video. However, on a Zoom call since there is no music channel and I suspect it is not a 2ch stereo(?) I have a different problem – low volume.

The video I was playing during the recording is this: Outcast 2 - A New Beginning - World Trailer | PS5 - YouTube

What other info would you need to help diagnose this, @nrp? I am on Windows 11 (22000.194), by the way.

1 Like

Would you be able to check if this also occurs on Windows 10 with the beta Framework Laptop Driver Bundle? Public Beta Test: 11th Gen BIOS v3.03 + Driver Bundle 2021_08_31

1 Like

Let me see if I can do that easily. I think I’d have to wipe my hdd to get out of the Win11 Beta program. If that’s the case, I wouldn’t want to go back to Win10 because it is a pain. If you have any ideas, do feel free to DM me.

1 Like

@Kieran_Levin not sure if this is still useful to you, but I just got my system yesterday and I’m seeing the same issue in PopOS:

  • Left channel only, when playing content only
  • More noticeable with content that is otherwise quiet
  • Still occurs in left channel even when left channel is muted with PulseEffects
  • Issue clearly not present on a usb DAC (Apple usb-c to headphone jack adapter)
  • Will occasionally stop and work as expected, but inconsistently. On my most recent reboot I can’t get it to stop even when removing and re-inserting the headphone jack
1 Like

Would you be able to check a couple of things to help us debug this:

  1. Does this occur on other distros/kernels, like Ubuntu 21.04 live USB or Fedora 34 Respin live USB?
  2. Does this occur with a different set of headphones?
1 Like

I’m still getting some noise while listening to headphones now & then, I tried to reproduce with some test tones and quiet music today but I didn’t notice any noise on these tests.

FWIW I tried with nothing plugged into any port except a short stereo 1/8" cable going straight into a field recorder.

I made recordings initially with test tones at a moderate volume, but I redid the tests with very quiet signals afterward. Test tones at 200, 400, 800, and 8000hz, then a linear sweep from 2hz to 20khz. (FYI the oscillator I used doesn’t prevent aliasing distortion, so that’s present in the recordings, but the noise we’ve been discussing is nothing like aliasing distortion so I didn’t feel the need to use a bandlimited or analog test tone for this…)

I think I’ve only heard noise when plugged into power, and I’m sure I was doing more than just playing a test tone when it happened. I also generally use the laptop with a wired mouse, so I’ll try these again later when I’m working on something on the laptop with a mouse plugged in too.

Test tones, recordings, screenshot (just to show what was running at the time of the recordings, and the general battery level) and photo of how the recorder was hooked up are all here in case anyone is interested, I’ll try reproducing again this week!


1 Like


  1. I’ve tried both Ubuntu 21.04 and Fedora 34 Respin (KDE) and didn’t experience the left-channel noise/crosstalk issue.
  2. I’ve used both Koss portapros and Beyerdynamic DT-770 headphones when I was hearing the noise, and they had identical behaviour.

In addition:

  • After my first reboot back into PopOS 21.04, I was also not experiencing the issue
  • After another reboot into PopOS 21.04, I tried a video in youtube and immediately noticed the noise. After removing and plugging in the headphone jack once, it went away and I didn’t hear it again.
  • I then attempted another reboot with the headphones plugged in at boot in case this was related, but this didn’t reproduce the issue
  • So far I haven’t found any way to reliably reproduce the issue
  • FYI - My “standard” reproduction method to test is to launch firefox (92.0), open Youtube, and start playing a video. For additional confirmation of the noise, I will pan hard-right on the output device in the system settings sound panel, which both amplifies/changes the noise noticeably, as well as makes it more obvious since there’s no other sound audible on the left channel.

I just got my Framework and am loving it but I’ve noticed this and one other intermittent noise issues. Music production is one of my primary uses for a computer. When working on any loud sound (ex. a bass drum), I notice crackles on the left channel that only happen when the sound is playing. The crackles sound different depending on how loud the sound it. This problem also sometimes goes away but doesn’t seem to depend on whether the charger is plugged in or not. I am using AKG Q701 headphones and I have not tested with another pair yet. I notice this problem when I’m working on music sitting on my couch with nothing else plugged in to the laptop.
When I am working in my studio plugged in to my audio interface via usb, I do not notice this issue. However, I notice a 2 high-frequency clicks when I begin recording. They are somewhere in the 11k-15k frequency range and are quite loud. I can compensate by starting recording a few bars early and then deleting the beginning of each recording but I would be great if this noise didn’t happen. I have not yet tried switching the USB card out.

EDIT: I am running PopOs, I have not tried any other distros.


I had this problem too. i’m running windows 10. i went into sound control panel>playback>headphones>properties>advanced then i disabled signal enhancements hit apply. it was gone. i turned it back on and it is gone. idk if that was a coincidence or not. if it happens again i will try this. i’ll update you on the results.

Edit: right as i finished this i tested it again and the noise was back. I tried turning signal enhancements on and off. it didn’t work so it is not that i then tried putting it to 16 bit 48000Hz. that has seemed to work. I can’t hear the difference between 16 and 24 bit audio anyways so i’m fine with 16bit but others are clearly not. This was done with power plugged in and the drivers i got from framework.


Thanks for the suggestion! Will try it myself because this noise issue has been driving me crazy

1 Like