Ubuntu 21.04 on the Framework Laptop

I tried upgrading to Linux kernel version 5.14.1 on Ubuntu 21.04:

Bad news: Laptop refuses to wake up from sleep. Black screen; no fan spin; no response to key presses; power button LED stays on. Ditto for deep and s2idle.
Good news: Wifi and BT were both working well.

Rolled back to 5.12. Sleep working again.

1 Like

So on 5.11-31 everything is working, but I do notice a behavior when resuming from deep sleep. The power LED is on when lifting the lid, but the screen is blank and everything is unresponsive for about 5 seconds. Then the screen comes on and everything is normal. This seems to happen ONLY when resuming from deep sleep.

It is consistent and reliable so I’m not too bothered by it, but I’m wondering if anyone else had this, and if they were able to fix it?

1 Like

@2disbetter Same experience here (kernel 5.12.0-051200). Takes ~5 seconds for the login screen to show up after I wake up from deep sleep. s2idle is almost instantaneous though.

1 Like

Is anyone else having issues with getting Ubuntu to recognize a headset with mic when plugged in? I have a TRRS headset and apparently it’s a TRRS port, but when I plug my headset in, it just recognizes the headphones but not the mic.

Edit: the mic works properly on other laptops, like my work Mac.

@Simon_Pratt ditto. I tried a couple of headsets with microphones built in but they don’t show up in the sound input devices list.

After digging around various stackexchange questions, I finally got my headset mic working on Ubuntu 21.04 kernel 5.12:

  1. I checked my codec version
    cat /proc/asound/card0/codec* | grep Codec
    This told me Realtek ALC295.

  2. Then I looked through the kernel documentation page here. In the ALC22x/23x/25x/269/27x/28x/29x section it lists dell-headset-multi for headsets that can also be used as mic-in.

  3. In /etc/modprobe.d/alsa-base.conf I added this line at the end:
    options snd-hda-intel model=dell-headset-multi

  4. Then restarted the laptop, plugged in my headset and now I see headset microphone and internal microphone as audio input device options in my sound settings.


Just installed Ubuntu 21.04.
The good: OS has automatically recognized my WiFi&BT.
The bad: the speedtest shows the same ping, same upload speed as the same test that I run on this laptop under Win10 with the latest drivers pack. But… the download speed is 2 times lower under Ubuntu( 64-67MBps) vs (148-150MBps) under Win10.
I have checked lib/firmware – and the latest Intel firmware for AX210 is not there. So I have downloaded the latest one, copied to lib/firmware and rebooted my Laptop. I have repeated test and now the download speed has been improved – I’ve got 75-77MBps for Ubuntu. So yes, the latest firmware brings some improvement, but still… 2 times slower than under Win10… :sob:

@KOSTYANTYN_RUKHLIS did you try updating to kernel 5.12 first?

No, it’s ~3AM here in ON, Canada, I’m done as for now, got only 4 hours to sleep before the business day start. :joy: Will play later with the different kernel. Thanks for the hint.


The default option for WiFi on Linux is to be on power saver mode. Try disabling that using this guide and try the speed test again. Be warned, however, that this does have a significant effect on battery life.

1 Like

@zmk5 Ok, I’ve checked, but this is definitely not my case. First of all, I test it with power plug connected. Also, in battery settings I set the top performance mode for both AC and battery scenarios.
But today it’s another miracle – the download speed is almost the same as via Win10 ( 110-155MBps for Ubunty vs 160-177MBps for Win10). But the upload speed is surprisingly low today for Ubunty – 10MBps vs yesterday’s 20MBps( and today Win10 shows 20 MBps as well). So it looks like the new driver is better than the one included with Ubuntu 21.04, but it’s not that stable as Win10 driver from the performance perspective.

Update: Yes, I have created tiny automation that runs multiple speedtests sequentially. And I can confirm the Win 10 running this automation shows pretty stable performance for the download and upload( within 5% difference between runs), whilst Ubuntu 21.04 has strange speed fluctuations for both download and upload( some runs have ~50% difference). I’m using the same conditions for both Win10 and Ubuntu runs. Just to conclude – newest Intel driver for Linux is better than stock one, but it’s not that stable as Intel’s driver for Win10 from the performance perspective. All Ubunty tests done with the stock kernel: 5.11.0-34. The last thing to try is to update to the 5.12 kernel – maybe it’s more stable and compatible with the Intel’s WiFi driver.

P.S. Just for the record – I’m using Meshed routers infrastructure in my house. But both Windows and Ubuntu tests done from the same table and as far as I see in both cases they connect to the same Mesh Pod

Having the battery plugged in or setting the battery setting to performance does not change the power setting of the WiFi chip. In fact, it is just an integer variable that needs to be manually changed. I’m fairly certain the link I provided would solve your issue.

1 Like

@zmk5 ,
Even considering the fact I had some doubts, but I gave a try and set it to 2. And the result is really interesting!
Now, the Ubuntu fluctuations are gone!!! I’m getting stable 120-130MBPs for download and 20-21MBPs for upload. At the same time Win10 scores 155-170MBPs for download and 20-21MBPs for upload.
So the outcome is:

  1. New version of the Intel Linux driver is a must if you want to have more or less real speeds.
  2. The /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf file has to be updated and wifi.powersave = 2 (disabled) should be stored there instead of the default 3. This will save you from the download/upload speed fluctuations on Linux. @nrp Maybe it’s important info to add to the guide for Ubuntu 21.04( and another Linuxes)?
  3. The Intel Linux driver/firmware is still behind comparing to the Win10 version in terms of the performance. Maybe the newer kernel( 5.12) will close this gap??? Who knows… :joy:

@zmk5 Although, I should admit that My HP Omen 15 2020 has significantly better download speed than either Win10 driver or Ubuntu 21.04 newest Intel driver on Frame.Work:

(this is my HP Omen sequential speed test with the stable result). As you can see the download speed is almost twice faster than Win10 on Frame.Work. It’s almost the same as a maximum download speed of my Rogers Internet plan( 300MBps). My HP Omen has Intel WiFi 6 AX201 160 Mhz WiFi card. I believe it’s more stable and the drivers are more polished even for Win10 than for the AX210 used by Frame.Work team. I hope at some point Intel and Frame.Work teams will fix this issue and improve drivers capabilities for AX210.

1 Like

Ok, small update. I’ve tried newer kernel 5.12. Unfortunately, no improvements, the WiFi performance is the same as 5.11. But I’ve got some strange issue with BT and headset with 5.12 kernel. Every minute the sound in BT headset disapears for few seconds. With 5.11 everything was working fine.
So I’m rolling back to my 5.11 kernel.
I have acceptable and stable results with Ubunty and 5.11 kernel, AX210 and Intel firmware and power saving turned off:

P.S. Also I have successfully configured fingerprint authentication in Ubuntu – both on Login screen and terminal sessions. Works like a charm, the same experience as under Win10. :slight_smile:

1 Like

@Simon_Pratt @Atul_Ingle the codec does not support mic input on the headphone jack on linux.

Do you mean driver? Codecs have nothing to do with the hardware itself. It’s just about what algorithm is used to convert raw audio into a more compact form.

@Simon_Pratt @Kieran_Levin I was able to get my mic input to work:

1 Like

@Atul_Ingle Thank you so much! I’ve added your extra step to the setup instructions.

After enabling the deep sleep my trackpad is not working after wakeup. I have updated the grub settings given in the above post. After laptop is wake up then mouse is not working. I had to restart laptop to make mouse working again.

I am using Ubuntu 21.04 with kernel version 5.11.0-34-generic,

Appreciate some help on this issue.