[RESPONDED] Installation Kali-Linux

How I installed Kali-Linux on a Framework

  1. Prepare an usb for the installation:

  2. Prepeare the Framework for the installation:

    • boot the laptop
    • during the boot click on the F2-button to enter the bios-menu
    • open the security-tab
    • disable secure-boot
    • leave the bios-menu and save the settings by clicking the F10-button
    • power-off the laptop
  3. Start the installation process for Kali-Linux:

    • insert the usb-drive
    • open boot-manager by with the F12-button on the keyboard
    • choose to boot from your usb-drive
    • in the first menu choose “installation”
    • run the whole installation-process
    • reboot
    • install update through the terminal with
      sudo apt update && sudo apt upgrade
    • reboot
  4. Start-up the system and install drivers:

    • open terminal
    • check the current drivers for issues
      • sudo dmesg
      • the issues are marked red
    • if the wifi-driver is missing
    • use the terminal to move the driver-file to the correct folder and reboot
      • sudo mv ~/Downloads/iwlwifi-ty-a0-gf-a0-XX.ucode /lib/firmware
      • sudo reboot
  5. Update the system:

    • open the terminal
    • check for updates and install them
      • sudo apt update
      • sudo apt upgrade

general points:

  • With Linux-Kernel 5.16.0 I had to use iwlwifi-ty-a0-gf-a0-67.ucode as wifi-firmware.
  • If you encounter any issues please tell me. I try to keep the post updated.

But why? You shouldn’t run Kali on Bare Metal.

1 Like

Why shouldn’t I run Kali on Bare Metal? I have specific use cases, where it’s easier to run it directly on the machine.

1 Like

Many reasons, but if you have specific use cases, then go ahead I guess. I just assumed it was a 9 year old script kiddie writing it. Sorry to come across as demeaning if I did.

1 Like

Detailed Linux installation guides are always welcome. Stickied!


Thank you for the detailed instruction. :+1: I’ve been wanting to practice with Kali Linux to pursue a career in penetration testing.

Very grateful to find this here. Thanks, @GeorgeHai. But I’m having serious problems with Etcher.

I’ve been using Ventoy over the past couple of years. On my advice a friend in France bought a Framework laptop, which arrived yesterday. I’d promised her I’d talk her through the installation of Ubuntu. So far so good.

But she’s a Mac user and you can’t (I discovered this morning) set up a Ventoy USB from a Mac. So I fell back on Etcher.

I created a bootable Ubuntu USB on my Hackintosh using Etcher. It fails to boot on my Framework. I recreated it using Etcher on this Framework laptop running Ubuntu. Again, the USB fails to boot. Framework’s elective boot, F12, simply fails to find the USB. It only finds my Ubuntu/Windows dual installation.

F12 finds Ventoy USBs just fine. I can only conclude that on my Hackintosh and on my Framework laptop, Etcher fails to create a bootable USB stick.


Oh, wait…

I could also conclude that my USB stick is somehow faulty!

Let me get back to you on that…


Ok. Thanks a lot for rubber-ducking me on this one. Yes, as I hear you shout back, it was indeed a dud USB stick. Booting nicely now from a shiny SanDisk Ultra.

Thinking it over, I must have allowed myself to be fooled by Etcher’s “Validation” run after the flashing. It leaves you with the impression that Etcher has checked the USB stick and it’s AOK. So the lesson is, don’t necessarily trust the “Validation”. It’s just checking that the code has arrived intact, not that the USB is kosher.

(But I’d still much rather use Ventoy.)


Thanks for the instruction post, helped a lot!

What about AMD RZ616 for Kali Linux

Hi @Gulfam_Rana_Amd I don’t think OP has that device, but if you have, you can try kali live to confirm. fwiw recent kali kernel should support it.

Maybe I’m doing something wrong, but I haven’t been able to get it to work in my VM

I will try it on bare metal soon, but I doubt it would work, so far I tried with nmtui

Do share the errors you’re getting, also the kernel version that kali is using

I tried it earlier and I was missing hardware drivers for wifi during the install with the latest regular linux kernel on baremetal and it listed a bunch but I couldn’t find my AMD RZ616, it also wanted me to plug in a usb with the drivers like windows…

In the VM I never set it up and was mostly hoping for ethernet to work, but that didn’t either and nmtui never showed any networks

I haven’t tried super hard to get it to work, but tails works amazingly and they are both debian distros. Hope there is a way to identify the drivers in tails and add them to other debian distors…